Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Aug 2018, 14:23
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArtfulPup (& Upup-Bionic-Beaver-RC)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 19 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, ..., 47, 48, 49 Next
Author Message
zigbert


Joined: 29 Mar 2006
Posts: 6546
Location: Valåmoen, Norway

PostPosted: Wed 25 Oct 2017, 05:00    Post subject:  

bigpup wrote:
Pmusic-radio streamer

USA stations.
The list of stations has some of them with messed up names.
What makes you think those are USA stations? I checked the '88.75 mhz' station, and I can't find it in the USA-list - but in the Thailand-list. I guess the default western font aren't capable in viewing asian names.

To narrow your search for 'country' in USA, the search-string must contain both words

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3429
Location: Worcestershire, UK

PostPosted: Wed 25 Oct 2017, 05:32    Post subject:  

LateAdopter wrote:
I have noticed that the ldconfig binary is missing. It's odd because ldd is there, and they come from the same package libc-bin.
The cache won't be updated when new packages are installed.

It seems to go into the devx...

The glibc package template is quite complicated but that is probably where it gets removed....

ldconfig is 750KB so quite big....

Which "cache" are we talking about? What's the effect of not updating it?

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
LateAdopter

Joined: 27 May 2011
Posts: 293
Location: Reading UK

PostPosted: Wed 25 Oct 2017, 05:56    Post subject:  

Hlleo peebee
/etc/ld.so.conf defines the paths to be checked for shared libs and /etc/ld.so.cache is where the database is stored for the linker to use. I guess it just speeds up loading dynamic executables.
ldconfig is typically run by a pinst script in a package. Also. I think the Puppy init process runs it in the "next boot will be faster" part if it notices a change in extra SFS.
Back to top
View user's profile Send private message 
Blackbird

Joined: 27 Nov 2012
Posts: 2

PostPosted: Wed 25 Oct 2017, 06:34    Post subject: ZestyPup
Subject description: No brightnes control on my Laptop
 

Greetings all

This is a common issue for me.

For years I have used this fix by

Cadejo - Aug 2013

Copy below into /etc/xdg/templates/_root_.jwmrc AND /root/.jwmrc ,
add it before the first <RootMenu> entries
Code:
<RootMenu label="" labeled="false" height="24" onroot="6">
<Program label="1" icon=""> echo 1 > /sys/class/backlight/acpi_video0/brightness</Program>
<Program label="2" icon=""> echo 2 > /sys/class/backlight/acpi_video0/brightness</Program>
<Program label="3" icon=""> echo 3 > /sys/class/backlight/acpi_video0/brightness</Program>
<Program label="4" icon=""> echo 4 > /sys/class/backlight/acpi_video0/brightness</Program>
<Program label="5" icon=""> echo 5 > /sys/class/backlight/acpi_video0/brightness</Program>
<Program label="6" icon=""> echo 6 > /sys/class/backlight/acpi_video0/brightness</Program>
<Program label="7" icon=""> echo 7 > /sys/class/backlight/acpi_video0/brightness</Program>
</RootMenu>


And add the following into /root/.jwmrc-tray after the "<TaskList/>" entry

Code:
<TrayButton label="" icon="/usr/local/lib/X11/mini-icons/idea16.xpm">root:6</TrayButton>

:

I have managed to get the mini icon to display by copying the icon from another puppy and placing the tray button code into the tray puppy preset
script.

The rest of the code has been entered into the appropriate places.

However when I click on the light-bulb, instead of getting a selection of 1-7 showing the option to "edit bookmarks is displayed .

Does anyone have any ideas how this can be implemented in Zesty please

Thanks in advance
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3429
Location: Worcestershire, UK

PostPosted: Wed 25 Oct 2017, 07:41    Post subject:  

LateAdopter wrote:
Hlleo peebee
/etc/ld.so.conf defines the paths to be checked for shared libs and /etc/ld.so.cache is where the database is stored for the linker to use. I guess it just speeds up loading dynamic executables.
ldconfig is typically run by a pinst script in a package. Also. I think the Puppy init process runs it in the "next boot will be faster" part if it notices a change in extra SFS.

I don't believe either XenialPup or Slacko have ldconfig in the main .sfs - just in the devx....

ldconfig is only called in /etc/rc.d/rc.update for a cross-build...which ArtfulPup is not.

ldconfig is removed in woof-ce 3builddistro line #993

_________________
LxPup = Puppy + LXDE

Last edited by peebee on Wed 25 Oct 2017, 08:27; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
Rangan Masti

Joined: 01 Jan 2013
Posts: 36
Location: Germany, Berlin

PostPosted: Wed 25 Oct 2017, 07:44    Post subject: ArtfulPup  

Hi, good morning.
Good work. Plans for artfulpup 64 bit....
Thank you.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3429
Location: Worcestershire, UK

PostPosted: Wed 25 Oct 2017, 08:28    Post subject: Re: ArtfulPup  

Rangan Masti wrote:
Hi, good morning.
Good work. Plans for artfulpup 64 bit....
Thank you.

None from me - will leave that to somebody else to tackle....

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
watchdog

Joined: 28 Sep 2012
Posts: 1629
Location: Italy

PostPosted: Wed 25 Oct 2017, 08:36    Post subject:  

Artfulpup-plus3 does not boot in frugal install on an external usb hd ext4 formatted with my laptop with errors which end-up to a console. No problem with prior zestypup.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10888
Location: Charleston S.C. USA

PostPosted: Wed 25 Oct 2017, 09:43    Post subject:  

So, what are the errors?
Is this a boot from a complete power off condition?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1629
Location: Italy

PostPosted: Wed 25 Oct 2017, 09:48    Post subject:  

Sorry! I have downloaded again the plus4 iso from the ally's mirror and now it boots. I upgraded the zestypup savefolder and it works with little changements. Perhaps I had problem with the mirrors and I did not check the md5sum.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 10888
Location: Charleston S.C. USA

PostPosted: Wed 25 Oct 2017, 10:11    Post subject:  

zigbert wrote:
bigpup wrote:
Pmusic-radio streamer

USA stations.
The list of stations has some of them with messed up names.
What makes you think those are USA stations? I checked the '88.75 mhz' station, and I can't find it in the USA-list - but in the Thailand-list. I guess the default western font aren't capable in viewing asian names.

To narrow your search for 'country' in USA, the search-string must contain both words

OK!

You must be smarter than the software you are running Shocked Laughing

GUI confusion on my part.

So, country and genre buttons only give you a list of what can be searched for.
Highlighting a listed item does not do anything. Is this what it is suppose to do?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 293
Location: Reading UK

PostPosted: Wed 25 Oct 2017, 10:51    Post subject:  

peebee wrote:
I don't believe either XenialPup or Slacko have ldconfig in the main .sfs - just in the devx....

ldconfig is only called in /etc/rc.d/rc.update for a cross-build...which ArtfulPup is not.

ldconfig is removed in woof-ce 3builddistro line #993

I think you are probably right. I looked at Precise372 and that doesn't have it either. It seems that only 64bit Puppies have it.

The Debian rules say that the postinst and postrm should run it if the package installs shared libraries, but most of the packages I looked in don't have postinst and postrm.

Maybe it wasn't relevant to Puppies using PET packages.

Sorry for the distraction.
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1130
Location: Smithers, BC, Canada

PostPosted: Wed 25 Oct 2017, 12:14    Post subject:  

jrb wrote:
Everything has worked well for me on my HP7800 core2 with one small odd exception. I study a language on https://www.duolingo.com/ using a harddrive installed Palemoon. It works great in Zesty but the last word of each sentence gets cut short in Artful. Some people have reported this on the Duolingo forums but not in Linux. Just throwing this out there in case anybody knows what could cause this. The browser and "/root/.moonchild productions" config file are shared between Zesty and Artful so there is no difference there.


Ok, I tracked down the problem. libpulse.so.0 in Zesty and Artful are different. Even though both list apulse-0.1.10.pet in woof-installed packages, all the libpulse??? files are different. libpulse.so.0 in Artful is a binary while libpulse.so.0 in Zesty is a link to libpulse.so.0.20.1. Simply by pasting in the libpulse from Zesty I have fixed my sound problem.

I tried getting the apulse package in Artful's PPM but it found no package.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3429
Location: Worcestershire, UK

PostPosted: Wed 25 Oct 2017, 14:19    Post subject:  

jrb wrote:
libpulse.so.0 in Zesty and Artful are different. Even though both list apulse-0.1.10.pet in woof-installed packages, all the libpulse??? files are different. libpulse.so.0 in Artful is a binary while libpulse.so.0 in Zesty is a link to libpulse.so.0.20.1. Simply by pasting in the libpulse from Zesty I have fixed my sound problem.

I tried getting the apulse package in Artful's PPM but it found no package.

Hi jrb
By mistake, the build config was installing both full pulseaudio and apulse but due to the alphabetical build order apulse was being overwritten by full pulseaudio.

I've now removed pulseuaudio in Artful so only apulse is built-in.

Light seems to work better with apulse than with pulseaudio but it looks like your program needs pulseaudio which you should be able to install thru ppm - but be aware that Light might not work as well with Youtube videos. If you install pulseaudio then you probably do need to also install a heavyweight browser....

Hope helps
Cheers
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
sszindian


Joined: 24 Apr 2010
Posts: 761
Location: Pennsylvania U.S.

PostPosted: Wed 25 Oct 2017, 19:11    Post subject: Artfulpup & +deltas  

peebee!

Just a quick question on the new Artfulpup?

Are all the latest (I believe 4 of them) '+delta upgrades' included in your latest download-build or must the user add them?

Reason asking... I don't do frugal installs on any puppy's... I do a live CD/DVD with a savefile to the HDD and would like to further test Artfulpup as I liked what I saw in your first build!

'Thanks'

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 19 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, ..., 47, 48, 49 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0857s ][ Queries: 13 (0.0284s) ][ GZIP on ]