Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Nov 2017, 19:21
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Apache OpenOffice
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Author Message
musher0


Joined: 04 Jan 2009
Posts: 11166
Location: Gatineau (Qc), Canada

PostPosted: Wed 13 Apr 2016, 02:30    Post subject:
Subject description: Apache Open Office, v. 4.1.2, for recent 32-bit DPups and Slackos
 

Hello everyone.

I've put together an sfs of apache Open Office 4.1.2, which is the latest version as
of this writing. Available from :
-- https://www.adrive.com/public/NUCwyV/aOO-4.1.2_en-US.sfs --
As you can see from the filename in the link, this one has the US English interface.

~~ Edits ~~
(Our French-speaking colleagues may be interested in the sfs of the French version.
They can access it from here.)

Notes --
# 1: Please note that this sfs is for recent 32-bit Puppies (even running on a 64-bit
computer). Untried on 64-bit Puppies.

# 2: Untried on older Puppies. Works fine on the following: "The Pooch" (so...
should work on most Dpup Wheezies) and Slim-6 (so... should work on recent
Slackos). Experience reports for other "breeds" of Pups are welcome.

End of notes --
~~ End of edits ~~

A peculiarity of this sfs is that it does NOT have the *.desktop file NOR the
symlinks in /usr/bin. So when you'll load this aOO sfs with sfs_load, you will NOT
be shown the familiar launch panel usually presented by sfs_load when it has
finished loading.

The reason I prepared the sfs this way is that the links offered by ex-factory
ApacheOpenOffice are NOT well suited for PuppyLinux:
    -- the default symlinks offer "openoffice" filenames, whereas,
    -- more often than not, the *.desktop files call < soffice -something >. Plus
    -- PuppyLinux does not have the same menu differentiation as other distros, not
    __ exactly the same menu categories.
As a consequence, I redid most of the "desktop-integration" into a separate pet.
Please get it from here:
-- https://www.adrive.com/public/JCY8GX/aOO-4.1.2_dsktp2.pet --

The order in which you install the two files above (the pet for the menu and /usr/bin,
and the sfs) does not matter. However, you have to install BOTH before you can
access the Open Office apps. This reminder may sound silly, but "human RAM
is a device that forgets". You remember that, don't you? Wink

Normally, you should see only one menu entry per OpenOffice application. E.g.
"OpenOffice Writer" under Document, "OpenOffice Calc" under Business, and so on.

This sfs of Apache Open Office will be located under /opt. On first launch, it will
create a user directory at /root/.config/openoffice4. I stongly suggest that you
move this directory to /mnt/home and bring a symlink of it back in place, because
this user directory can get pretty big pretty quickly, especially if you equip your aOO
with major plug-ins and templates.

Any problems, let me know. There shouldn't be any since I have tested it for more
than 10 days, But just in case, so you know that I'm here as a resource.

Enjoy! BFN.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11166
Location: Gatineau (Qc), Canada

PostPosted: Wed 13 Apr 2016, 13:47    Post subject:  

Hello all.

I just did a major edit of the style and contents of the message above.
It may be worth a re-read.

TWYL.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11166
Location: Gatineau (Qc), Canada

PostPosted: Wed 13 Apr 2016, 23:33    Post subject:  

Hello all.

If you need it, you'd download the 64-bit version from:
-- https://www.adrive.com/public/CWRAtf/aOO-4.1.2_amd64_en-GB.sfs --

As mentioned in my post at the top of this page, you'll also have to install the pet
archive for the desktop integration for this aOO 64-bit to work.
This pet for
desktop integration should be "bit-neutral", since there are no executables in it.

Enjoy.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Puppus Dogfellow


Joined: 07 Jan 2013
Posts: 1497
Location: nyc

PostPosted: Thu 14 Apr 2016, 14:45    Post subject:  

mirrored, musher0, thanks:

aOO-4.1.2_amd64_en-GB.sfs
aOO-4.1.2_dsktp2.pet
aOO-4.1.2_en-US.sfs
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11166
Location: Gatineau (Qc), Canada

PostPosted: Thu 14 Apr 2016, 18:19    Post subject:  

My pleasure!
_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11166
Location: Gatineau (Qc), Canada

PostPosted: Thu 14 Apr 2016, 18:41    Post subject:
Subject description: BUG WARNING
 

Hello all.

For the time being, avoid launching OpenOffice with the Quick Start or with the General
Launcher that show up in the "Utility" menu. They somehow freeze the launch.

Launching the individual apps directly (e.g. Writer, from the "Documents" sub-menu)
seems ok.

I'm on it. I'll let you know what I find and possibly a corrective.

For now, the only corrective seems to be to delete the directory at /root/.config/.openoffice4
and to restart one of the aOO application (NOT one of the general launchers).

Thanks for your understanding. BFN.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 21 Aug 2016, 02:53    Post subject: i provide a database of Puppies
Subject description: format csv : just import them in your spreadsheet OpenOffice
 

i provide a database of Puppies in the topic Gnumeric click here format csv that can be used every where. For people who are interested by managing their kennel.
Why not join the tar;gz here ? To make you take a glance at Gnumeric, the perfect clone of EXCEL (better than Excel because bugs corrected)

format csv : just import them in your spreadsheet OpenOffice
Spreadsheet.jpg
 Description   350 puppies only (alive) in my Jukebox
 Filesize   63.58 KB
 Viewed   235 Time(s)

Spreadsheet.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
mikeslr


Joined: 16 Jun 2008
Posts: 2008
Location: 500 seconds from Sol

PostPosted: Mon 23 Oct 2017, 20:53    Post subject: Apache OpenOffice 4.1.3 (32 Bit)  

Just a link to musher0's builds and instructions: http://murga-linux.com/puppy/viewtopic.php?p=971883#971883.

mikesLr

P.S. Note his explanation of why Apache OpenOffice may be superior to LibreOffice if you have to work with Microsoft Office files.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11166
Location: Gatineau (Qc), Canada

PostPosted: Thu 02 Nov 2017, 19:20    Post subject:  

Hello all.

I have put together two sfs's for apacheOpenOffice-4.1.4, out last Oct. 11.
Please follow mikesLr's link above to get the goods!

To save space, I have removed version 4.1.3 from my repo at augras.eu.

The md5, sha1 and sha256 hashes for those sfs's are attached here, however.
I apologize for the apparent complication, but as you may know, security experts
recommend that the hashes not be alongside the archives.

BFN.
Hashes_aOO-414.zip
Description 
zip

 Download 
Filename  Hashes_aOO-414.zip 
Filesize  663 Bytes 
Downloaded  3 Time(s) 

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0491s ][ Queries: 13 (0.0055s) ][ GZIP on ]