Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 19 Nov 2017, 12:37
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
claws-mail
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
sheldonisaac

Joined: 21 Jun 2009
Posts: 693
Location: Philadelphia, PA

PostPosted: Mon 06 Nov 2017, 13:50    Post subject:  claws-mail
Subject description: ver 3.15.1
 

musher0 has made Puppy-compatible versions of claws-mail 3.15.1.

Please see his post in the Puppy Projects area, at
http://murga-linux.com/puppy/viewtopic.php?p=973403#973403

It works fine on this Dell E6410, under musher0's Xenial with 4.1 kernel.
I will try it on other hardware and Puppys, and think he wants people to test and report.

_________________
Dell E6410: Xenial, Slim Slacko 6, LuPu Super 2, Tahr
Dell D610: Windows XP, Puppy Linux 5.2
Intel D865GBF: Tiny Windows 7, Puppy Linux 5.2
Acer Aspire One: Windows XP, Puppy Linux 5.2
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Mon 06 Nov 2017, 14:37    Post subject:  

Tested in stretchpup 700a2 by radky: claws-mail requires the patched openssl 1.0.0 used in ubuntu.

Code:
# claws-mail
claws-mail: /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/lib/i386-linux-gnu/libetpan.so.20)
claws-mail: /usr/lib/i386-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/lib/i386-linux-gnu/libetpan.so.20)


Recompile needed in my opinion.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Mon 06 Nov 2017, 16:22    Post subject:  

Thanks, Sheldon, for creating this thread.

@watchdog: I'm on it! Will double-check, Back in ten. BFN.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Mon 06 Nov 2017, 17:52    Post subject:  

@watchdog:

You're right. I tried Claws-mail 3.15.1 on my DPupStretch-7 (built last
March, not radky's), and it's a no-go. I tried substituting the libetpan 17
library for the libetpan 20 and it doesn't work. Tough for this newest
version, then.

However, the sfs for Claws-mail 3.13.2 loads and runs fine on my
DPupStretch-7. (Please see attached pic.) If you don't need the latest
version, maybe try this one? It's the 2nd file from the bottom in this list:
http://augras.eu/puppy_linux/?dir=musher0/xenialPup-706-k41/Internet

Best I can do ATM, I'm a bit short of time today.

BFN.
Claws-mail-3.13.2-sfs-works-on-DPupStretch7.jpg
 Description   
 Filesize   151.25 KB
 Viewed   94 Time(s)

Claws-mail-3.13.2-sfs-works-on-DPupStretch7.jpg


_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Tue 07 Nov 2017, 01:33    Post subject:  

Yes version 3.13.2 of claws-mail works in stretchpup 700a2 but it has not gpg support. Sylpheed from debian installed by PPM has gpg support. I do not use gpg but I prefer have it in hands.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Tue 07 Nov 2017, 03:36    Post subject:  

watchdog wrote:
Yes version 3.13.2 of claws-mail works in stretchpup 700a2 but
it has not gpg support. Sylpheed from debian installed by PPM has gpg support. I
do not use gpg but I prefer have it in hands.

Hi watchdog.

Correct me if I'm wrong, but DPupStretch-7 does not have the gpg or gpg2
executables. Open a console and type
Code:
whereis gpg
or
Code:
whereis gpg2
: there will be nothing.

According to the Claws-mail [url=http://www.claws-mail.org/plugins.php?
section=downloads]plugins[/url] page, those are required by the PGP plugins. It's not
so much Claws-mail that does not have PGP, it's the Puppy. (XenialPup-7 is in the
same situation.)

Even if Claws-mail-3.13.2 had its PGP plugins, it probably could not use them,
since the gpg or gpg2 execs are not in the Puppy.

I saw that the gpg/gpg2 executables are not in the Pups, and any user can double-
check too --, but I also think that confirmation is needed from someone with
experience of PGP / GPG on Claws-mail.

BFN.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Tue 07 Nov 2017, 09:41    Post subject:  

You can install gpg by PPM: gnupg2, gnupg-agent, libgpgme11, libksba, libpth, pinentry-gtk2 are needed. Then:

Code:
ln -s /usr/bin/pinentry-gtk2 /usr/bin/pinentry


You can import your keys:

Code:
gpg --import /path-to/keys/*


I always managed to install a sylpheed with gpg support.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11156
Location: Gatineau (Qc), Canada

PostPosted: Tue 07 Nov 2017, 12:01    Post subject:  

watchdog wrote:
You can install gpg by PPM: gnupg2, gnupg-agent, libgpgme11, libksba, libpth, pinentry-gtk2 are needed. Then:
Code:
ln -s /usr/bin/pinentry-gtk2 /usr/bin/pinentry


You can import your keys:
Code:
gpg --import /path-to/keys/*

I always managed to install a sylpheed with gpg support.

If you know, why ask? Question

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0428s ][ Queries: 13 (0.0082s) ][ GZIP on ]