Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 12 Dec 2017, 10:28
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
A workable way to install skype 4.3 in puppy
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 18 of 18 [266 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18
Author Message
Mike Walsh


Joined: 28 Jun 2014
Posts: 3208
Location: King's Lynn, UK.

PostPosted: Wed 08 Nov 2017, 18:23    Post subject: Re: An Alternative  

peterw wrote:
Don't want to hijack the topic but I thought that some may find this useful. Whilst Skype is ubiquitous. There are alternatives which have the advantage that you don't need an account and anyone can join and they work well. This is one that I have found. The first web site is the actual site to start the call and the second site is the web site describing it.

https://appear.in/
http://www.makeuseof.com/tag/move-google-plus-hangouts-appear-really-good/


Nice one, Peter. Yah, there's more and more of these sort of webapps coming on-line almost by the day, now. Another apparently by the name of zoom.us works along similar lines ( https://zoom.us/ ); this one, seemingly, geared more toward enterprise customers.

EDIT:- And within the last 24 hrs there's been the announcement of Windows/MacOS/Linux desktop versions of the iOS/Android Signal video-conferencing app.....although this one needs to be 'paired' with the phone app before you can use it. Many of these mentioned make use of real-time WebRTC/HTML5.

We're getting spoilt for choice, aren't we? Laughing


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
snayak

Joined: 14 Sep 2011
Posts: 365

PostPosted: Fri 10 Nov 2017, 02:39    Post subject:  

I am another unlucky to see my skype not allowing me to login. They stopped it on 7th. What to do now?
_________________
[Precise 571 on AMD Athlon XP 2000+ with 512MB RAM]
[Fatdog 611 on Intel Pentium B960 with 4GB RAM]

Home: http://www.mathmeth.com/sn/
Blog: http://srinivas-nayak.blogspot.com/
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2085
Location: Out wandering... maybe.

PostPosted: Fri 10 Nov 2017, 03:06    Post subject:  

Heck, I'm still annoyed Microsoft killed a perfectly workable solution (note: yes, I know it's only text messaging and not really a Skype equivalent, but eh) in favor of the micromanaging they're doing on this platform - MSN Messenger. Rolling Eyes
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * [ Puppy Precise 5.7.1 JP, Frugal install ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3103
Location: The Blue Marble

PostPosted: Fri 10 Nov 2017, 07:19    Post subject:  

peterw suggested appear.in. I've used https://appear.in/ with Chrome. It works well enough. Rather heavy and makes the CPU works harder, but it works.

Another one is https://talky.io/. I haven't used them before.

These two are browser based. You need a recent enough browser with webrtc support.

Someone else suggested https://zoom.us/. I've used this too. You need to download a client for this one. They have clients for 64-bit and 32-bit linux; and I've run them successfully. Sound, video, screen sharing, all works. You just need to edit zoom.sh (the startup script) to make sure it finds the "missing" libraries (not really missing, those libraries in part of firefox or seamonkey so just need to direct it to find it there). A matter of editing LD_LIBRARY_PATH in the zoom.sh script.

Skype is dead.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1495
Location: Italy

PostPosted: Fri 10 Nov 2017, 09:35    Post subject:  

If you still have some credit money on skype account then you can spend it with skype web and a webrtc browser: for old puppies you can use the gtk2 firefox 45.9.0esr.

https://web.skype.com/
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3103
Location: The Blue Marble

PostPosted: Fri 10 Nov 2017, 10:06    Post subject:  

watchdog wrote:
If you still have some credit money on skype account ...
Ah, yes, I forgot we can do that.

Quote:
... then you can spend it with skype web and a webrtc browser: for old puppies you can use the gtk2 firefox 45.9.0esr.

https://web.skype.com/
Glad to know that. Thanks for the enlightenment. I should give that a try.
_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3035
Location: Worcestershire, UK

PostPosted: Fri 10 Nov 2017, 19:42    Post subject:  

Another version....
https://repo.skype.com/deb/pool/main/s/skypeforlinux/

skypeforlinux_8.11.76.3_amd64.deb

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
snayak

Joined: 14 Sep 2011
Posts: 365

PostPosted: Sat 11 Nov 2017, 02:48    Post subject:  

Dear peebee,

Does this skypeforlinux_8.11.76.3_amd64.deb work on puppy?

I did:
Code:

dpkg -x skypeforlinux_8.11.76.3_amd64.deb skypeforlinux-8.11.76.3
dir2sfs skypeforlinux-8.11.76.3

On my Fatdog 611 it generated skype-8.11.76.3_600.sfs.

On invoke, it says:
Code:

/usr/share/skypeforlinux/skypeforlinux: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /usr/share/skypeforlinux/skypeforlinux)
/usr/share/skypeforlinux/skypeforlinux: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.19' not found (required by /usr/share/skypeforlinux/skypeforlinux)
/usr/share/skypeforlinux/skypeforlinux: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /usr/share/skypeforlinux/skypeforlinux)
/usr/share/skypeforlinux/skypeforlinux: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /usr/share/skypeforlinux/libnode.so)
/usr/share/skypeforlinux/skypeforlinux: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /usr/share/skypeforlinux/libnode.so)
/usr/share/skypeforlinux/skypeforlinux: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /usr/share/skypeforlinux/libffmpeg.so)


Sad

How to know which GLIBC and GLIBCXX I have.
And is it safe to upgrade to the demanded versions?

Sincerely,
Srinivas Nayak

_________________
[Precise 571 on AMD Athlon XP 2000+ with 512MB RAM]
[Fatdog 611 on Intel Pentium B960 with 4GB RAM]

Home: http://www.mathmeth.com/sn/
Blog: http://srinivas-nayak.blogspot.com/
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3035
Location: Worcestershire, UK

PostPosted: Sat 11 Nov 2017, 03:01    Post subject:  

snayak wrote:
Does this skypeforlinux_8.11.76.3_amd64.deb work on puppy?

Works on xenialpup64-7.0.8.6....
Your Fatdog is too old Crying or Very sad

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 3103
Location: The Blue Marble

PostPosted: Sat 11 Nov 2017, 06:52    Post subject:  

peebee wrote:
snayak wrote:
Does this skypeforlinux_8.11.76.3_amd64.deb work on puppy?

Works on xenialpup64-7.0.8.6....
Your Fatdog is too old Crying or Very sad

Xenialpup is based Ubuntu Xenial 16.04 LTS. That's only a tad over a year ago.
Fatdog 611 is based on Fatdog 600 which was launched in mid-2012. That is seriously over 5 years ago.

In theory you can get a replacement libc and libstdc++, taking the newer libraries from newer Fatdogs (700 or even 710). But I have never done it myself, and I strongly recommend against it. Doing it is like doing a open-chest heart surgery. You only do it when there is no other choice.

If you can, update to a newer Fatdog (or any other puppies, for that matter).
Otherwise, as watchdog suggested, try gtk2 firefox 45.9.0esr - hopefully it still works.

PS: There is another way, to address exactly the problem you encounter: http://lightofdawn.org/wiki/wiki.cgi/NewAppsOnOldGlibc. But this requires a lot more effort and precision.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
Revolverve

Joined: 08 Nov 2008
Posts: 101
Location: 45°17'24.9"N 72°16'03.2"W

PostPosted: Sat 11 Nov 2017, 14:00    Post subject:
Subject description: out look at skype
 

If you wish to anyway "support" MS/skype ,you dont need to install linux beta alpha (if ever a release you see one day ...),open a free mail account,hotmail,outlook,.live,whatever MS mail service may exist ,there is a ³beta² skype integrated in/aside the mailbox,works better then the last skype4linux or google chrome skype extension I tried.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 18 of 18 [266 Posts]   Goto page: Previous 1, 2, 3, ..., 16, 17, 18
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0642s ][ Queries: 15 (0.0158s) ][ GZIP on ]