Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 18 Jun 2018, 19:23
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy Revitalized as 5.2.8.7 - Nov., 2017 - Final
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 67 of 70 [1036 Posts]   Goto page: Previous 1, 2, 3, ..., 65, 66, 67, 68, 69, 70 Next
Author Message
sheldonisaac

Joined: 21 Jun 2009
Posts: 720
Location: Philadelphia, PA

PostPosted: Sun 10 Dec 2017, 12:19    Post subject:  

rockedge (in part) wrote:
My entire journey into the world of Puppy Linux really got going with Lucid 5.2

Same for me! Thanks a lot to playdayz, and now to Richard!

_________________
Dell E6410: Xenial, etc
Dell Mini 9, Acer Aspire One, EeePC 1018P, PowerBook G4
Intel D865GBF, Intel DQ35JOE

Last edited by sheldonisaac on Sun 10 Dec 2017, 12:36; edited 1 time in total
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 494
Location: Scotland

PostPosted: Sun 10 Dec 2017, 12:27    Post subject:  

I too will miss Lucid. It has always been my favourite puppy.

Regards,

Ken.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1889
Location: Maine, USA

PostPosted: Sun 10 Dec 2017, 14:55    Post subject:  

Thanks for your sentiments about Lucid Pup. But it is not going away. Although its usefulness for browsers is essentially gone, it is still viable as a workstation for documents and other computer activities that don't involve browsers, other than dillo. I plan to release a 20171125 lupulibre version in the spring that contains the final version of LibreOffice 5.4, and maybe the next final LO in the fall if there is any interest in it.

For those needing LibreOffice as an SFS package, I uploaded LO 5.3.7 and the current java package here:
http://www.mediafire.com/file/nquucapcevdg105/LibreOffice-5.3.7_en-US_gz.sfs
b339bda35a3b8d69c71806b713eb5915

http://www.mediafire.com/file/9fqzpyztb282itt/jre-8u152-i586_gz.sfs
c6c4089e9b91f9a0065da43a1e86a6c1
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Wed 13 Dec 2017, 22:22    Post subject:  

The devx download link doesn't work in quickpet.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Thu 14 Dec 2017, 00:25    Post subject: Re: Lucid Puppy Revitalized as 5.2.8.7 - Nov., 2017 - Final
Subject description: Lupu-528-005 upgraded with recent versions of many components.
 

I found a version of devx and kernal sources at the following link:

http://shinobar.server-on.net/puppy/lupu/

but I don't know if it is the right version.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Thu 14 Dec 2017, 01:44    Post subject:  

Is there a way to enable copy and paste on the Dillo browser. The Dillo browser would be much more usefull if I could copy links and text from it to seamonkey.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Thu 14 Dec 2017, 02:14    Post subject: Re: Links to Supplemental (pet, sfs) Packages  

rerwin wrote:
Development Support, Proprietary
[b]Kernel Source


This is probably what I was looking for in my previous post.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Thu 14 Dec 2017, 02:51    Post subject: Re: Links to Supplemental (pet, sfs) Packages  

delete
Back to top
View user's profile Send private message 
tallboy


Joined: 21 Sep 2010
Posts: 978
Location: Oslo, Norway

PostPosted: Thu 14 Dec 2017, 13:11    Post subject:  

Hi s243a.
From https://www.dillo.org/dillo2-help.html:
Quote:
Copy&Paste:
Just hold down the left mouse button and move to select the area to copy. To paste, go to the target application and press the middle mouse button.
If you want to select more than one screen, hold the mouse button down and scroll with PgUp, PgDn or the arrow keys.
If you want to paste an URL into Dillo, do it on the "clear-URL" button (the "X" next to the location bar).
Note: If it doesn't work, please try again. There's a bug lurking there.

The bold text is my emph., the text is from the manual! Very Happy

If you don't have a .dillorc file, you can copy this one to /root if you want to make some modifications:
https://www.dillo.org/dillo-2.x/dillorc

tallboy

Addition: from line 20 or thereabout in .dillorc:
Quote:
# Mouse middle click by default drives drag-scrolling.
# To paste an URL into the window instead of scrolling, set it to NO.
# Note: You could always paste the URL onto the URL box clear button.
#middle_click_drags_page=YES

BTW:
And I found both /etc/dillo/dillorc and /usr/etc/dillo/dillorc in my Lucid 5.2.8.7, no wonder things may be hard to set. According to the man page, user mods should be found in /root/.dillo/dillorc, not just /root/.dillorc as I suggested above.

_________________
True freedom is a live Puppy on a multisession CD/DVD.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Fri 15 Dec 2017, 02:22    Post subject: Re: Release Candidate 20171110
Subject description: For lupu, sulu2 & sulu4, so far
 

rerwin wrote:
After experimenting with the various browsers provided in this thread I conclude that only seamonkey-2.46 is reliable with lucid pup. Even with 2.46, flashplayer issues some warnings that do not seem to impact its operation. SM-2.48 and Palemoon require at least the glibc 2.19 upgrade of the glib components but issue some warnings or errors when used with add-ons.

no-script installs on palmoon without issue, which isn't available in the version of seamonkey that comes with your latest iso.

Quote:
Furthermore, sylpheed 3.4.1 issues error messages and OpenSSL seems to cause problems with other programs rejecting newer versions of some library components.

I got your palemoon pet working. I'll let you know if I get this error.

Quote:
To maintain Lucid Pup's reputation for stability, I omit the upgrades that provide or require library components beyond those provided by the Lucid repos.

Makes sence but I like palemoon so I installed those upgrades. Smile

Quote:
However, the glibc219 and palemoon installer packages are available (see below) for those accepting the limitations of seamonkey 2.48 and palemoon in the lucid environment.

Did this and it worked Very Happy. Thankyou very much Smile

Quote:
I expect this to be the final release of lucid pup 5.2.8.7 unless there are last-minute patches.

I see that ISOs have been updated since I read this post so I expect another version is brewing.


Quote:
It is intended for those installations that don't need the latest browsers or cannot be upgraded to a newer Puppy due to hardware constraints. Because of the browser situation, I feel it is time to move on to XenialPup or some other relatively new Puppy. I plan to migrate to Xenial 7.0.9 for my own use, but am open to other recommendations.

Quite a jump in versions but it makes since as long as your computer isn't too old. That said, Lupu is awesome and tahrpup is still quite fresh.

Quote:
I view the new release as a a "release candidate", to allow for fixes. So, please report any issues that should be corrected for this final version.

I'll let you know. P.S. how do I disable the touchpad?
Quote:

The 20171110 release disk images are here:
http://www.mediafire.com/?5il6yef4h3sdj


xTo add support for seamonkey 2.48+ and palemoon, install glibc219_runtime and (optionally) palemoon_installer (which installs SSE version where necessary):


As a note when I first tried these pets it didn't work. I did strace palemoon and realized that it never installed but the installer thought it did. Not sure if it was some random quirk with my system or a legit bug. Anyway, if it helps I first tried the palemoon installer from the menu. After doing an strace and realizing it wasn't there I tried it from the command line. Palmoon thought it was already installed, so I selected uninstall from the installer and for good measure I ran one of the uninstall scripts from the package folder. I than ran the install script from the command line, selected the latest version of palemoon and it worked Smile. Actually palemoon so far seems to be running better for me on lupu than it has on tahrpup but that's probably just because I haven't used it for that long on lupu.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1889
Location: Maine, USA

PostPosted: Fri 15 Dec 2017, 14:49    Post subject:  

s243a,
Thanks for reporting your experiences with the new release. As a result of your comments about the palemoon installer, I have updated its version to 20171215, which eliminates the initial message about palemoon being already installed. I recommend that anyone who has downloaded the earlier version (15 downloads) replace it, to avoid that annoyance. (The link is on the previous page.)

Regarding disabling the touchpad:
    menu > Desktop > Desktop Settings > FlSynclient configure your touchpad

    Click OK, then restart X (menu > Shutdown > Restart X server).

    menu > Desktop > Desktop Settings > FlSynclient configure your touchpad

    Set 'Touchpad Mode' to Off, then click Save button and then Quit button.
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 494
Location: Scotland

PostPosted: Sat 16 Dec 2017, 08:49    Post subject:  

Hello All,
I'd just like to bump my posts which are the 7th and 8th one down in the link below.

http://murga-linux.com/puppy/viewtopic.php?t=90461&start=975

I've quoted them here.

Quote:
I have downloaded some you tube videos as mp4 files using youtube-dl. They play using lupusuper2-5.2.8.7-k3.2.48-20161228 but they don't play on lupusuper2-5.2.8.7-k3.2.48-20171110 or lupusuper1-5.2.8.7-k3.0.25-20171125.
I assume this might be something to do with the updates unless I am missing something. They also play on presice 5.7.1 and racy 5.5. I did try installing vlc 1.1.10. to lupusuper2-5.2.8.7-k3.2.48-20171110 but they did not play on vlc either. The videos were downloaded in the last week so not something I've had on my drive for a long time. I'd be grateful for any help.


Mplayer appears showing "loading" then within a second or so goes to "stopped"

I've looked at rerwin's list of updated packages and it does not include mplayer. Could this be due to the updating of another package.

I also have problems with pup radio/tv.

Quote:
Has anybody got pup radio/tv to work. I am using sulu 002 (the most recent version) with known working urls. This is what I get running in a terminal.

Code:
GMLIB-Message: after init: position=0.000 length=0.000 start_time=0.000 run_time=0.000 volume=0.00 player=dead media=unknown uri=


I have this running in the last version of sulu 002 using the same url. Here is the url

Code:
http://bbcmedia.ic.llnwd.net/stream/bbcmedia_radio1_mf_p|BBC Radio 1


These problems are stopping me using the recent update of sulu 002.

Can anybody please reply if only to tell me I'm doing something stupid or better still a solution.
Thanks in advance.

Regards,

Ken.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Sat 16 Dec 2017, 15:50    Post subject:  

keniv wrote:
Hello All,
I'd just like to bump my posts which are the 7th and 8th one down in the link below.

http://murga-linux.com/puppy/viewtopic.php?t=90461&start=975

I've quoted them here.

Quote:
I have downloaded some you tube videos as mp4 files using youtube-dl. They play using lupusuper2-5.2.8.7-k3.2.48-20161228 but they don't play on lupusuper2-5.2.8.7-k3.2.48-20171110 or lupusuper1-5.2.8.7-k3.0.25-20171125.
I assume this might be something to do with the updates unless I am missing something. They also play on presice 5.7.1 and racy 5.5. I did try installing vlc 1.1.10. to lupusuper2-5.2.8.7-k3.2.48-20171110 but they did not play on vlc either. The videos were downloaded in the last week so not something I've had on my drive for a long time. I'd be grateful for any help.


Mplayer appears showing "loading" then within a second or so goes to "stopped"

I've looked at rerwin's list of updated packages and it does not include mplayer. Could this be due to the updating of another package.

I also have problems with pup radio/tv.

Quote:
Has anybody got pup radio/tv to work. I am using sulu 002 (the most recent version) with known working urls. This is what I get running in a terminal.

Code:
GMLIB-Message: after init: position=0.000 length=0.000 start_time=0.000 run_time=0.000 volume=0.00 player=dead media=unknown uri=


I have this running in the last version of sulu 002 using the same url. Here is the url

Code:
http://bbcmedia.ic.llnwd.net/stream/bbcmedia_radio1_mf_p|BBC Radio 1


These problems are stopping me using the recent update of sulu 002.

Can anybody please reply if only to tell me I'm doing something stupid or better still a solution.
Thanks in advance.

Regards,

Ken.


I can confirm this error: Here is what I get
Code:

palemoon &> bla.txt
/usr/local/bin/palemoon: line 39: 30534 Bus error
 /usr/lib/glibc219/lib/ld-linux.so.2 --library-path /usr/lib/glibc219/lib:/usr/lib/glibc219/usr/lib:/usr/lib/glibc219/libstdc++:/usr/X11R7/lib:$PMDIR $PMDIR/palemoon "$@"


Randome guess of what might be the issue:
1. Maybe it is looking for the libraries in the wrong spot
2. Maybe we need to update dbus.

Let's try an strace next and see if I can make sence of the output.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Sat 16 Dec 2017, 17:07    Post subject:  

When palemoon starts up we seem to be missing a bunch of libraries. I'm not sure if any of this has to do with youtube error, since this happens before youtube shuts down palemoon but here is part of the strace output:

Code:

execve("/usr/local/bin/palemoon", ["palemoon"], [/* 53 vars */]) = 0
brk(0)                                  = 0x8144000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap2(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7721000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/lib/tls/i686/sse2/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/i686/sse2/cmov", 0xbff16c50) = -1 ENOENT (No such file or directory)
open("/lib/tls/i686/sse2/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/i686/sse2", 0xbff16c50) = -1 ENOENT (No such file or directory)
open("/lib/tls/i686/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/i686/cmov", 0xbff16c50) = -1 ENOENT (No such file or directory)
open("/lib/tls/i686/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/i686", 0xbff16c50)     = -1 ENOENT (No such file or directory)
open("/lib/tls/sse2/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/sse2/cmov", 0xbff16c50) = -1 ENOENT (No such file or directory)
open("/lib/tls/sse2/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/sse2", 0xbff16c50)     = -1 ENOENT (No such file or directory)
open("/lib/tls/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls/cmov", 0xbff16c50)     = -1 ENOENT (No such file or directory)
open("/lib/tls/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/tls", 0xbff16c50)          = -1 ENOENT (No such file or directory)
open("/lib/i686/sse2/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/i686/sse2/cmov", 0xbff16c50) = -1 ENOENT (No such file or directory)
open("/lib/i686/sse2/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/i686/sse2", 0xbff16c50)    = -1 ENOENT (No such file or directory)
open("/lib/i686/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/i686/cmov", {st_mode=S_IFDIR|0755, st_size=64, ...}) = 0
open("/lib/i686/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/i686", {st_mode=S_IFDIR|0755, st_size=27, ...}) = 0
open("/lib/sse2/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/sse2/cmov", 0xbff16c50)    = -1 ENOENT (No such file or directory)
open("/lib/sse2/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/sse2", 0xbff16c50)         = -1 ENOENT (No such file or directory)
open("/lib/cmov/libncurses.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/lib/cmov", 0xbff16c50)         = -1 ENOENT (No such file or directory)
open("/lib/libncurses.so.5", O_RDONLY)  = 3
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1067

PostPosted: Sat 16 Dec 2017, 22:28    Post subject:  

Here is a partial hack: I didn't do everything from the command so forgive me if I make any mistakes in the commands below. Note that I've encapsulated the result in a pet.

create the folder
Code:

mkdir /lib/tls
ln -s /lib/i686 /lib/tls/i686
ln -s /lib/i686 /lib/i686/sse2
ln -s /usr/lib/glibc219/lib/libncurses.so.5 /lib/i686/cmov/libncurses.so.5
ln -s /opt/palemoon /usr/local/palemoon


I'll have to test this on a fresh install to see if it works. If anyone is going to try this then please try it on a fresh install first.
fake_se.zip
Description 
zip

 Download 
Filename  fake_se.zip 
Filesize  880 Bytes 
Downloaded  51 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 67 of 70 [1036 Posts]   Goto page: Previous 1, 2, 3, ..., 65, 66, 67, 68, 69, 70 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2025s ][ Queries: 15 (0.1348s) ][ GZIP on ]