Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 16 Aug 2018, 14:33
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How can I upgrade to cups 1.7.5?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
number77

Joined: 22 Oct 2010
Posts: 646

PostPosted: Mon 18 Dec 2017, 14:29    Post subject:  How can I upgrade to cups 1.7.5?  

Hello
I have tahr605 frugal installed on a dell vostro 1320, 2.2ghz,2gb ram. I am trying to add printer drivers but the cups site (http:/localhost:631) is giving me an error of, 500 internal server error. I am trying to install a dell 3000cn and a sharp ar-m201. Is this the right way or has cups site moved.
Any help would be appreciated.
Thanks
number77

Last edited by number77 on Tue 19 Dec 2017, 04:06; edited 1 time in total
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2112
Location: Maine, USA

PostPosted: Mon 18 Dec 2017, 17:39    Post subject:  

Are you sure cups is running?

try
Code:
ps -auxw | grep cups
in a terminal

if it's not running, try
Code:
/etc/init.d/cups start

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Slacko
Currently using full install: DebianDog
Back to top
View user's profile Send private message Visit poster's website 
Galbi


Joined: 21 Sep 2011
Posts: 1046
Location: Bs.As. - Argentina.

PostPosted: Mon 18 Dec 2017, 17:53    Post subject:  

If you look here, you'll see that is very common problem.
https://cse.google.com/cse?cx=015995643981050743583%3Aabvzbibgzxo&q=500+internal+server+error.&sa=Search&cof=FORID%3A0#gsc.tab=0&gsc.q=500%20internal%20server%20error.&gsc.page=1

I ended changing for another Puppy. Currently using LxPupSC, CUPS works fine.

Saludos.

_________________
Remember: "pecunia pecuniam parere non potest"
Back to top
View user's profile Send private message 
number77

Joined: 22 Oct 2010
Posts: 646

PostPosted: Tue 19 Dec 2017, 02:03    Post subject:  

trapster wrote:
Are you sure cups is running?

try
Code:
ps -auxw | grep cups
in a terminal

if it's not running, try
Code:
/etc/init.d/cups start

This is what I got.
root# ps -auxw | grep cups
root 6504 0.0 0.0 6376 2856 ? Ss 05:47 0:00 /usr/sbin/cupsd -C /etc/cups/cupsd.conf
root 10986 0.0 0.0 4136 800 pts/1 S+ 05:51 0:00 grep cups
root# /etc/init.d/cups start
cups: started scheduler.
I do still get server error though.
Back to top
View user's profile Send private message 
number77

Joined: 22 Oct 2010
Posts: 646

PostPosted: Tue 19 Dec 2017, 02:17    Post subject:  

Galbi wrote:
If you look here, you'll see that is very common problem.
https://cse.google.com/cse?cx=015995643981050743583%3Aabvzbibgzxo&q=500+internal+server+error.&sa=Search&cof=FORID%3A0#gsc.tab=0&gsc.q=500%20internal%20server%20error.&gsc.page=1

I ended changing for another Puppy. Currently using LxPupSC, CUPS works fine.

Saludos.

Thanks. I will try other puppies that I have but I think it is too complex for me.
Back to top
View user's profile Send private message 
number77

Joined: 22 Oct 2010
Posts: 646

PostPosted: Tue 19 Dec 2017, 04:04    Post subject:  

Hello
Cups works fine on the same laptop but with tahr64 605 and version 1.7.5, the cups on the 32 bit tahr has 1.4.8 and does not.
How can I upgrade to 1.7.5.
Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 1020

PostPosted: Tue 19 Dec 2017, 11:59    Post subject:  

The current version of cups is:
Package: cups (1.7.2-0ubuntu1.8)
https://packages.ubuntu.com/trusty-updates/cups
The procedure is simple and straightforward - download and install it together with its dependencies. Have a look at that red dot depends list in the above link - the list seems to be huge but not all of them are needed.

However, you should first upgrade your glibc - did you do that? That thread is marked solved:
http://murga-linux.com/puppy/viewtopic.php?p=975714#975714
Back to top
View user's profile Send private message 
number77

Joined: 22 Oct 2010
Posts: 646

PostPosted: Tue 19 Dec 2017, 12:34    Post subject:  

anikin wrote:
The current version of cups is:
Package: cups (1.7.2-0ubuntu1.8)
https://packages.ubuntu.com/trusty-updates/cups
The procedure is simple and straightforward - download and install it together with its dependencies. Have a look at that red dot depends list in the above link - the list seems to be huge but not all of them are needed.

However, you should first upgrade your glibc - did you do that? That thread is marked solved:
http://murga-linux.com/puppy/viewtopic.php?p=975714#975714

Anikin
That is well beyond my capabilities.
Back to top
View user's profile Send private message 
anikin

Joined: 10 May 2012
Posts: 1020

PostPosted: Tue 19 Dec 2017, 12:51    Post subject:  

Give me some time and I'll post a little howto on upgrading Puppy packages using Debian/Ubuntu repositories.
Back to top
View user's profile Send private message 
number77

Joined: 22 Oct 2010
Posts: 646

PostPosted: Tue 19 Dec 2017, 13:54    Post subject:  

anikin wrote:
Give me some time and I'll post a little howto on upgrading Puppy packages using Debian/Ubuntu repositories.

Thanks that would be a help
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0727s ][ Queries: 14 (0.0077s) ][ GZIP on ]