Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Oct 2018, 21:39
All times are UTC - 4
 Forum index » Off-Topic Area » Security
Meltdown exploit proof-of-concept
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
fabrice_035


Joined: 28 Apr 2014
Posts: 499
Location: Bretagne / France

PostPosted: Sun 14 Jan 2018, 06:47    Post subject:  Meltdown exploit proof-of-concept
Subject description: can't try : compile error (for 64-bit only?
 

Hi,

And now, the POC https://github.com/iaik/meltdown

edit: yet another https://github.com/paboldin/meltdown-exploit

I can't compil, obscur error ( gcc version for x86 ? )

Code:

 make
make -C libkdump
make[1]: Entering directory `/root/Downloads/meltdown-master.zip.extracted/meltdown-master/libkdump'
gcc -c -fPIC libkdump.c -o libkdump.o -O3 -pthread -Wno-attributes
libkdump.c: In function ‘libkdump_read_tsx’:
libkdump.c:97:3: error: inconsistent operand constraints in an ‘asm’
   asm volatile("xor %%eax, %%eax\n"                                           \
   ^
libkdump.c:119:18: note: in expansion of macro ‘meltdown_nonull’
 #define MELTDOWN meltdown_nonull
                  ^
libkdump.c:478:7: note: in expansion of macro ‘MELTDOWN’
       MELTDOWN;
       ^
make[1]: *** [libkdump.o] Error 1
make[1]: Leaving directory `/root/Downloads/meltdown-master.zip.extracted/meltdown-master/libkdump'
make: *** [libkdump/libkdump.a] Error 2




Code:
root# ldd --version
ldd (Ubuntu EGLIBC 2.19-0ubuntu6.9) 2.19

gcc --version
gcc (Ubuntu 4.8.4-2ubuntu1~14.04.3) 4.8.4




Question [/code]
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1543

PostPosted: Sun 14 Jan 2018, 09:55    Post subject:  

I think the problem with these things is that they just ASS-U-ME everyone is running a 64-bit OS, and they think 32-bit is obsolete or non-existent, so they don't bother to tell you this before you download. I had the same problem dealing with Discord Staff, they finally changed their website to say "64-bit Linux required" in tiny writing so you don't download the entire thing for nothing then get some strange error like "Illegal instruction" "Segmentation Fault" "Wrong ELFCLASS" etc.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Off-Topic Area » Security
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0322s ][ Queries: 14 (0.0063s) ][ GZIP on ]