Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 16 Aug 2018, 16:06
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Blacksmith
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
labbe5

Joined: 13 Nov 2013
Posts: 1271
Location: Canada

PostPosted: Wed 31 Jan 2018, 07:04    Post subject:  Blacksmith
Subject description: free Linux tool to detect Meltdown vulnerability exploitations
 

https://www.sentinelone.com/blog/sentinelone-releases-free-linux-tool-detect-meltdown-vulnerability-exploitations/

This is a race that the security industry needs to run together in order to win – which is why SentinelOne today is releasing a new free tool to prevent Meltdown exploitation while the patching process catches up.

Dubbed Blacksmith, this tool detects the attempted exploitation of Meltdown vulnerability on all Linux systems, empowering Linux admins to stop attacks before they take root.


There are two key factors for why we chose to prioritize the Linux version of this tool. First, because Linux is very susceptible to such attacks as there is no comprehensive solution available. And second, Linux is the preferred OS of the world’s top supercomputers and therefore, is a high-value target for attackers. Together, these reasons made it clear that it was critical to help secure Linux environments as quickly and effectively as possible right now.

For system administrators : https://www.sentinelone.com/wp-content/uploads/2018/01/s1-blacksmith.zip
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2520
Location: 500 seconds from Sol

PostPosted: Wed 31 Jan 2018, 11:25    Post subject: Requires lib -- may run under artful or stretch  

Hi Tried to run it under Xenialpup64. ldd reported:

"/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.22' not found (required by /mnt/home/my-stuff/temp1/s1-blacksmith.zip.extracted/s1-blacksmith)
libstdc++.so.6 (GLIBCXX_3.4.22) => not found"

Xenialpup64 already included libstdc++.so.6. So blacksmith is looking for a different version of that lib; perhaps newer and, thus, possibly found under artful or stretch.

mikesLr
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Security/Privacy
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0243s ][ Queries: 12 (0.0026s) ][ GZIP on ]