Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 May 2018, 09:15
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
transmission not working
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
chimnya123

Joined: 19 Jul 2014
Posts: 17

PostPosted: Sun 11 Feb 2018, 02:35    Post subject:  transmission not working
Subject description: torrent not downloading
 

hi i m running fatdog64 721from pendrive. i have also created savefile on my hdd.when i use transmission to download any torrent thru magnet link it does not start download even if there are seeders and leechers.i have googled the issue and according to that i have ticked 'pick a random port everytime' box in 'preferences'-'network tab' also.then i added extra trackers also from 'add tracker url.'but 'property' tab shows no peers and under the tracker tab all connections getting failed.
then i have tried ctorrent (which is another bittorrent client )from terminal emulator also, but it isn't working either.
so is fatdog not allowing me to download any torrents?
i don't understand the problem pl help me
Back to top
View user's profile Send private message 
drunkjedi


Joined: 24 May 2015
Posts: 885

PostPosted: Sun 11 Feb 2018, 04:39    Post subject:  

Hi friend,
I think you may need to tinker with Fatdog's Firewall.

But I am not sure.
Try asking in Fatdog's thread.
http://murga-linux.com/puppy/viewtopic.php?p=982708#982708
Back to top
View user's profile Send private message 
chimnya123

Joined: 19 Jul 2014
Posts: 17

PostPosted: Mon 12 Feb 2018, 06:30    Post subject:  

Hi drunkjd,I untick 'eztables firewall' from 'control panel' and disabled it , now transmission working fine.so now I have to configure rules in firewall cfg file.do you have configured them? FAQs in fatdog menu shows some of rules and examples but, as i m not expert I don't fully understand that. So for allowing transmission thru firewall what should I do?
Back to top
View user's profile Send private message 
drunkjedi


Joined: 24 May 2015
Posts: 885

PostPosted: Mon 12 Feb 2018, 10:36    Post subject:  

I have not configured the firewall, I don't know much about it.
Ask on fatdog's thread.
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2108
Location: Maine, USA

PostPosted: Mon 12 Feb 2018, 17:32    Post subject:  

Try these in a console

Code:
iptables -A INPUT -m state --state RELATED,ESTABLISHED -p udp --dport 51413 -j ACCEPT
iptables -A OUTPUT -p udp --sport 51413 -j ACCEPT

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Slacko
Currently using full install: DebianDog
Back to top
View user's profile Send private message Visit poster's website 
chimnya123

Joined: 19 Jul 2014
Posts: 17

PostPosted: Wed 14 Feb 2018, 23:34    Post subject:  

hi trapster , thanx for helping me
i tried above commands in consol and then i enabled firewall, but -no luck .also i first enabled firewall and then tried these commands, but again -no luck
when i go to transmission/preferences/network/port for incoming peers- 'test port '51413 (or any no.) then its showing me 'port is closed'
what can i do
Back to top
View user's profile Send private message 
drunkjedi


Joined: 24 May 2015
Posts: 885

PostPosted: Thu 15 Feb 2018, 00:35    Post subject:  

Hey chimnya123,
It would be easier for trapster to help you if you post the output of command
Code:
iptables -L -n
With the firewall running, so that he will know all the rules set.

Also I think you should untick the 'pick a random port everytime' box in 'preferences'-'network tab' of transmission, and let it use the port 51413 as in the commands given by trapster.
I am just guessing here. All that stuff goes over my head.
Back to top
View user's profile Send private message 
drunkjedi


Joined: 24 May 2015
Posts: 885

PostPosted: Thu 15 Feb 2018, 00:42    Post subject:  

Hey Chimanya123,

Did you by any chance restart eztables after executing the commands trapster gave?
That would revert the changes made.
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2108
Location: Maine, USA

PostPosted: Thu 15 Feb 2018, 18:02    Post subject:  

I don't use fatdog and I'm not sure of the formatting for the firewall cfg file.

Look at what I posted and some of the examples for the cfg file. You should see a pattern Smile

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Slacko
Currently using full install: DebianDog
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0496s ][ Queries: 14 (0.0205s) ][ GZIP on ]