Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 17 Oct 2018, 19:00
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Puppy package update manager
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Author Message
slavvo67

Joined: 12 Oct 2012
Posts: 1570
Location: The other Mr. 305

PostPosted: Sat 11 Oct 2014, 13:39    Post subject:  

A few items and suggestions if I may:

I initially thought the updater wasn't working correctly.

It read: Package "$name" is at version "$version" on multiple lines.

Jasper made a good point, with a pause at 20% and so on up to 100%.

My update required many items to be updated. The interactive window requiring "OK" became an annoyance, after the first few updates. It would be nice to have this automated, without the pop-ups.

As someone mentioned earlier, it would be nice to choose which items you want to update.

Additional note: It appears I lost at least a few menu entries. This may or may not be related to the actual packages that were updated but specifically, my Opera and Seamonkey menu items disappeared. They still work from terminal. I may have lost other menu items but I haven't taken a full inventory. Running OV Precise 5.8

Best,

Slavvo67
Back to top
View user's profile Send private message 
linus.cl

Joined: 02 Apr 2014
Posts: 127
Location: Germany

PostPosted: Wed 26 Nov 2014, 09:56    Post subject:  

Thank you for tips!

Now you can choose which update do you want to install.
I made a new version with gtkdialog. It looks really better.
There is one Main Window.
Many thanks to zigbert: http://murga-linux.com/puppy/viewtopic.php?t=38608 and LazY Puppy http://murga-linux.com/puppy/viewtopic.php?t=96575

Try it out and report errors! Smile Very Happy

P.S.: xanad: I think your language pack isn't working with the new version. Unfortunately. Sad But many thanks for your help!

bigpup: Do you really think packages like firefox ... needn't an update?
Maybe we can choose some packages which needs an update and search especially for them.
screenshot_updatemanager_2014-11-26_145508.png
 Description   
 Filesize   65.17 KB
 Viewed   405 Time(s)

screenshot_updatemanager_2014-11-26_145508.png

updatepuppy.tar.gz
Description  Puppy Update Manager 3
gz

 Download 
Filename  updatepuppy.tar.gz 
Filesize  2.09 KB 
Downloaded  211 Time(s) 

Last edited by linus.cl on Wed 26 Nov 2014, 15:44; edited 3 times in total
Back to top
View user's profile Send private message Visit poster's website 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Wed 26 Nov 2014, 13:16    Post subject:  

You should continue to increase/use version number (so: Update Manager 3 etc.pp.) and put it always into the first post or even -at least- put a link to it in first post.

Pretty cool, the tree example is working for you. Cool

RSH

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
linus.cl

Joined: 02 Apr 2014
Posts: 127
Location: Germany

PostPosted: Wed 26 Nov 2014, 13:32    Post subject:  

linus.cl wrote:

Many thanks to zigbert: http://murga-linux.com/puppy/viewtopic.php?t=38608 and LazY Puppy http://murga-linux.com/puppy/viewtopic.php?t=96575


Yes, it is working! Very Happy

Thank you for the help!
Back to top
View user's profile Send private message Visit poster's website 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Wed 26 Nov 2014, 21:45    Post subject:  

You probably want to sort your list in alphabetical order?
Code:
sort -u YourList > YourListSortedTemp
cp -af YourListSortedTemp YourList
rm -f YourListSortedTemp

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
J. L.

Joined: 05 Mar 2010
Posts: 26

PostPosted: Sat 20 Dec 2014, 03:39    Post subject:  

Thank you very much for this revolutionary script. So far, I haven't seen anything broken on Tahrpup 6.0 CE. Good job!
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11129
Location: Charleston S.C. USA

PostPosted: Sat 20 Dec 2014, 05:21    Post subject:  

Puppy Update Manager 3

Tahrpup 6.0 CE
Frugal install on hard drive
Save directory

It is listing as newer package versions of programs ones that are older than the ones installed in Tahrpup.
So, it is not finding newer packages, but older packages.

Example:
Programs already installed in Tahrpup that are newer than those listed as updates.

Pup-sysinfo V2.5.2
Peasyglue V1.8
Paverecord V9.0.5
Gtk-chtheme V2.0
etc...
Too many to list.

And for these:
PeasyPDF V3.1 wants to update to the same version.
Galculator V1.3.4 wants to update to the same version.

So this program script is not working for me.
All it seems to do is offer older versions of programs or the same version.

See image
capture807.png
 Description   
 Filesize   51.01 KB
 Viewed   290 Time(s)

capture807.png


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
J. L.

Joined: 05 Mar 2010
Posts: 26

PostPosted: Sat 20 Dec 2014, 08:46    Post subject:  

Mine is a full install, and I haven't double-checked the versions. Guess I spoke too soon, because it offered me pretty much the same packages again on second run after reboot... Then said my system is updated immediately.

*Oh I see, it updates one at a time and you have to select each one. Also accidentally got the older version.

*Already noticed an issue, I got another HDD space indicator. Didn't bother testing further, it's obvious this needs more polish and official integration.

*Premature thoughts banished, I now see what to do. Install only the essentials not part of puppy's backbone, and this tool is perfect for reporting that. Thanks!
Back to top
View user's profile Send private message 
xyz

Joined: 17 Mar 2018
Posts: 22

PostPosted: Sun 15 Apr 2018, 13:57    Post subject: nice with legopen unicorn  

nice with legopen unicorn
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2442s ][ Queries: 15 (0.1177s) ][ GZIP on ]