Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 10 Dec 2018, 10:53
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Precise not seeing savefile during boot (Solved!)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
a_salty_dogg


Joined: 15 Dec 2013
Posts: 140

PostPosted: Wed 18 Apr 2018, 19:51    Post subject:  Precise not seeing savefile during boot (Solved!)  

Brief back-story first...

Trying to build a dedicated drive containing all my "modern" pups, namely Tahr 6.03, Precise 5.71, Slacko 5.7, Slacko 6.3.0, and to share all super-large programs (e.g. browsers, mediaplayers) between them in common where compatible, in order to try and keep my savefiles down to a reasonable size.

Reformatted a flash drive to ext2 and created a separate folder for each puppy into which I copied all base files & a savefile for each, plus files exclusive to each distro (like devx files) then copied those large common files into home and linked where appropriate.

Grub4Dos sees all 4 puppies correctly just as it should and has been installed on this drive only, which works fine with my BIOS.

Tahr and Slackos all load and run just as I'd hoped, except the one problem is when trying to boot into Precise, it refuses to see the savefile on this drive; finds any other precisesave.2fs's anywhere around my system and proceeds to load if only one, or offer the choice if more, but will not see the one on this drive!
If I temporarily rename any others leaving only this one available, it still doesn't see it but goes on to load Precise this time in RAM.

Sorry if this was all TMI, any ideas for a solution please, or where I can maybe find a log file to explain what's happening?

Last edited by a_salty_dogg on Thu 19 Apr 2018, 01:28; edited 2 times in total
Back to top
View user's profile Send private message 
a_salty_dogg


Joined: 15 Dec 2013
Posts: 140

PostPosted: Wed 18 Apr 2018, 20:01    Post subject:  

Oh, at one stage I also tried to create a small "fake" 32 MB savefile in the folder, when closing down after running in RAM, hoping to make some sort of path for the boot sequence to follow, with intention of overwriting that with a proper savefile later, but no luck, Precise didn't see that either on reboot!
Back to top
View user's profile Send private message 
a_salty_dogg


Joined: 15 Dec 2013
Posts: 140

PostPosted: Thu 19 Apr 2018, 00:57    Post subject:  

FIXED! Very Happy

No idea how or why but based on pm discussion with Semme (for which many thanks!)
I tried changing a single line in menu.lst from
Code:

  kernel /Precise_5.71/vmlinuz   psubdir=Precise_5.71 pmedia=usbflash pfix=fsck

to
Code:

  kernel /Precise_5.71/vmlinuz   psubdir=Precise_5.71 pmedia=cd pfix=fsck

and now boot magically finds the correct puppy_precise_5.7.1.sfs and thus the associated precisesave.2fs on this drive along with any others already in the system!
(It's still utterly beyond me how it affected only the Precise install and not the others! Rolling Eyes )
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0563s ][ Queries: 13 (0.0307s) ][ GZIP on ]