Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 15 Oct 2018, 18:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Digikam 5.9 latest build
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
labbe5

Joined: 13 Nov 2013
Posts: 1386
Location: Canada

PostPosted: Fri 23 Mar 2018, 13:46    Post subject:  Digikam 5.9 latest build
Subject description: AppImage for 32&64-bit systems
 

32-bit : https://download.kde.org/stable/digikam/digikam-5.9.0-01-i386.appimage

64-bit : https://download.kde.org/stable/digikam/digikam-5.9.0-01-x86-64.appimage

Puppy and Dog users can enjoy Digikam with AppImage. Size: 380M.
For low-specs machines, Digikam is not a good fit. You need a good deal of process power to enjoy such an app.

What's new :
now permits to run the bundle under Firejail sandboxing technology for a better security level
...including the new media server dedicated to sharing collection contents on local networks with compatible DLNA devices or applications, such as tablets, cellulars, TV, etc.
There are plenty of DLNA applications available in digital stores like iTunes or GooglePlay. As the DLNA and UPNP protocols are standardized, we don’t need to develop dedicated applications for each client device that wants to access the digiKam/Showfoto contents.
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2682
Location: 500 seconds from Sol

PostPosted: Sat 24 Mar 2018, 15:00    Post subject: Appears to work under Stretchdog64  

Hi labbe5,

Thanks for posting about digikam 5.9. It appears to be functional under Strectchdog64 and Xenialpup64.

mikesLr
Back to top
View user's profile Send private message 
retry3

Joined: 15 Aug 2006
Posts: 104
Location: Ohio

PostPosted: Wed 16 May 2018, 19:02    Post subject:  

This looks like something I would like to have, so I looked on the appinage site and am confused as usual.

Is this a .pet?

Would it work in tahrpup 6.0.5? (I don't know enough about downloading and installing to find out for myself)

Any advice as to where to look next?

Thanks for any help.

retry3
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 2768
Location: South Australia :-(

PostPosted: Wed 16 May 2018, 21:42    Post subject:  

It's an appimage which is a single file to downlod. You might even say it's an executable archive. Just make the permissions executable and click on it to run it.
_________________
Software <-> Distros <-> Tips <-> Newsletters
Back to top
View user's profile Send private message Visit poster's website 
retry3

Joined: 15 Aug 2006
Posts: 104
Location: Ohio

PostPosted: Thu 17 May 2018, 18:21    Post subject:  

smokey01 wrote:
It's an appimage which is a single file to downlod. You might even say it's an executable archive. Just make the permissions executable and click on it to run it.


Hey, thanks smokey01!

That helps a lot.

Regards,
retry3
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4227
Location: King's Lynn, UK.

PostPosted: Wed 20 Jun 2018, 08:45    Post subject:  

@ labbe5:-

Thanks for this. The 32-bit AppImage runs in Upup Bionic 18.05, with the addition of libopenal from the Bionic repos.

It also runs nicely in Slacko 570, using the above libopenal from Bionic, plus the addition of libsndio & libbsd from Xenial.

I've uploaded a .pet package for the deps that 570 needs to my Google Drive:-

https://drive.google.com/file/d/1PFOhmTtj4-Kk-1s2_0uM_HS9O2kN_Zg7/view?usp=sharing

In theory, an AppImage should be the same as a statically-compiled package with all dependencies included.....but this is KDE-based, so, er.....'nuff said..!


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
mikeslr


Joined: 16 Jun 2008
Posts: 2682
Location: 500 seconds from Sol

PostPosted: Wed 20 Jun 2018, 13:09    Post subject:  

Thanks, Mike, for the info & pet.

mikesLr
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4227
Location: King's Lynn, UK.

PostPosted: Wed 20 Jun 2018, 14:17    Post subject:  

You're very welcome, Mike.

Only thing is, you can't track the extra libs down using ldd.....because it doesn't see an AppImage as an executable binary. So you have to do it the old-fashioned way, tracking 'em down one at a time, as you try starting it via the terminal.

First time I've ever needed to go 'lib-chasing' to get an AppImage to run... Shocked

Experimentation is showing it'll run under Slacko 5.6 & Racy 5.5, too. Which being the case, it should run under Precise 571 w/out any hassle.....and probably ETP's Chromebook Pup, too (based on 571, with Openbox). And of course, Sailor's Slacko 571, too!

I rather suspect the version of the glibc is irrelevant; it probably has that tucked away in there, as well. Just those 3 extra libs required to get things happening.

Next on the list will then be Raring.....and Tahr & Xenial should run w/out issue. We'll see. I'm running all of these from a single, sym-linked AppImage in my remote data partition (given the size of the darned thing; *ouch*!)

I don't normally go a lot on KDE-based stuff (too fussy by far for my liking).....but I do like this. Way better than Shotwell, anyroad. Although I confess, I cannot for the life of me figure out why a photo organiser needs a sound library.....from OpenBSD, of all things. (*huh??*)

(*scratches head*)

But; it works. So.....enjoy..!

EDIT:- As I fully expected, it does run in Precise 571. And 'Chromepup'. (Not Lucid). And Upup Raring.....though, very strangely, not Tahrpup 6.0.6 (uefi). (*Comes back with a segfault; ???*)

Haven't tried Xenial yet, or Sailor's Slacko 571; that's a task for tomorrow.....though I don't anticipate any problems, since most of the 'extra' libs came from Xenial's repos anyway, and Slacko 570 fired DigiKam straight up after adding the extra libs. (And when all's said & done, 571 is contentedly running a copy of 570's save-file anyway....)


Mike. Wink

_________________
MY PUPPY PACKAGES | 'Thanks' are always appreciated!
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0529s ][ Queries: 12 (0.0094s) ][ GZIP on ]