Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Oct 2018, 13:54
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Installed latest Firefox (Quantum); how to make it run?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
woofwof

Joined: 06 Jun 2018
Posts: 9

PostPosted: Sat 09 Jun 2018, 00:41    Post subject:  Installed latest Firefox (Quantum); how to make it run?
Subject description: (Solved)
 

[SOLVED] Just search for libgtk-3 in PPM (the Puppy Packet Manager) but make sure you add the "-3" to end or the right ones won't show up. [SOLVED] THANKS FOR FIX dancytron, bigpup, and mikelr. Cool

Hi, I installed and tried to run the latest Firefox release, Quantum..I got it from here, the portable version made by Fredx181 ->

http://murga-linux.com/puppy/viewtopic.php?p=978010#978010

..but when i put "ff" from the file onto the desktop and click it all it does is create a folder that says Profile on the desktop, program doesn't open.


Thanks in advance to talented and super fast forum people for any suggestions!



.

Last edited by woofwof on Sat 09 Jun 2018, 23:43; edited 13 times in total
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1143

PostPosted: Sat 09 Jun 2018, 00:54    Post subject:  

Tell us exactly what version of Puppy or Dog you are using. Also, I assume you are using Fred's portable Firefox.

The instructions to drag the ff file on to the desktop may be the problem. Drag the ff back to where you found it (or reinstall). Then run it by clicking on ff file or right clicking on ff file and choosing "run" or "Open".

If that doesn't work, open a terminal window in the folder with the ff file and type "./ff" Tell us what messages you get.
Back to top
View user's profile Send private message 
woofwof

Joined: 06 Jun 2018
Posts: 9

PostPosted: Sat 09 Jun 2018, 01:03    Post subject:  

I'm on Tahrpup 6..but Im not sure if it's 6.0.2 or 6.0.3..or on 6.0.5. I'm total new sorry. Yeah i tried running ff within it's firefox32 folder and nothing happened. I'll try it again if you suggest it. Then I will reinstall but then i got a problem of making sure i remove all files or another error probably occur.

DANCYTRON, I ran terminal in firefox32 folder which first originally contained ff file..but first i put ff back in folder and moved any shortcuts (?) on desktop to trash.

Terminal says...XPCOMGlueLoad error for file /root/firefox32/libmozgtk/so:
libwayland-cursor.so.0: cannot open shared object file: No such file or directory
Couldn't load XCOM.


Anything else u need? Thanks for help.

Last edited by woofwof on Sat 09 Jun 2018, 04:17; edited 6 times in total
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1143

PostPosted: Sat 09 Jun 2018, 01:29    Post subject:  

Okay, that means that it is not finding something that it needs to run.

Bad download? I try to redownload and see what happens.

If that doesn't do it, someone else will come along and help you figure out what is missing.
Back to top
View user's profile Send private message 
woofwof

Joined: 06 Jun 2018
Posts: 9

PostPosted: Sat 09 Jun 2018, 03:57    Post subject:  

Reinstalled and uncompressed in different places but still nothing. When I click ff in firefox32 folder to run I guess another file or folder is added to firefox32, I think it's just Profile folder though..just like before.

Please, any suggestions, Im desperate thanks!

Last edited by woofwof on Sat 09 Jun 2018, 23:16; edited 2 times in total
Back to top
View user's profile Send private message 
foxpup


Joined: 29 Jul 2016
Posts: 571
Location: europa near northsea

PostPosted: Sat 09 Jun 2018, 05:04    Post subject: gtk3  

I think this firefox needs gtk3 and Tahr does not have it. It is in the first page of the firefox quantum thread you refer to, woofwof.
Back to top
View user's profile Send private message 
woofwof

Joined: 06 Jun 2018
Posts: 9

PostPosted: Sat 09 Jun 2018, 06:13    Post subject:  

Thanks foxpup, that really might be it, but im now away from pc and am writing from mobile..I will try it later!
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11132
Location: Charleston S.C. USA

PostPosted: Sat 09 Jun 2018, 16:15    Post subject:  

Need to go back to the forum topic and read the edit entries.
Something about GTK3 and where the Firefox folder needs to be placed.
http://murga-linux.com/puppy/viewtopic.php?p=978010#978010

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
woofwof

Joined: 06 Jun 2018
Posts: 9

PostPosted: Sat 09 Jun 2018, 17:32    Post subject:  

Yeah working on it..problem is that Gtk3 on that specific forum page says its for Slacko but i still downloaded/installed it cause it's buntu-based anyway I put it in root and even put it in firefox32 folder, still nothing. I went to Gtk website and looked to download it from there but I mean just the instruction guide appears to be more difficult than rocket science haha. Now I'm trying this one -> http://murga-linux.com/puppy/viewtopic.php?p=989764#989764

Still searching here and other forums & sites for info maybe I'll send a pm to Fredx181 the guy who ported (?) Firefox Quantum and just be patient.


.

Last edited by woofwof on Sat 09 Jun 2018, 22:22; edited 4 times in total
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1143

PostPosted: Sat 09 Jun 2018, 18:22    Post subject:  

Better to install it from Ubuntu using the Puppy Package Manager.

Try searching for "libgtk" in the PPM and see if you can find it.

edit:

Here is the link on the Ubuntu site.
https://packages.ubuntu.com/trusty/libgtk-3-0

so the name of the package is libgtk-3-0. Find that in the PPM and install it with its dependencies. That ought to do it.

edit again: You keep saying you are putting firefox in /root. That means inside your savefile. Consider putting it in /mnt/home instead. It will work both places, but since it is portable there is no reason to put it in the save file if you don't need to.
Back to top
View user's profile Send private message 
woofwof

Joined: 06 Jun 2018
Posts: 9

PostPosted: Sat 09 Jun 2018, 20:58    Post subject:  

Not there..I placed more repositories and updated them. It's not showing up. Should I download directly from ubuntu site? I'll do the firefox in /mnt/home thing too.

Thanks for help, may god(s) (if they exist) bless u.
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2692
Location: 500 seconds from Sol

PostPosted: Sat 09 Jun 2018, 22:40    Post subject:  

Which Puppy are you using? I think I successfully used Mike Walsh's Gtk3 pet "for precise" in Slacko 5.7.1 and Tahrpup. No running either at the moment so relying on often flaky memory. After installing a restart-x, maybe reboot, is necessary.

mikesLr
Back to top
View user's profile Send private message 
woofwof

Joined: 06 Jun 2018
Posts: 9

PostPosted: Sat 09 Jun 2018, 23:30    Post subject:  

Nice, solved. Thanks a lot dancytron, bigpup, and mikeslr. I'll update original post with info how it was fixed.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2205s ][ Queries: 14 (0.0305s) ][ GZIP on ]