Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 18 Jul 2018, 20:24
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Just-Lighthouse64-801
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [38 Posts]   Goto page: Previous 1, 2, 3
Author Message
Dry Falls

Joined: 16 Dec 2014
Posts: 564
Location: Upper Columbia

PostPosted: Thu 03 May 2018, 11:00    Post subject: version upgrade  

version upgrade. Maybe beta quality. Seems stable (for now)
Issues: PPM needs work, although gslapt is the prefered package manager;
rox starting to freeze up with heavy use. go to menu|Desktop|applets|RefreshDrives;
Almost gtk3 ready.

Base file got fat. now contains webkit-gtk, python, perl and qt4-lite. 291M.

Just-Lighthouse64-801.iso | md5: 57c53c29eb866a26459de1b16c0b90c6
Devx-JL64_801.sfs | md5: 05938efcb896207378e7b47fe89cf5cd
kernel_sources-4.16.5-JLx86_64.sfs | md5: 06d3404b4ff53ac1c4ec6b1106fcf324
NLS_base-JL64_801.sfs | md5: 8dfaba8e3e39bfcf0d30d3ad0ec669f3
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 564
Location: Upper Columbia

PostPosted: Sun 27 May 2018, 02:30    Post subject:  

new iso uploaded:

Just-Lighthouse64-801B2.iso 345M see opening post.

Last edited by Dry Falls on Thu 31 May 2018, 23:46; edited 1 time in total
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 1047

PostPosted: Thu 31 May 2018, 17:47    Post subject:  

Dry Falls wrote:
new iso uploaded:

Just-Lighthouse64-801B2.iso 345M see opening post.
The link name says *B2, but the target file name is *B1, and so is the name+link in the opening post. I guess B2 is a typo.
_________________
Fatdog64-721|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 564
Location: Upper Columbia

PostPosted: Thu 31 May 2018, 23:59    Post subject: oops  

Thanks Step! fixed link. B2 is right - now 324M
md5sum:
a80d7f22b354f3cc83ef5ccaa186f527 Just-Lighthouse64-801B2.iso

Edit: Oh, It was a typo. Just hadn't posted the most recent till now!

df
Back to top
View user's profile Send private message 
Pete22


Joined: 08 May 2009
Posts: 264
Location: Utah, USA

PostPosted: Wed 27 Jun 2018, 17:05    Post subject: 64-801B2 Not working for me  

Hello Dry Falls.

I want to thank you for keeping lighthouse pup alive. It is my favorite puppy.

I downloaded this new version 801fB2 and did a frugal install. Perhaps I did the frugal install wrong,
because, I am not having a good time with it. I redownloaded it and checked the md5 to see if that was the problem, but it was not.

So maybe you could give me a walk through on a frugal install as a first step in solving my issues.

Things I seeing.

1- Xfce desktop. I like to add my own icons, but it does not allow that. I don't mind using the other desktop but I need one that I can add
icon links to without too much geekiness.

2- I cannot get most of the 801.sfs' to work. For example firefox. i had to go and find a deb for firefox. It worked, but it said it was missing
some files. Now it only works in Spot and refuses to be the default browser.

3- Could not get the libreoffice pet and others to work at all.

4- I get no sound.

I am typing this from another puppy right now. This evening I will get back in to Just lighthouse and give you more details.

I know that Just lighthouse is really for folks who are more geeky, but I would love to have it work for me.

All this could be user error. I am hoping that with a little help, I can get it going to my liking.
Back to top
View user's profile Send private message 
stemsee

Joined: 27 Jun 2013
Posts: 2256
Location: In The Way

PostPosted: Thu 28 Jun 2018, 06:32    Post subject:  

Hi Dry Falls

Downloaded, and installed manual frugal and running well.

Here is some hopefully useful feedback.
I installed my Wifi-TrayNet app and connected to network perfectly!
opened browser and foud webpage using duckduckgo homepage. My laptop is 1920x1080, normally I zoom in, geany/browser, using ctrl++ or ctrl and two fingers on trackpad, but no go, could be keyboard layout, I will try others, mine is GB. I also use pinch to zoom on touchscreen, in browser, geany and image viewers, no go.

I was editing a script, which gained full executable permissions, I was not able to change permissions using the properties gui nor in term.

On shutdown I created save file using simple encryption, it seemed to complete, but it didn't ask for password and no file was created, in sdb2 (ext).

I will have a play around, see what I can find!

stemsee
Back to top
View user's profile Send private message MSN Messenger 
chrabak

Joined: 18 Mar 2014
Posts: 7

PostPosted: Fri 29 Jun 2018, 17:11    Post subject: LH64-801
Subject description: full install fails
 

Hello Dry Falls.

how to get a full install on LightHouse64-801? the live CD runs
fine (well, no trackpad and cannot read the sd card slot) but the
full install fails misserably. the install runs, and i get a few
files copied to the partition. my grub2 menu boots it into a kernel
panic. even a frugal install on my Acer VX 15 fails. any ideas?

here is the inxi report...


System: Host: Mariner18014 Kernel: 4.16.8 x86_64
____(64 bit gcc: 7.3.0) Desktop: Openbox 3.6.1
____Distro: Just-Lighthouse64 Linux Linux 4.16.8 [ arch]
Machine: System: Acer (portable) product: Aspire VX5-591G v: V1.03
____Mobo: KBL model: Wish_KLS v: V1.03 Bios:
____Insyde v: V1.03 date: 01/26/2017
Battery BAT1: charge: 42.9 Wh 95.6% condition: 44.9/46.0 Wh (97%)
____model: COMPAL PABAS0241231 status: Discharging
CPU: Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
____flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
____bmips: 22464 clock speeds: max: 3800 MHz 1: 1306 MHz
____2: 3167 MHz 3: 3189 MHz 4: 2953 MHz 5: 3215 MHz
____6: 3307 MHz 7: 3290 MHz 8: 3169 MHz
Graphics: Card-1: Intel Device 591b bus-ID: 00:02.0
____Card-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
____bus-ID: 01:00.0
____Display Server: X.org 1.20.0 drivers: nouveau,intel
____(unloaded: nv,vesa) tty size: 124x24
____Advanced Data: N/A for root
Audio: Card Intel CM238 HD Audio Controller driver: snd_hda_intel
____bus-ID: 00:1f.3 Sound: ALSA v: k4.16.8
Network: Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network
____Adapter driver: ath10k_pci bus-ID: 02:00.0
____IF: N/A state: N/A mac: N/A
____Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit
____Ethernet Controller
____driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 03:00.0
____IF: enp3s0 state: down mac: <filter>
Drives: HDD Total Size: 516.2GB (5.4% used) ID-1:
____/dev/sda model: HFS512G39TND size: 512.1GB
____ID-2: USB /dev/sdb model: USB_Flash_Drive size: 4.1GB
Partition: ID-1: swap-1 size: 16.78GB used: 0.00GB (0%)
____fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 40.0C mobo: N/A gpu: 38.0
____Fan Speeds (in rpm): cpu: N/A
Info: Processes: 193 Uptime: 7 min Memory: 347.3/15906.8MB
____Init: SysVinit runlevel: 5 Gcc sys: N/A
____Client: Shell (bash 4.4.191) inxi: 2.3.0


ubuntu 18.04 installed and runs fine on my hardware (after i loaded
the nvidia drivers cause it could not even shutdown without it). i
tried bionicDog64 (based on 18.04) and it has simmilar challenges
on frugal and full install on my hardware.

i have always run puppies on old hardware. this year i treated
myself to a new machine - the cheapest gaming i7-7700 i could find
- and i cannot get a puppy to run :( xenial64_7.5 does run but i
have not been able to get the track pad or sd reader working.

puppy with jwm and rox has been my development system since 2009.
i cannot even think of doing it any other way. thanks "Dry Falls"
and to everybody who has ever had a hand in puppy creation. i love
it.
Back to top
View user's profile Send private message 
Dry Falls

Joined: 16 Dec 2014
Posts: 564
Location: Upper Columbia

PostPosted: Thu 05 Jul 2018, 00:21    Post subject:  

Sorry to have taken so long to answer these.

@Pete (& TWIMC): Thanks for sticking with my project! I've had no problems using or making new frugal save-file installs. In fact, it seems to me better at finding the base sfs and save files than ever. Of course, I use grub2 and have no access to a 64bit legacy boot machine. It does work in qemu but that is no test for booting a save file. I'm assuming the problem you experience must be related to the isolinux.cfg. It probably needs tweaked. Remember that the install must be in the top of the partition or no more than One directory deep! If it is a usb partition, make sure the append line contains "pmedia=usbflash" and NOT "cd".

There is a section on boot parameters in Lighthouse faqs.

In xfce desktop, I've no problem changing the icon theme from the xfce-settings application (to an installed icon theme). However, there seems no option to change individual icons like there is in kde except for *.desktop files which can be edited.

Firefox is a whoops on my part (bad symlink in the sfs) fix it with
Code:
rm -f /usr/bin/firefox
sleep .5
ln -s /usr/lib64/firefox/firefox /usr/bin/firefox


What other sfs files have you had a problem with? The directory structure is basically unchanged since Tazoc created Lighthouse, which means most pets for woofCE puppies won't work in lighthouse without some editing. Always check the lighthouse repo first and slackware second. Also advise using *.txz packages and right-click 'install-txz' instead of petget. (It's on my todo list to change the default for .txz in mime-types)

On the topic of browsers, as has been the case for as long as I've been involved with lighthouse, browsers accessed from the menu run as spot. Root is accessed from wbar or the terminal. You can also edit the .desktop file in /usr/share/applications.

The easiest frugal install is manual. If it is to usb media, 'pmedia=usbflash' (or usbssd) is essential. Otherwise, open the drive/partition you want to use with rox-filer and drag the base, initrd.xz and vmlinuz files there and edit your pre-existing boot menu accordingly. Even more sure-fire is to install to a directory with the psubdir=myuniquefoldername. Extra sfs files can be located in that folder or on the top of the partition.

I've fixed the sound issues with
Code:
chmod -x /etc/rc.d/rc.alsa
. It was confusing pulse, which handles sound. Make adjustments with Pulse-audio volume control from the menu or 'Sound' from wizardwizard (setup) or right-click the speaker tray-icon (left-click in xfce).

@Stemsee: Greetings. Surf browser zoom-in is <control shift k> and out is <control shift j>. Keyboard shortcuts are found in /usr/share/doc/surf/surf.1 (also in the man directory). A location bar of sorts (dmenu) is called up with <control g>. Terminal is probably the easiest. Wbar "Surf" icon runs it as root. Surf is not multiuser friendly (spot can't download anything).

Can't replicate the permissions problem you described. Not sure what's up with that.

The encrypted save-file is something I've never played with, but I remember hearing it is restricted to ext2. Even so, the code is partially in both the init script and rc.shutdown and is untouched from the original. It may be broken since gcrypt has been upgraded several times since.

Thanks for testing. Soon I'll have an updated version uploaded with new sfs files. Having some problems with the devx since the gcc-8.1.1 upgrade.

@chrabak: Lighthouse is meant to run in ram. A full install is not recommended. The closest option which is supported is pupmode 6 (save to partiition). If you still want a full install, there is a good help file in the fatdog faqs, although I don't think they support it. I think you could make an install to partition and then delete the initrd folder. Unsquash the base sfs there and the system might read it as a full install, but I wouldn't count on it.

I think you've already discovered one issue: nvidia.

Below is a package (getnvidia) for lighthouse (click to unzip). It's built into the next release.

edit: Yes, encrypted pupsave is broken. Errors seem to point to losetup. fails to mount.
getnvidia-1.0-64.txz.gz
Description  click to unzip
gz

 Download 
Filename  getnvidia-1.0-64.txz.gz 
Filesize  96.45 KB 
Downloaded  6 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [38 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0554s ][ Queries: 13 (0.0089s) ][ GZIP on ]