Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 20 Jul 2018, 14:50
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
TazPup Alpha 17
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 39 of 39 [583 Posts]   Goto page: Previous 1, 2, 3, ..., 37, 38, 39
Author Message
thinkpadfreak

Joined: 17 Oct 2016
Posts: 24

PostPosted: Wed 27 Jun 2018, 08:21    Post subject:  

Hello.
I have been trying tazpup since Alpha 13.

I think tazpup sets hwclock in utc. On the other hand, windows assumes that the hardware clock is in local time.

I have some puppies installed on my PC in addition to windows, and all the puppies set hwclock in local time. The setting of tazpup affects the other puppies and windows.

As for tazpup, is it possible to choose between localtime and utc?

Regards.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 911
Location: PH

PostPosted: Thu 28 Jun 2018, 22:45    Post subject:  

@thinkpadfreak for the meantime just delete the TZ file in /etc. type unset TZ in terminal and press enter. And use hwclock -l to set the system time to local only. Im trying to fix this system time problem.

Right now I will try to prepare the first beta release of TazPup.
Back to top
View user's profile Send private message 
thinkpadfreak

Joined: 17 Oct 2016
Posts: 24

PostPosted: Fri 29 Jun 2018, 08:07    Post subject:  

mistfire wrote:
> for the meantime just delete the TZ file in /etc. type unset TZ in terminal and press enter. And use hwclock -l to set the system time to local only.

Thank you for response.
I suspect that, though the procedure above makes hardware clock equal system time, ntpd or something writes utc into hardware clock. As a result, system time is different from localtime.

I think that, if we have the file /etc/localtime, system time will be corrected. But hardware clock will remain in utc.

Anyway, I am looking forward to the beta version.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1103

PostPosted: Fri 29 Jun 2018, 09:54    Post subject:  

mistfire wrote:
@thinkpadfreak for the meantime just delete the TZ file in /etc. type unset TZ in terminal and press enter. And use hwclock -l to set the system time to local only. Im trying to fix this system time problem.

Right now I will try to prepare the first beta release of TazPup.


Related to time, there should be something to set lets you set time from the internet. I think that I might of done this under

Slitaz Panel -> Boot -> Manage Daemons

before. Oddly the version of TazPup that I'm running, while I post now, has this grayed out but I'm sure that I used it before. Maybe this was fixed in later versions.

Edit. So Under Tux, I set the timezone under:
Setup -> Time Zone COnfiguration

I logged out looged in as root and the time was correct (Maybe it would have also been correct if I logged back in under Tux.

Anyway, Under root I was able to open

Slitaz Panel -> Boot -> Manage Daemons

and the time server was running. It is called, "ntpd".

I did all this using alpha 12. I have newer versions of TazPup installed just not on the computer that I was presently typing on.

Edit 2 I logged out then back in as Tux and the time is still correct but for better or worse Tux doesn't have access to "Manage Daemons".
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 344
Location: Yugoslavija

PostPosted: Fri 29 Jun 2018, 10:02    Post subject: tzclock_3.0.6-1_i386.deb  

this one works
tzclock_3.0.6-1_i386.deb
Back to top
View user's profile Send private message 
thinkpadfreak

Joined: 17 Oct 2016
Posts: 24

PostPosted: Fri 29 Jun 2018, 21:32    Post subject:  

s243a wrote:
> Related to time, there should be something to set lets you set time from the internet.

Adjustment of the hardware clock by "ntpd" is OK, but the hardware clock has to be in localtime for the compatibility with Windows. Ntpd seems to set the hardware clock in utc, which causes a problem.

Edit:
In order to keep the hardware clock in localtime, one might either stop ntpd or, issue a command before shutdown such as:
# hwclock --systohc --localtime

zagreb999 wrote:
> this one works
> tzclock_3.0.6-1_i386.deb

Thank you for your advice.
However, my concern is not how to set the time zone correctly but how to set the hardware clock as we wish (localtime or utc).
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 911
Location: PH

PostPosted: Fri 29 Jun 2018, 22:25    Post subject:  

Tazpup Alpha 17 released:

* Improved system clock (puppy algorithm is now applied)
* utc and localtime can now selected on configure timezone

Download: https://drive.google.com/file/d/1FdWZvrfLwZM9-HXa_BNLfS_F09sUO_GA/view?usp=sharing

Build kit
https://drive.google.com/file/d/1N0tuuS2-HIk22_3DMblihje41-51Sxho/view?usp=sharing
Back to top
View user's profile Send private message 
thinkpadfreak

Joined: 17 Oct 2016
Posts: 24

PostPosted: Mon 02 Jul 2018, 04:02    Post subject:  

I am using Alpha 17 under Japanese environment. The clock issue seems to have been mostly fixed.

One of the members in Puppy Linux Japanese Forum suggests a setting as follows:

/etc/daemons.conf
NTPD_OPTIONS="-nqp pool.ntp.org"

This way, ntpd quits after clock is set. (It does not run as a daemon) This setting seems to help prevent the hardware clock being re-written in the way we don't expect.

P.S.
urxvt does not function properly. Some commands cannot be executed, probably because it is a cut-down version.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1103

PostPosted: Mon 02 Jul 2018, 22:06    Post subject:  

thinkpadfreak wrote:
I am using Alpha 17 under Japanese environment. The clock issue seems to have been mostly fixed.

One of the members in Puppy Linux Japanese Forum suggests a setting as follows:

/etc/daemons.conf
NTPD_OPTIONS="-nqp pool.ntp.org"

This way, ntpd quits after clock is set. (It does not run as a daemon) This setting seems to help prevent the hardware clock being re-written in the way we don't expect.

P.S.
urxvt does not function properly. Some commands cannot be executed, probably because it is a cut-down version.


I kind of like this approach because it means less process running Smile. It also should be adequate for most peoples needs.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 911
Location: PH

PostPosted: Tue 03 Jul 2018, 02:04    Post subject:  

Hello there

Can you help me about this problem.

I noticed that pristine slitaz triggers /etc/init.d/rc.shutdown when going to shutdown or reboot while in tazpup does not but it is defined in /etc/inittab in both slitaz and tazpup. Any ideas how to get it work on tazpup?
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1103

PostPosted: Thu 05 Jul 2018, 01:39    Post subject:  

mistfire wrote:
Tazpup Alpha 17 released:

* Improved system clock (puppy algorithm is now applied)
* utc and localtime can now selected on configure timezone

Download: https://drive.google.com/file/d/1FdWZvrfLwZM9-HXa_BNLfS_F09sUO_GA/view?usp=sharing

Build kit
https://drive.google.com/file/d/1N0tuuS2-HIk22_3DMblihje41-51Sxho/view?usp=sharing


I'm just looking at the code and the following doesn't appear to be an error:

Ln#416 of make-tazpup.sh
Code:

mksquashfs "slitaz-rootfs" "$DISTRO_PUPPYSFS" -comp xz -Xbcj x86 -b 1M -Xdict-size 100%


However, for if some reason you leave "$curdir" (due to a code modification) then it will get an error. The code might be more robust to changes if you use the following instead:

Code:

mksquashfs "$curdir/slitaz-rootfs" "$DISTRO_PUPPYSFS" -comp xz -Xbcj x86 -b 1M -Xdict-size 100%


and this would be more consistent with the rest of your code.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1103

PostPosted: Mon 09 Jul 2018, 00:37    Post subject:  

So I couldn't figure out why I was deleting files and wasn't freeing up any space. After some time of incessant deleting I finally figured out all the files were being moved to:

/mnt/home/.Trash-0/files

The trick is to open /mnt/home/ as root. This option is available by right clicking the folder.

After one navigates to the above path, one must highlight all the items in the folder then in the edit menu (located on the menu bar) select "remove". This removed most files except for ldlinux.sys, basesfs.msh, blank.png, boot.msg, elp.msg, savefile.msg, startnet.msg.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 1103

PostPosted: Tue 17 Jul 2018, 22:58    Post subject:  

You use to be able to right click on the desktop and select logout. This no longer work on TazPup Alpha 17. This is relevant, because sometimes when you install packages the taskbar disappears. I also noticed that if you logout by:

/etc/init.d/slim stop

that

/etc/init.d/slim start

doesn't restart the desktop. This isn't a problem to me because it makes sense to have logging in and starting the desktop as to separate functions. However, I need to know the command to start the desktop.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 39 of 39 [583 Posts]   Goto page: Previous 1, 2, 3, ..., 37, 38, 39
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0762s ][ Queries: 13 (0.0159s) ][ GZIP on ]