Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 18 Nov 2019, 09:22
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Granule: Flashcard memory program
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Mon 12 May 2008, 08:17    Post subject:  Granule: Flashcard memory program  

http://granule.sourceforge.net/

Quote:
granule is a flashcard program that implements Leitner (by the German psychologist Sebastian Leitner in the 1970s) cardfile methodology for learning new words described in his book So lernt man lernen. Der Weg zum Erfolg. ("Learning to learn. The road to success.")




To run, Menu->Utility->Granule.

The program has minimal help. To learn usage the manual
is available for offline browsing. Also refer to the examples.

N.B. This version seems to run OK only with pup2...(not sure about pup2.17?)

Last edited by muggins on Sat 17 May 2008, 20:29; edited 2 times in total
Back to top
View user's profile Send private message 
gw

Joined: 22 Apr 2006
Posts: 89
Location: Suisse

PostPosted: Tue 13 May 2008, 16:32    Post subject:  

Hello muggins,

Granule seems very interesting, thank you.
But in Muppy 0.8.3, I obtain the following message :
"granule: error while loading shared libraries: libassa-3.5.so.5: cannot open shared object file: No such file or directory"
Is there anywhere this library as a pet package?

Many thanks
--
gw
Back to top
View user's profile Send private message Visit poster's website 
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Tue 13 May 2008, 20:22    Post subject:  

gw,

Thanks for letting me know. I knew that granule needed libassa, & had it compiled & intended to bundle it with the .pet, but in my haste to upload I forgot!

Anyway, for the eight people that downloaded granule, i've re-uploaded it, with libassa included, if you want to re-download.

cheers.
Back to top
View user's profile Send private message 
cf13

Joined: 27 Mar 2007
Posts: 55

PostPosted: Wed 14 May 2008, 15:02    Post subject:  

Hi muggins,

First of all thanks for answering my request Razz

I'm getting this error

Quote:

(granule:16326): Gtk-WARNING **: Unable to locate theme engine in module_path: "xfce",

(granule:16326): Gtk-WARNING **: Unable to locate theme engine in module_path: "xfce",

(granule:16326): Gtk-WARNING **: Unable to locate theme engine in module_path: "xfce",

(granule:16326): Gtk-WARNING **: Unable to locate theme engine in module_path: "xfce",

(granule:16326): Gtk-WARNING **: Unable to locate theme engine in module_path: "xfce",

(granule:16326): Gtk-WARNING **: Unable to locate theme engine in module_path: "xfce",
terminate called after throwing an instance of 'Glib::FileError'


I'm running a full hard drive install puppy dingo and I don't have installed xfce, I need it?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Thu 15 May 2008, 02:13    Post subject:  

cf13,

maybe I'm the only person that has the blasted thing working on puppy! I tried compiling it on pup3, but ran into a bunch of problems. But I've compiled it on pup4...I hope you're using the one with the 2.6.21.7 kernel?

It turns out that besides the included libassa, it also needs libgtkmm-2.4.so, libgdkmm-2.4.so, libatkmm-1.6.so, libpangomm-1.4.so, libcairomm-1.0.so & libglibmm-2.4.so. Most of these are available as .pets, from the pup3 or pup4 section of the puppy ibiblio repository, but I had to snaffle libcairomm from packages.debian.org. (It's in the included granule-libs.tar.gz).

So you need to extract the granule-libs.tar.gz to /. Granule won't work until you've additionally installed the above packages.

N.B. Sorry pup3 users, but even though this was compiled on the 2.6.21.7 compatible pup4, I couldn't get it working on pup3. first it was complaining about libpixman-1.so.0, then when i purloined this from pup4, I was getting some other error, that's when I bailed!

So, for pup4:
granule-libs.tar.gz
Description 
gz

 Download 
Filename  granule-libs.tar.gz 
Filesize  22.93 KB 
Downloaded  631 Time(s) 

Last edited by muggins on Sat 17 May 2008, 20:35; edited 1 time in total
Back to top
View user's profile Send private message 
cf13

Joined: 27 Mar 2007
Posts: 55

PostPosted: Sat 17 May 2008, 14:39    Post subject:  

Hi muggins,

I downloaded and installed the libraries, after changing the gtk theme I'm not having the xfce error anymore, but still have this one

Quote:
granule
terminate called after throwing an instance of 'Glib::FileError'
Aborted


Thanks
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Sat 17 May 2008, 20:34    Post subject:  

cf13,

are you trying the first version, (which only seems to like pup2xxx), or the second version? Also, if you enter in a console:

Code:
uname -r


what response do you get? And if you try starting granule in a console, by entering granule, what response?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Sun 18 May 2008, 07:16    Post subject:  

cf13,

(or anyone else having granule probs), if you can't get granule going, I wonder whether you've looked at any of the other options posted in your original thread?

So far, (besides granule & 3 small tcl/tk flashcard scripts), I've had a squizz at:

Freshmemory QT4
Flashqard QT4
Athena-fcm Java
Pauker Java
jMemorize Java

I haven't looked at any of the python-based flashcard programs. If you're using pup4, have the devx .sfs file, and download & install the QT4 .pet, then the first two compile easily.

But from what I've seen, the 3 java apps seem to have the most functionality. So if you've installed the java environment, and have whatever the minimal environment is for java, they're definitely worth a look.
Back to top
View user's profile Send private message 
cf13

Joined: 27 Mar 2007
Posts: 55

PostPosted: Sun 18 May 2008, 13:10    Post subject:  

Quote:
are you trying the first version, (which only seems to like pup2xxx), or the second version?


Embarassed Embarassed I was trying the first version, sorry

Installed the second one and I get this error:
Quote:

# granule
granule: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory


I checked /usr/lib and that library is there, but it's marked in red, like having an error.

Anyway muggins thanks a lot for your worries, I have java installed so I'm gonna check out your suggestions, actually I downloaded a mobile version of Pauker, and it seems to work with my phone Razz now it comes the hardes part... to study!!! Wink Laughing
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Sun 18 May 2008, 21:29    Post subject:  

cg 13,

you're so close! Unfortunately it needs these library file to run:

Quote:
It turns out that besides the included libassa, it also needs libgtkmm-2.4.so, libgdkmm-2.4.so, libatkmm-1.6.so, libpangomm-1.4.so, libcairomm-1.0.so & libglibmm-2.4.so. Most of these are available as .pets, from the pup3 or pup4 section of the puppy ibiblio repository, but I had to snaffle libcairomm from packages.debian.org. (It's in the included granule-libs.tar.gz).


Plus you would need to download this, and extract it to /, then hopefully granule will work.

Otherwise, definitiely go with one of the java apps, especially as they seem more user friendly.
Back to top
View user's profile Send private message 
SkyPilot

Joined: 28 Aug 2005
Posts: 18
Location: Murphysboro, Illinois

PostPosted: Wed 21 May 2008, 19:16    Post subject:  

I've been watching this thread and also trying to install granule. I get the same problem that cf13 was trying. I installed the libs (although if I understand the information from the extracting screen we're not installing a lib, but a symlink), and the program says it can't find libgtkmm-2.4.so or libgtkmm-2.4.so.1, both of which show, in /usr/lib a broken symlink.

Is there a place to download libgtkmm-2.4.so (etc.) or am I missing something that is extremely to the hard core programmer (which I am not - but ask me to parse a Greek or Latin verb and watch me).
Back to top
View user's profile Send private message Visit poster's website 
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Thu 22 May 2008, 03:20    Post subject:  

SkyPilot,

for pup4 you need to download & install these:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/atk-1.20.0.pet
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/glibmm-2.14.1.pet
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/gtkmm-2.12.1.pet
Back to top
View user's profile Send private message 
SkyPilot

Joined: 28 Aug 2005
Posts: 18
Location: Murphysboro, Illinois

PostPosted: Thu 22 May 2008, 22:22    Post subject:  

Muggins,

Thanks for replying! I appreciate it!

I tried downloading "atk-1.20.0.pet" (5 or 6 times) and clicked on it in Rog to have it installed. I was told that it was processing, but never got the notice that it was successfully installed (hence I did it 5-6 times and got the same result, no successful notification).

"glibmm-2.14.1.pet" and "gtkmm-2.12.1.pet" were installed successfully. I ran, or tried to run, granule from the cli, but was told that libcairo was needed, so downloaded "cairomm.1.4.4.pet" and it loaded successfully.

I then tried again to run granule from cli and got the following:

#granule
terminate called after throwing an instance of 'Glib::FileError'
Aborted
#

I'm trying this on a Dell Inspiron 2650, 1.6ghz, 385mb memory and a 30gig HD.

Once again, thanks for your help. I see that I've lurked here longer than you, but I most certainly do not have your skill with computers.
Back to top
View user's profile Send private message Visit poster's website 
muggins

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Thu 22 May 2008, 22:44    Post subject:  

SkyPilot,

yes, I also didn't get the atk .pet registering, but I think it installs OK. You are using pup4 aren't you? (As I couldn't get it to work on pup3 at all!)

If you enter granule in a console, what errors do you get? Anything regarding missing libraries?
Back to top
View user's profile Send private message 
SkyPilot

Joined: 28 Aug 2005
Posts: 18
Location: Murphysboro, Illinois

PostPosted: Fri 23 May 2008, 10:43    Post subject:  

Sorry that I wasn't clearer. The message I posted last night is what happened when I typed granule into the console (shouldn't have called it cli, command line interface).

To recap, after installing everything except the atk .pet, typing granule in the console brought up a message about libcairo... missing. So I installed the cairomm .pet and tried it in the console again. The result was

#granule
terminate called after throwing an instance of 'Glib::FileError'
Aborted
#

At that point I called for help since I don't really know what I'm doing. And yes, I'm using Dingo. Haven't really changed anything except adding some games, the OpenOffice sfs and trying to install granule.

Again, thanks for your advice!
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0614s ][ Queries: 13 (0.0092s) ][ GZIP on ]