Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 15 Jul 2018, 17:20
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Trelby screenplay software
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
aj dowell

Joined: 18 Jul 2015
Posts: 2

PostPosted: Sat 18 Jul 2015, 19:47    Post subject:  Trelby screenplay software
Subject description: Trelby not found but supposedly installed
 

I'm using tahrpup based on Ubuntu 14.04 on a usb flashdrive with a tahrsave file. I want to use Puppy full time but unable to install and use my favorite screenwriting app.

Does someone have a solution without having to change programs?

http://www.trelby.org/download
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7829
Location: World_Hub

PostPosted: Sun 19 Jul 2015, 07:48    Post subject:  

Welcome to the forum AJ Mate.

When you say "unable to install," what was the problem?

Ah, you need Python and a handful of other goodies:
Quote:
Installation instructions for Trelby on Linux (tar.gz)
------------------------------------------------------

You have to copy trelby/ to /opt/trelby/. Afterwards you can run the
program with the command "/opt/trelby/src/trelby.py".

External dependencies required:

* Python (2.6 or 2.7)
* wxWidgets (2.8] and its Python bindings (wxPython)
* lxml

Installing the deb vs my tar.gz wouldn't matter.

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3177
Location: wales

PostPosted: Sun 19 Jul 2015, 09:11    Post subject:  

there was a problem with python-wxgtk2 in tahrpup which is now fixed.

so open quickpet and click on 'tahrpup updates' and you should get a message with "postinstall fix for python-wxgtk2.8 ...aj dowell"

then as semme says you just need a few things from the PPM use the find box to install...

python-wxgtk2.8
python-lxml

then install the trelby.deb and it should fire up.

NOTE: if you've already installed python-wxgtk2.8 before the quickpet fix, you may need to uninstall python-wxgtk2.8 and then reinstall for the fix to work

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
aj dowell

Joined: 18 Jul 2015
Posts: 2

PostPosted: Sat 25 Jul 2015, 17:40    Post subject: trelby
Subject description: installing missing package worked
 

Thank You Semme and 666philb. It is working properly now and I will be able to use Puppy full time now. You're both awesome.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0349s ][ Queries: 11 (0.0058s) ][ GZIP on ]