Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 14 Dec 2017, 18:57
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Adobe Flash Player Auto Updater
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 7 [101 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 2313
Location: Queensland

PostPosted: Mon 10 Aug 2015, 16:52    Post subject:  

bigpup wrote:
If you offer an option, so the program searches for a new version of Flash Player, notifies about the update, but gives you the option to download and install.


Working on it, just about finished with a rewrite of the script, I'll be giving it a menu entry, when run it will give the option to check for new flash version at startup and some other features.

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2313
Location: Queensland

PostPosted: Tue 11 Aug 2015, 08:16    Post subject:  

New version 1.3 for testing, see first post, there was a new flash update earlier today.
_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4299
Location: West Lothian, Scotland, UK

PostPosted: Wed 12 Aug 2015, 06:43    Post subject:  

Installed latest version = update_flash-1.3
Doean't run from the menu entry.
Get this in a console.
Code:
# update_flash
awk: cmd. line:1: fatal: cannot open file `/root/.update_flash' for reading (No such file or directory)
/usr/bin/update_flash: line 28: yad: command not found
#
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2313
Location: Queensland

PostPosted: Wed 12 Aug 2015, 08:40    Post subject:  

Sylvander wrote:
Installed latest version = update_flash-1.3
Doean't run from the menu entry.


It needs yad installed to run, I'm guessing your trying it in slacko which doesn't have yad,

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4299
Location: West Lothian, Scotland, UK

PostPosted: Wed 12 Aug 2015, 11:33    Post subject:  

OK...
Installed yad, and "Update Flash" now runs from the menu entry in Slacko-5.7.0-pae. Very Happy

Looks polished, and seems to be working well.
I like the way it now tells the version it has just installed.

Nice job! Cool
Back to top
View user's profile Send private message 
Bindee

Joined: 19 Jun 2014
Posts: 365

PostPosted: Thu 13 Aug 2015, 18:41    Post subject:  

https://github.com/rtrouton/rtrouton_scripts/tree/master/rtrouton_scripts/install_latest_adobe_flash_player

https://github.com/rtrouton/rtrouton_scripts/blob/master/rtrouton_scripts/install_latest_adobe_flash_player/install_latest_adobe_flash_player.sh

Don't know if there is anything from the above Mac OSX update script that would be of any use as that determines and grabs the latest version........
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4299
Location: West Lothian, Scotland, UK

PostPosted: Fri 14 Aug 2015, 06:20    Post subject:  

Now I'm getting this:
How come?
00.jpg
 Description   
 Filesize   28.75 KB
 Viewed   642 Time(s)

00.jpg

Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2313
Location: Queensland

PostPosted: Fri 14 Aug 2015, 21:01    Post subject:  

Sylvander wrote:
Now I'm getting this:
How come?


It only updates if flashplayer was previously installed from a pet or manually added, it doesn't install the entire flash package, only the libflashplayer.so,

it looks for an existing file as it retrieves the version number to tell whether it's up to date, it also uses the the icons from an installation.

If you comment out the lines in red, it will work if the libflashplayer.so is missing

Quote:
73 #export FLASH_PLAYER="/usr/lib/mozilla/plugins/libflashplayer.so"
74 function ABOUT_UPDATER(){
75 #if [ ! -f "$FLASH_PLAYER" ]; then
76 #ABOUT="<b><span size='"'x-large'"'>Adobe Flash Player</span></b>
77 #Doesn't appear to have been installed
78 #Please click on the links for the latest Flash packages"
79 #LINK1="<b><u><span color='"'blue'"'>Update Flash 1.3 By Geoffrey 11th August 2015</span></u></b>"
80 #LINK2="<b><u><span color='"'blue'"'>http://www.murga-linux.com/puppy/viewtopic.php?t=84267</span></u></b>"
81 #LINK3="<b><u><span color='"'blue'"'>http://www.smokey01.com/OscarTalks</span></u></b>"
82 #else
83 ABOUT="<b><span size='"'x-large'"'>Adobe Flash Updater</span></b>
84 Updates only the flash player plugin libflashplayer.so
85 Please click on the links for the latest Flash packages"
86 LINK1="<b><u><span color='"'blue'"'>Update Flash 1.3 By Geoffrey 11th August 2015</span></u></b>"
87 LINK2="<b><u><span color='"'blue'"'>http://www.murga-linux.com/puppy/viewtopic.php?t=84267</span></u></b>"
88 LINK3="<b><u><span color='"'blue'"'>http://www.smokey01.com/OscarTalks</span></u></b>"
89 #fi
~
~
~
124 #[ ! -f "$FLASH_PLAYER" ] && ABOUT_UPDATER && exit 1

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4299
Location: West Lothian, Scotland, UK

PostPosted: Sat 15 Aug 2015, 04:27    Post subject:  

Geoffrey wrote:
It only updates if flashplayer was previously installed from a pet or manually added

OK, I manually installed flashplayer, and then used your script/program to update it.
Appears to have worked as it aught. Very Happy
Back to top
View user's profile Send private message 
sfs

Joined: 02 Nov 2013
Posts: 38
Location: Russia

PostPosted: Wed 19 Aug 2015, 03:46    Post subject:  

perl -> sed
Code:
LATEST_VERSION=`perl -ne 'if(m/Version (.*?)</){ print $1 . "\n"; }' ~/.flash_update/index.html || sed -n '/<strong>Version /s/^.*<strong>Version \(.*\)<\/strong>.*$/\1/p' ~/.flash_update/index.html `

_________________
PuppyRus-Arch
Back to top
View user's profile Send private message Visit poster's website 
Geoffrey


Joined: 30 May 2010
Posts: 2313
Location: Queensland

PostPosted: Sat 17 Oct 2015, 04:15    Post subject:  

Updated to version 1.4, all gtkdialog now, no yad, enable/disable run at startup or run from menu.
_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Thu 22 Oct 2015, 19:37    Post subject:  

Geoffrey wrote:
Updated to version 1.4, all gtkdialog now, no yad, enable/disable run at startup or run from menu.

I just test your script (useful and effective).
My proposal: rather than proposing a new utility, you could help develop "getflash". If you agree, you're welcome.
http://www.murga-linux.com/puppy/viewtopic.php?t=74491
Regards

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 9676
Location: Charleston S.C. USA

PostPosted: Thu 22 Oct 2015, 20:08    Post subject:  

The Getflash in Tahrpup 6.0.3 does have a forum link to Auto Updater, if you want to install and use it.

Making it an option, to select in Getflash, does seem like a good idea. Idea
Seems like a good combining of two very good programs.

Getflash would initially install Flash.
Your code would add the option to make it auto update.

I like it Exclamation Very Happy
capture19202.png
 Description   
 Filesize   52.5 KB
 Viewed   408 Time(s)

capture19202.png


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Fri 23 Oct 2015, 05:40    Post subject:  

bigpup wrote:
Making it an option, to select in Getflash, does seem like a good idea. Idea
Seems like a good combining of two very good programs.

Getflash would initially install Flash.
Your code would add the option to make it auto update.

Good idea!

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Fri 23 Oct 2015, 09:34    Post subject:  

bigpup wrote:
Your code would add the option to make it auto update.

I started integrating the automatic update.
To be continued ...

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 7 [101 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0518s ][ Queries: 14 (0.0042s) ][ GZIP on ]