Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 18 Oct 2017, 13:14
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Master Pdf Editor 3.5.10
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 3 [44 Posts]   Goto page: 1, 2, 3 Next
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 2301
Location: Queensland

PostPosted: Wed 23 Sep 2015, 06:48    Post subject:  Master Pdf Editor 3.5.10  

Edit: update

I've packaged master-pdf-editor-3.5.10.sfs, this requires Qt to be installed.
master-pdf-editor-3.5.10_wary.sfs should work in pups with old library files, contains Qt, glibc 2.11.3 and GLIBCXX 3.4.13, this has some limitations such as not opening browser links.
master-pdf-editor-3.5.10.png
 Description   
 Filesize   39.13 KB
 Viewed   1315 Time(s)

master-pdf-editor-3.5.10.png


_________________
Carolina: Recent Repository Additions


Last edited by Geoffrey on Sun 01 Oct 2017, 02:40; edited 6 times in total
Back to top
View user's profile Send private message 
april


Joined: 14 Sep 2013
Posts: 988
Location: Off Lizard Island for a bit

PostPosted: Mon 12 Oct 2015, 17:08    Post subject:  

Thanks I'll give it a try and report back here to you any problems, just to make your day!

Actually I meant that as a joke but I ran into problems on Puppy Precise 5.7.1.
The sfs loads OK but it wont start


# master-pdf-editor-3
/opt/master-pdf-editor-3.4.03/masterpdfeditor3: /opt/master-pdf-editor-3.4.03/lib/libc.so.6: version `GLIBC_2.15' not found (required by /lib/libglib-2.0.so.0)
/opt/master-pd
Back to top
View user's profile Send private message Yahoo Messenger 
Geoffrey


Joined: 30 May 2010
Posts: 2301
Location: Queensland

PostPosted: Mon 12 Oct 2015, 23:00    Post subject:  

april wrote:
Thanks I'll give it a try and report back here to you any problems, just to make your day!

Actually I meant that as a joke but I ran into problems on Puppy Precise 5.7.1.
The sfs loads OK but it wont start


# master-pdf-editor-3
/opt/master-pdf-editor-3.4.03/masterpdfeditor3: /opt/master-pdf-editor-3.4.03/lib/libc.so.6: version `GLIBC_2.15' not found (required by /lib/libglib-2.0.so.0)
/opt/master-pd


It's not suitable for precise, works with wary racy pups that are missing the newer library files.

For it to run in precise it will need the qt library for it, which you can get from here
I'll update MasterPDF with two version, one generic the other for wary and older pups, give me some time to do that as I've been ill so it's slowly slowly.

Updated, see first post

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
anewuser

Joined: 05 Feb 2012
Posts: 69

PostPosted: Fri 16 Oct 2015, 11:37    Post subject:  

Geoffrey, ty.

Updated sfs working fine and well on tahrpup 6.0.2 CE non pae. Did not test on older puppy versions but will try on wary5.5/racy5.5

What a nice editor, good find. Notes writing along the pdfs will come very handy on this end.
Back to top
View user's profile Send private message 
april


Joined: 14 Sep 2013
Posts: 988
Location: Off Lizard Island for a bit

PostPosted: Mon 19 Oct 2015, 16:58    Post subject:  

master-pdf-editor-3.4.12-wary.sfs Works fine in Precise 5.7.1 now thank you .
Small problem , will not start from Menu but rather going to /opt/master-pdf-editor-3.4.12/masterpdfeditor3 gets it running so there is probably a small adjustment needed in the link .

Looked it up and the script needs a change in /usr/bin/masterpdfeditor-3
#! /bin/ash
/opt/master-pdf-editor-3.4.12/masterpdfeditor

to
#! /bin/ash
/opt/master-pdf-editor-3.4.12/masterpdfeditor3

Good program thanks , and I like the fact that it ends up in /opt/ I put all my external added later programs there.
Back to top
View user's profile Send private message Yahoo Messenger 
Geoffrey


Joined: 30 May 2010
Posts: 2301
Location: Queensland

PostPosted: Mon 19 Oct 2015, 17:23    Post subject:  

april wrote:
master-pdf-editor-3.4.12-wary.sfs Works fine in Precise 5.7.1 now thank you .
Small problem , will not start from Menu but rather going to /opt/master-pdf-editor-3.4.12/masterpdfeditor3 gets it running so there is probably a small adjustment needed in the link .

Looked it up and the script needs a change in /usr/bin/masterpdfeditor-3
#! /bin/ash
/opt/master-pdf-editor-3.4.12/masterpdfeditor

to
#! /bin/ash
/opt/master-pdf-editor-3.4.12/masterpdfeditor3

Good program thanks , and I like the fact that it ends up in /opt/ I put all my external added later programs there.


I'll assume that you installed the qt lib files for precise, that's why it worked when you ran /opt/master-pdf-editor-3.4.12/masterpdfeditor3, /opt/master-pdf-editor-3.4.12/masterpdfeditor is a script that loads the required lib files needed by wary.
You would be better to install the other master-pdf-editor-3.4.12.sfs that does not contain qt and the library files, it's /usr/bin/masterpdfeditor-3 does have this code
Code:
#! /bin/ash
/opt/master-pdf-editor-3.4.12/masterpdfeditor3

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
april


Joined: 14 Sep 2013
Posts: 988
Location: Off Lizard Island for a bit

PostPosted: Tue 20 Oct 2015, 05:56    Post subject:  

If its not broke don't fix it . I did have the QT sfs loaded
Back to top
View user's profile Send private message Yahoo Messenger 
greengeek


Joined: 20 Jul 2010
Posts: 4658
Location: Republic of Novo Zelande

PostPosted: Fri 23 Oct 2015, 14:06    Post subject: Re: Master Pdf Editor 3.4.12  

Geoffrey wrote:
master-pdf-editor-3.4.12_wary.sfs should work in pups with old library files, contains Qt, glibc 2.11.3 and GLIBCXX 3.4.13
Hi Geoffrey, I keep getting download errors when trying to access this sfs. Any ideas?
downloaderror.jpg
 Description   
 Filesize   20.04 KB
 Viewed   1532 Time(s)

downloaderror.jpg

Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2301
Location: Queensland

PostPosted: Fri 23 Oct 2015, 18:56    Post subject: Re: Master Pdf Editor 3.4.12  

greengeek wrote:
Geoffrey wrote:
master-pdf-editor-3.4.12_wary.sfs should work in pups with old library files, contains Qt, glibc 2.11.3 and GLIBCXX 3.4.13
Hi Geoffrey, I keep getting download errors when trying to access this sfs. Any ideas?


It looks like the link changed, removing the "s" from "https", this is no good if your sharing your dropbox account links Confused

I'm sure I included the s as I copy pasted the links when creating the post, and it did work.

I'll edit them to how they should be and see if it sticks, else try coping the url and paste it in the address bar, then add the missing s

this is weird as all my old links to dropbox work fine at the moment.

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4658
Location: Republic of Novo Zelande

PostPosted: Sat 24 Oct 2015, 03:11    Post subject:  

Hmmmm, I wonder if it is some sort of dns hijack.
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4658
Location: Republic of Novo Zelande

PostPosted: Sat 24 Oct 2015, 14:46    Post subject: Re: Master Pdf Editor 3.4.12  

Geoffrey wrote:
It looks like the link changed, removing the "s" from "https", this is no good if your sharing your dropbox account links Confused
Thanks, that worked - got it now. Works well on my Slacko 5.6 derivative. cheers.

EDIT : - actually I do have an error - if I try to make a new pdf and insert a text box it says "Error loading default font:Helvetica"
Anyone have a tip for the best way around this? I'm not sure if I simply don't have this font at all, or if I just need to tell masterpdfeditor where to find it, or if it should already be part of the program itself but is missing...

EDIT 2 : I can edit the default font in "Tools/settings/editing" but only have a choice of "deja vu" in different versions. No other font options appear. It would be nice to increase the choices if I knew how.

EDIT 3 : Apparently masterpdfeditor is looking for its fonts in /usr/share/fonts/default/TTF. The only fonts I have in there are deja vu. If I add other TTF fonts into that directory they are seen by masterpdfedit. I don't know why Abiword etc sees a whole bunch of fonts that are not in that TTF directory (maybe Abiword and the other programs use the type1 fonts and masterpdfeditor only sees TTF?)

Last edited by greengeek on Sat 24 Oct 2015, 15:40; edited 1 time in total
Back to top
View user's profile Send private message 
rufwoof

Joined: 24 Feb 2014
Posts: 2143

PostPosted: Sat 24 Oct 2015, 15:17    Post subject:  

Neat. Thanks.

I like how you can insert attachments into the PDF. Handy for when you have some spreadsheets to go along with the text in the PDF document (rather than having to externally link them).
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2301
Location: Queensland

PostPosted: Sat 24 Oct 2015, 17:10    Post subject: Re: Master Pdf Editor 3.4.12  

greengeek wrote:
I do have an error - if I try to make a new pdf and insert a text box it says "Error loading default font:Helvetica"

This seems to be a common error from some of the forums I've read, the fix is to go to Menu > Tools > Settings > Editing, then select the default font there, that works for me.
masterpdfeditor-font-1.png
 Description   
 Filesize   34.46 KB
 Viewed   1474 Time(s)

masterpdfeditor-font-1.png


_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
rufwoof

Joined: 24 Feb 2014
Posts: 2143

PostPosted: Sun 25 Oct 2015, 06:12    Post subject:  

I changed the default font from Helvetica to DejaVu Sans Book (and set the default font size to 16 as that's what I generally prefer), also changed the Update setting to 'Never', rebuilt the SFS ... and now using that as my default PDF viewer. Absolutely great. Can edit PDF's, add bookmarks, add attachments such as where the PDF was sourced from or a spreadsheet of the data used in the document etc.
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4658
Location: Republic of Novo Zelande

PostPosted: Mon 26 Oct 2015, 04:07    Post subject: Re: Master Pdf Editor 3.4.12  

Geoffrey wrote:
This seems to be a common error from some of the forums I've read, the fix is to go to Menu > Tools > Settings > Editing, then select the default font there, that works for me.
I see from your screenshot that you have a similar problem as i have with each font showing up twice.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 3 [44 Posts]   Goto page: 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0535s ][ Queries: 14 (0.0053s) ][ GZIP on ]