Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 08 Feb 2016, 13:06
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Disque dur externe problème accent
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Wed 14 Oct 2015, 14:11    Post subject:  Disque dur externe problème accent
Subject description: encodage
 

Salut,

j'ai un problème lorsque je monte mon disque dur externe sur puppy tahr 6.0.2/lxpup (enfin c'est un disque dur multimédia pour regarder sur la télé voire écouter sur sa chaine hi fi), sur windows et sur ubuntu ça marche très bien mais sur puppylinux quand y'a un accent "é" par exemple, ça remplace par un "?" et du coup je peux pas compresser avec PackIt en Zip car le chemin n'est pas reconnu.


J'imagine que je pourrai renommer mon dossier et enlever les "é" et autres trucs mais bon... J'aimerai plutôt résoudre ce problème, svp.

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 6425
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 16 Oct 2015, 18:02    Post subject: LXpup tahr :  

LXpup tahr : demande leur sur leur forum, ou sur le site de Jejy69. Moi perso je te repondrais des bêtises. selon moi il faut regarder du côté UTF8 ou la norme iso du pack de langues FR

fr_BE.UTF-8 UTF-8
fr_BE ISO-8859-1
fr_BE@euro ISO-8859-15
fr_CA.UTF-8 UTF-8
fr_CA ISO-8859-1
fr_CH.UTF-8 UTF-8
fr_CH ISO-8859-1
fr_FR.UTF-8 UTF-8
fr_FR ISO-8859-1
fr_FR@euro ISO-8859-15
fr_LU.UTF-8 UTF-8
fr_LU ISO-8859-1
fr_LU@euro ISO-8859-15

_________________
Puppy is muscular, not fat !

Last edited by Pelo on Sun 18 Oct 2015, 19:35; edited 1 time in total
Back to top
View user's profile Send private message Yahoo Messenger 
augras

Joined: 11 Nov 2013
Posts: 1196
Location: france

PostPosted: Sat 17 Oct 2015, 03:27    Post subject:  

Bonjour,
Comme Pelo : problème d'encodage de caractères à mon avis.
Comment le résoudre : aucune idée !
Je suis également sous tahrpup, mis à jour en version 6.0.3, et je n'ai pas ce problème. Je ne l'ai pas eu dans les versions antérieures non plus.
Philippe
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 6425
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 17 Oct 2015, 04:03    Post subject: LXpup tahr est un pâle erzatz de tahrpup,  

LXpup tahr est un pâle erzatz de tahrpup,
Jejy69 s'est sans doute marié et doit pouponner. LXpup buggue de partout depuis qu'il n'ont plus leur metteur au point francophone.
J'ai posé la question sur leur topic. On va bien voir.

_________________
Puppy is muscular, not fat !
Back to top
View user's profile Send private message Yahoo Messenger 
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Sat 17 Oct 2015, 10:18    Post subject:  

Oui, Lxpup c'est comme Tahrpup (lxpup tahr), c'est pas Lxpup qu'est en cause à mon avis.

Ca dépend peut-être du systeme de fichier de mon HDD, jsais plus en quoi c'est (j'imagine en NTFS).

Et pour l'UTF8,moi aussi j'ai pensé à ce genre de choses mais j'ai aucune idée de comment faire :'(

Je vais demander à celui qui s'occupe de TahrPup éventuellement.

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 2752

PostPosted: Sat 17 Oct 2015, 10:30    Post subject:  

Bonjour totolanio,

Il faut repasser dans l'interface de Quick Setup et sous le choix de la langue, il faut cocher l'encodage UTF-8

Cordialement,
Médor
Capture_2015-10-17(2).jpg
 Description   
 Filesize   65.61 KB
 Viewed   205 Time(s)

Capture_2015-10-17(2).jpg


_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Mon 19 Oct 2015, 09:46    Post subject:  

Salut Médor,

malheureusement c'est déjà coché :'(

Je précise que le problème n'arrive qu'avec le disque dur externe que j'ai branché, ça n'arrive pas avec les clefs USB que j'ai.

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 2752

PostPosted: Mon 19 Oct 2015, 11:52    Post subject:  

Bonjour totolanio,

En plus de l'encodage UTF-8 sur Puppy, Il faudrai connaitre le système de fichiers de ce disque externe (ntfs ?), les clés usb sont d'origine formatées en fat32.
Voir le résultat de la commande : fdisk -l (-l de lister).

Comme sous un autre linux il n'y a pas ce problème de caractères accentués, il peut y avoir une inadéquation dans la commande de montage.
Je ne constate pas ici sous Puppy 5/6x de problèmes d'accents sur mes partitions ntfs (disque dur interne) ou d'autres disques dur (XP/ntfs) connectés par un adaptateur usb.

Voir les commandes de montage en mode console sur ce message
Ex:
FAT32 : mount -t vfat -o iocharset=utf8,codepage=850,shortname=mixed,quiet /dev/sdb1 /mnt/sdb1
NTFS : mount -t ntfs-3g -o rw,quiet,iocharset=utf8,locale=fr_FR.UTF-8 /dev/sdb1 /mnt/sdb1
Le cas échéant, démonter avant le disque par l'icône du bureau...


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Thu 22 Oct 2015, 11:14    Post subject:  

J'ai pas tout compris, mais je vais voir le système de fichier et je réponds dès que j'ai la réponse Smile
_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Fri 23 Oct 2015, 12:33    Post subject:  

En fait, j'ai vérifié, ça bug aussi sur ma clef USB mais pas sur mon disque dur en NTFS
Code:
/dev/sda1   *          63   365322239   182661088+   7  HPFS/NTFS/exFAT


Sur sda1, pas de bug d'accents.

Mais sur sdb1, problème d'accent, et c'est en FAT32 apparemment.
Code:
/dev/sdb1            8064    31309823    15650880    c  W95 FAT32 (LBA

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.

Last edited by totolanio on Sat 24 Oct 2015, 10:47; edited 1 time in total
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Sat 24 Oct 2015, 10:47    Post subject:  

Ok j'ai monté la clef USB avec cette commande

Code:
mount -t vfat -o iocharset=utf8,codepage=850,shortname=mixed,quiet /dev/sdb1 /mnt/sdb1


Ca m'a retourné "Option inconnue -R"

Mais en revanche ça a bien monté la clef et ça a résout le bug.

Comment faire pour que ça soit toujours comme ça automatiquement ?

(et bien joué monsieur médor !!)

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Thu 29 Oct 2015, 12:58    Post subject:  

Je parie que la solution est simple alors j'ose. Up.
_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 2752

PostPosted: Thu 29 Oct 2015, 14:15    Post subject:  

Bonsoir Totolanio,

Désolé, je me suis absenté quelques jours, et je n'ai pas TahrPup pour pouvoir vérifier les scripts de montages...

On peut cependant soit faire un script "mnt-sdb1" (à placer sur le bureau) :
Code:
#!/bin/sh
mount -t vfat -o iocharset=utf8,codepage=850,shortname=mixed,quiet /dev/sdb1 /mnt/sdb1


Soit éventuellement ajouter une ligne dans /etc/fstab :
Code:
/dev/sdb1    /mnt/sdb1 vfat  auto,quiet,iocharset=utf8,codepage=850 0 0

À la condition de ne connecter qu'une clé en vfat...


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
totolanio

Joined: 03 Jan 2015
Posts: 178

PostPosted: Wed 04 Nov 2015, 11:41    Post subject:  

Mince, j'ai oublié de répondre et tester :'( désolé

Pour la clef USB ça le fait mais si je branche plusieurs trucs ?

Là j'ai branché ma clef USB (sdb1) et mon disque dur multimédia et quand je le branche ça me met sdc1, sdc3 et sdc4 (sdc4 contient mes données, le reste jsais pas ce que c'est, un booter comme grub j'imagine)

Et j'imagine que quand j'ai pas branché la clef USB, ça les renomme en sdb1, sdb3 et sdb4 ??
Bref c'est un peu compliqué

En gros, j'ai soit sdb1 à monter, soit sdc4 (et peut-être sdb4), donc je fais quoi ? je créé plusieurs scripts ?

_________________
Main puppy used : LxPup tahr.
Multiple package installer/remover.
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 2752

PostPosted: Wed 04 Nov 2015, 12:27    Post subject:  

Bonjour totolanio,

En effet ce n'est pas pratique, le script (ou la ligne dans fstab) n'est valable que pour sdb1 et avec un système de fichiers en vfat.
Voir à insérer en premier que le disque externe, il doit donc être monté en sdb1, ensuite les autres clés...

Il faudrait poser la question sur le fil anglophone de TahrPup pour trouver une meilleure solution, le problème étant identifié.


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1754s ][ Queries: 12 (0.0108s) ][ GZIP on ]