Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 17 Nov 2018, 17:06
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Where can I find a Calibre sfs to download?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Author Message
wimpy


Joined: 22 Aug 2012
Posts: 406
Location: Essex, UK

PostPosted: Sun 18 Oct 2015, 10:36    Post subject:  Where can I find a Calibre sfs to download?
Subject description: For managing e-book collections
 

There is a link on the forum to a calibre.sfs. The link no longer works. I would be grateful for help in finding a sfs to download.
_________________
LxXenial16.08, LxPupSc17.07.01,Lucid 5.2.8 and others - all frugal
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7852
Location: World_Hub

PostPosted: Sun 18 Oct 2015, 12:03    Post subject:  

Wimpy, the binary here should work with both yer pups.
_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 406
Location: Essex, UK

PostPosted: Mon 19 Oct 2015, 03:08    Post subject:  

Thank you. That worked fine. Incidentally, the program recommended updating by using a terminal command -
Code:
sudo -v && wget -nv -O- https://raw.githubusercontent.com/kovidgoyal/calibre/master/setup/linux-installer.py | sudo python -c "import sys; main=lambda:sys.stderr.write('Download failed\n'); exec(sys.stdin.read()); main()"

I ignored this for the moment because of the "sudo wget" - I'm not sure what adjustments should be made to that terminal command for puppy. In any case, unless I find a fatal flaw in this version, I'm inclined to leave well alone.

_________________
LxXenial16.08, LxPupSc17.07.01,Lucid 5.2.8 and others - all frugal
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1851
Location: lincoln, uk

PostPosted: Mon 19 Oct 2015, 03:29    Post subject:  

http://www.smokey01.com/saluki/sfs/calibre-0.8.29-i686.sfs

Smile
Back to top
View user's profile Send private message Visit poster's website 
Semme


Joined: 07 Aug 2011
Posts: 7852
Location: World_Hub

PostPosted: Mon 19 Oct 2015, 07:42    Post subject:  

Sounds good wimpy, but stay away from the update.. It's going to require newer libs than either of your pups have.

Store it outside the save file and symlink it to your "my-apps/bin" folder.. Or anywhere you like for that matter.

A rename wouldn't hurt. Wink

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
wimpy


Joined: 22 Aug 2012
Posts: 406
Location: Essex, UK

PostPosted: Mon 19 Oct 2015, 09:22    Post subject:  

@Semme Thanks for the advice.
@ally I downloaded the SFS from your link. Thanks.
It did insist that it needed UTF-8 encoding. On a faster machine it would be fine, but on my slow rig I decided to stay with the pet, which doesn't seem to need it.

_________________
LxXenial16.08, LxPupSc17.07.01,Lucid 5.2.8 and others - all frugal
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Tue 20 Oct 2015, 11:54    Post subject: Calibre is ...  

Considering US courts recent decision on Google providing books for community access, this app may be a great utility for a home system's library management.

Author's site
Author's video

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
Fishy

Joined: 26 Jan 2006
Posts: 231

PostPosted: Thu 05 Nov 2015, 14:45    Post subject: Calibre Update
Subject description: Newer version rquired for hardware
 

Hi I was wondering if someone could make an updated version of calibre?

Direct download from their site alway results in segmentation default. I have tried to follow the installation and install the proper dependencies but have only managed to screw things up. The existing calibre SFS will install in Tahr64 but unfortunately is too old to recognize my Kobo Glo HD. Checking off the plugin support newer firmware does not help.

Since reading is my major hobby it irks me to no end to have to boot my wife's windows box to install a book. The pain of waiting for updates to install before starting calibre is excruciating. Twisted Evil

Please help Crying or Very sad
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 2771
Location: South Australia :-(

PostPosted: Thu 05 Nov 2015, 20:09    Post subject:  

I did one for Fatdog-700 back in April. It's not the latest but may be of use.

http://www.smokey01.com/fd700/sfs/calibre-2.23.0-x86_64.sfs

_________________
Software <-> Distros <-> Tips <-> Newsletters
Back to top
View user's profile Send private message Visit poster's website 
tlchost

Joined: 05 Aug 2007
Posts: 2094
Location: Baltimore, Maryland USA

PostPosted: Thu 05 Nov 2015, 22:51    Post subject:  

from what I've experienced, the latest versions of calibre will not work with puppy....
Back to top
View user's profile Send private message Visit poster's website 
keniv

Joined: 06 Oct 2009
Posts: 494
Location: Scotland

PostPosted: Sun 08 Nov 2015, 06:22    Post subject:  

Hi smokey01
Thanks for the calibre .sfs. Unfortunatly it will not load for me. I am using wary tiny 511 on an old toshiba laptop (800MHz 320MB). This is quite fast with wary tiny. I am trying to keep my saave file as small as possible hence the need for an sfs. I know calibre needs python 2.6 or better. I have a pet for python 2.6 but was thinking of converting this to an sfs unless I can find a ready made one. I dont use python for anything else. Do you think this would work with your version of calibre?

Regards,

Ken.
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 2771
Location: South Australia :-(

PostPosted: Sun 08 Nov 2015, 08:11    Post subject:  

No idea Ken. I only tested it in Fatdog-700.
_________________
Software <-> Distros <-> Tips <-> Newsletters
Back to top
View user's profile Send private message Visit poster's website 
Geoffrey


Joined: 30 May 2010
Posts: 2362
Location: Queensland

PostPosted: Sun 08 Nov 2015, 09:05    Post subject:  

http://smokey01.com/carolina/sfs/calibre-1.1.0.sfs
_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 494
Location: Scotland

PostPosted: Sun 08 Nov 2015, 13:59    Post subject:  

Hi smokey01 and geoffrey,
Thanks for the replies and the link to calibre-1.1.0.sfs. I cannot get this one to load either. I have got calibre -0.8.29.sfs. It almost works in that it loads, asks for utf-8 encoding to be ticked then goes through its setup routine then crashes with it shutting down. I may give up with wary and try with lucid 5287 which I also use.

Regards,

Ken.
Back to top
View user's profile Send private message 
Fishy

Joined: 26 Jan 2006
Posts: 231

PostPosted: Tue 10 Nov 2015, 21:55    Post subject: Calibre Update  

Hi Smokey unfortunately calibre 2.23 is one or two releases before the firmware update required. Sad

Thanks for reading my request. Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [18 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0792s ][ Queries: 11 (0.0122s) ][ GZIP on ]