Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 26 Sep 2017, 10:47
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
testing: a slacko without xorgwizard-automatic
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 5 [73 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 8656
Location: qld

PostPosted: Thu 03 Dec 2015, 03:55    Post subject:  

bigpup wrote:
Intel i7 2600
Nvidia Geforce GTX 960
8 GB ram
Frugal USB flash drive

Boots to a desktop, but the desktop is all distorted and in general
unusable. Just a bunch of lines, partial images, and colors.
Kernel support for this graphics card is probably the problem.


TBH, I'm not real happy with 4 series kernels. While they work on my gear they are failing on lots of others.


I'm uploading a 32 bit version with appropriate improvements (K 3.14.57) which I'm hoping addresses yours and L18L's issues. Announcement soon.

Also I'll upload a delta for the 64 version that attempts to fix non US keyboard layouts (that fix is in the 32 version). It has the same kernel as the original though so won't fix your problem. In my next release I might roll back to 3.18.xx which is an LTS kernel too.

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 9268
Location: Charleston S.C. USA

PostPosted: Thu 03 Dec 2015, 04:31    Post subject:  

Well, I did get it to work by using the Vesa driver.
_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 3417
Location: www.eussenheim.de/

PostPosted: Thu 03 Dec 2015, 04:47    Post subject: Re: testing: slacko 6.3.0.1 without xorgwizard-automatic
Subject description: modesetting driver
 

01micko wrote:
I see you have the - Intel® PowerVR SGX545, a known problem in many kernels. I don't know why it is broken. I'll have to recheck my kernel config. It should work with 'modesetting' xorg driver which will need to be moved from 'drivers-alternate' in with all the drivers.

The problem with NOX is that it still loads the kernel modules. I don't think pfix=nomodeset would help either because vesa doesn't work as far as I know with that chip.

You are right, it definetely works with modesetting only.
ma fd64-Xorg.o.log wrote:
[ 7.168] (II) Module glx: vendor="X.Org Foundation"
[ 7.168] compiled for 1.16.3, module version = 1.0.0
[ 7.168] ABI class: X.Org Server Extension, version 8.0
[ 7.168] (==) AIGLX enabled
[ 7.168] (==) Matched modesetting as autoconfigured driver 0
[ 7.168] (==) Matched fbdev as autoconfigured driver 1
[ 7.168] (==) Matched vesa as autoconfigured driver 2
[ 7.168] (==) Assigned the driver to the xf86ConfigLayout
[ 7.168] (II) LoadModule: "modesetting"
[ 7.169] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 7.181] (II) Module modesetting: vendor="X.Org Foundation"
[ 7.181] compiled for 1.16.3, module version = 0.9.0
[ 7.181] Module class: X.Org Video Driver
[ 7.181] ABI class: X.Org Video Driver, version 18.0

Quote:
In my next release I might roll back to 3.18.xx which is an LTS kernel too.
Looks like safe side of the road. (Posting from fd which has 3.18.7)
Download for testing is no problem for me (broadband unlimited).
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 8656
Location: qld

PostPosted: Thu 03 Dec 2015, 04:56    Post subject:  

Ok..

New versions are released

32 bit iso and a 64 bit (delta only).

See main post

@L18L.. I suggest you try the 32 bit version.. I hope it works!

Check out trying the keyboard layout too (if not US). That goes for all users.

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2864
Location: Worcestershire, UK

PostPosted: Thu 03 Dec 2015, 05:23    Post subject:  

UK keyboard now AOK on slacko-6.3.0.1 32bit

Boot to desktop and usb mouse both OK on this nvidia desktop

Drive icons partially obscured by tray in this desktop theme

Video-Info 1.5.1 - Thu 3 Dec 2015 on Slacko Puppy 6.3.0.1 - Linux 3.14.57 i686

Chip description:
d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

X Server: Xorg Driver used: nouveau

X.Org version: 1.14.3
dimensions: 1366x768 pixels (361x203 millimeters)
depth of root window: 24 planes
Screenshot.png
 Description   
 Filesize   8.19 KB
 Viewed   826 Time(s)

Screenshot.png


_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 9268
Location: Charleston S.C. USA

PostPosted: Thu 03 Dec 2015, 05:31    Post subject:  

Slacko64 Puppy 6.3.0.2
Nvidia Geforce GTX 960

No help.

Boots to a desktop, but the desktop is all distorted and in general
unusable. Just a bunch of lines, partial images, and colors

I switched to the modesetting driver

Desktop OK using that driver.
.
Screenshot.jpg
 Description   
 Filesize   69.92 KB
 Viewed   830 Time(s)

Screenshot.jpg


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 3417
Location: www.eussenheim.de/

PostPosted: Thu 03 Dec 2015, 06:22    Post subject: testing: a slacko without xorgwizard-automatic
Subject description: It works.
 

1024x768 OOTB
Changing to 1920x1080 works.
Keyboard de works.

Code:
# glxgears
434 frames in 5.0 seconds = 86.781 FPS


Menu>Leave>Exit to prompt
black screen,
Typing "xwin" -> back to X

At my first try I got black screen with restartX.
Thus there might be some issues. Rolling Eyes
But that is no show stopper, just work for help desk Wink

Thank you
Screenshot_2015-12-03.png
 Description   
 Filesize   4.67 KB
 Viewed   810 Time(s)

Screenshot_2015-12-03.png

Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 674
Location: Philadelphia, PA

PostPosted: Thu 03 Dec 2015, 10:08    Post subject: Slacko 6.3.0.1 32  

01micko (in part) wrote:
Ok..

New versions are released

32 bit iso

Testing the Slacko 6.3.0.1 32 bit on this Dell laptop Latitude E6410.

Yes, it boots to desktop, keyboard works, mouse works, touchpad works.

touchscreen N/A

As I recall the GRUB4DOS commands:

Code:
kernel /slacko32/vmlinuz
initrd /slacko32/initrd.gz
boot

Quote:

-rw-r--r-- 1 root root 180240416 Dec 3 02:00 puppy_slacko_6.3.0.1.sfs
-rw-r--r-- 1 root root 1329985 Dec 3 01:49 initrd.gz
-rw-r--r-- 1 root root 4762624 Dec 3 01:49 vmlinuz
-rw-r--r-- 1 root root 33529888 Dec 3 01:49 zdrv_slacko_6.3.0.1.sfs


Thanks,
Sheldon

_________________
Dell E6410: Slim Slacko 6, LuPu Super 2, Tahr
Dell D610: Windows XP, Puppy Linux 5.2
Intel D865GBF: Tiny Windows 7, Puppy Linux 5.2
Acer Aspire One: Windows XP, Puppy Linux 5.2
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 871
Location: SW Wisconsin

PostPosted: Thu 03 Dec 2015, 10:41    Post subject:  

01micko wrote:
Ok..

New versions are released

32 bit iso and a 64 bit (delta only).

Frugal install of 32 bit to SSD on Fujitsu S6520 (core 2 duo, synaptics touchpad, iwlwifi, intel i915 dvr graphics.

boots to desktop
keyboard works (us only to test)
touchpad works (synaptics, flsynclient configuration works)
no input issues I can see
glxgears runs
iwlwifi (series 5000) connects using Frisbee
sound ok
lid closure/suspend works

Code:
Operating System      : Slacko Puppy - 6.3.0.1
User Name      : root (root)
Date/Time      : Thu 03 Dec 2015 08:25:43 AM CST
-Display-
Resolution      : 1280x800 pixels
OpenGL Renderer      : Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
X11 Vendor      : The X.Org Foundation
-Audio Devices-
Audio Adapter      : HDA-Intel - HDA Intel
Audio Adapter      : PC-Speaker - pcsp
-Input Devices-
 Lid Switch
 Power Button
 Power Button
 AT Translated Set 2 keyboard
 Fujitsu FUJ02B1
 Fujitsu FUJ02E3
 PC Speaker
 SynPS/2 Synaptics TouchPad
 Video Bus
-Printers (CUPS)-
CUPS-PDF      : <i>Default</i>
-SCSI Disks-
ATA INTEL SSDSA2M080
MATSHITA DVD-RAM UJ862BJ

Edit: Changed theme to touchpad light and rechecked glxgears with vblank_mode=0 exported. 900 FPS, slow for this laptop. I generally see 1350 to 1400 in X-slacko for example. Don't see any errors in the drm setup though. Variability before has been def. a function of the Xorg version and the kernel version.

_________________
Pups currently in kennel Very Happy X-slacko 4.3 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.

Last edited by Marv on Thu 03 Dec 2015, 11:12; edited 1 time in total
Back to top
View user's profile Send private message 
unicorn316386

Joined: 07 Apr 2015
Posts: 208
Location: Canada

PostPosted: Thu 03 Dec 2015, 10:56    Post subject:  

32-bit iso on Dell Latitude D410, booting to folder on ext2 partition with grub4dos

- "loading kernel modules" takes 65 seconds on first boot, 35 on second boot, 30 on third boot (on slacko 6.3.0 this part takes 5 seconds on first boot, 2/3 seconds after). Tried downloading iso again, same behavior (checksum equal, iso is valid)
- wireless does not show up, tried all three network options (it did in slacko 6.3.0 32-bit, as eth1 / ipw2200 driver)
- keyboard and touchpad works
- switched from "dark touch" to "dark mouse" theme because BIG "dark touch" makes some menu items unreachable here
- exited to prompt and ran xorgwizard afterwards for Lolz, didn't seem to blow anything up or make above issues disappear

edit: Running "change_kernels" from terminal and selecting the 3.14.55 files from slacko 6.3.0 and rebooting fixes both issues.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3209
Location: Ontario Canada

PostPosted: Thu 03 Dec 2015, 11:44    Post subject: testing: a slacko without xorgwizard-automatic  

Manual frugal install to a 4gb flash drive, pc is an Acer laptop:

video-info-glx 1.5.3 Thu 3 Dec 2015 on Slacko Puppy 6.3.0.1 Linux 3.14.57 i686
2.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
oem: Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS
product: Intel(R) Sandybridge/Ivybridge Graphics Controller Hardware Version 0.0

X Server: Xorg Driver: intel
X.Org version: 1.14.3
dimensions: 1366x768 pixels (361x203 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.1.7

Intel(R) Core(TM) i3-3227U CPU @ 1.90GHz
Core 0: @800 1: @800 2: @800 3: @800 MHz

trackpad,touchscreen,wired mouse all working.
It booted to the desktop and started the wired network.

Seems to be working well.
Screenshot.jpg
 Description   
 Filesize   26.04 KB
 Viewed   682 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
8Geee


Joined: 12 May 2008
Posts: 1172
Location: N.E. USA

PostPosted: Thu 03 Dec 2015, 12:23    Post subject:  

I ran the base 6.3.0-nonpae a week ago it sets up nice. I have a question and a future request.

Is 'X' still in this alpha-release, JIC? I note the iso is larger than base 6.3.0

At some time in the future, I'd like to see the 32-bit (nonpae) kernal bumped to 3.18.22 LTS or a handy 3.19.xx version.

Since my video is i915 with single-core Atom, this one should run well on an Eee-pc. I have access to the 702 model (8Gb/1Gb 7" screen), The base 6.3.0 ran on it, but slower (needs a 2Gb RAM-stick). This should run fine on it. BTW, I've been using a 7-series eee with Slacko 5.5 and 5.7 w/o problems.

_________________
Linux user #498913
Back to top
View user's profile Send private message 
unicorn316386

Joined: 07 Apr 2015
Posts: 208
Location: Canada

PostPosted: Thu 03 Dec 2015, 14:02    Post subject:  

8Geee wrote:
At some time in the future, I'd like to see the 32-bit (nonpae) kernal bumped to 3.18.22 LTS or a handy 3.19.xx version.

I think my undetected wireless problem in 3.18.22 and 4.1.1 was passed down to 3.14.57 (this exact version). 3.14.55/20, 3.12.21, 3.10.32, 3.4.94, and 4.3.0EmSee (interestingly) works fine. I wonder which one of these contributors is the culprit:

http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/log/?h=linux-3.14.y
http://fossies.org/diffs/linux/3.14.56_vs_3.14.57/

Do you know which changed file holds the answer 8Geee? Until it is fixed I do not agree with your assessment. Laughing
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2864
Location: Worcestershire, UK

PostPosted: Thu 03 Dec 2015, 14:18    Post subject:  

Slacko-6.3.0.1 32bit....

Boot to desktop ok on my ASUS laptop with intel graphics

Touchpad also ok - although I was hoping that clickpads might be better supported - the right button bit of the clickpad still does not work OOTB - do I still edit xorg.conf to make it work?? N0 - I have to copy /usr/share/X11/xorg.conf.d/50-synaptics.conf to /etc/X11/xorg.conf.d and edit the copy....2 lines to add:
Option "ClickPad" "true"
Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"

Wifi - Frisbee detects all wifi signals as usual - SNS doesn't show any signals.
If I change theme then SNS displays signals.

====> DISPLAY <====

Display Specifications:
+ Monitor VertRefresh: 60.0 times/s
+ Screen Dimensions: 1366x768 pixels (361x203 millimeters)
+ Screen Depth: 24 bits (planes)

Xorg Startup Log (/var/log/Xorg.0.log):
+ Xorg Driver in use: intel
+ Loaded Modules: dri2 evdev fb glx synaptics
+ X.Org version: 1.14.3

OpenGL 2D/3D Rendering:
+ Direct Rendering: Yes
+ Vendor: Intel Open Source Technology Center
+ Renderer: Mesa DRI Intel(R) Bay Trail x86/MMX/SSE2
+ Version: 3.0 Mesa 9.1.7

VGA controller [0300]: Intel Corporation ValleyView Gen7 [8086:0f31] (rev 0e)
+ Kernel Driver: i915
+ Memory Used: 599.07 KB
+ Path: /lib/modules/3.14.57/kernel/drivers/gpu/drm/i915/i915.ko
+ Description: Intel Graphics

====> INPUT DEVICES <====

AT Translated Set 2 keyboard
ETPS/2 Elantech Touchpad
Lid Switch
PC Speaker
Power Button
Sleep Button
USB Camera
Video Bus
Screenshot.png
 Description   
 Filesize   73.08 KB
 Viewed   589 Time(s)

Screenshot.png

Screenshot(1).png
 Description   
 Filesize   33.83 KB
 Viewed   590 Time(s)

Screenshot(1).png


_________________
LxPup = Puppy + LXDE

Last edited by peebee on Thu 03 Dec 2015, 16:22; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
darry1966


Joined: 26 Feb 2012
Posts: 898

PostPosted: Thu 03 Dec 2015, 16:15    Post subject:  

Dell D620: Keyboard, Mouse and keyboard working and sound.
Wireless Card namely Intel
®
PRO/Wireless 3945A/G (802.11a/g), Dell Wireless 1490 (802.11a/g), Dell Wireless 1390 (802.11g works with Frisbee showing all available networks with good strong connection. However SNS doesn't didn't try Network Wizard.

Love the theme and the fact you have one calculator not 4. Makes one not want to reduce the number of apps down.

Weird behaviors noted xorgwizard in menu doesn't work when you click on it.
Had to go via logging out. Noticed some keys didn't work when typing xorgwizard when out of X. Also as mentioned Simple Network Wizard total fail.

Watching videos was impressive full screen achieved when watching youtube.

Overall less sluggish than 6.3.0 which was like a snail.


Specs Dell620:
Intel
®
Core™ Solo and Duo processors 667MHz Front Side Bus & 2M Smart L2 Cache
Intel
®
Core™ Solo processor T1400 (1.86GHz)
Intel
®
Core™ Duo processor T2300E (1.66GHz) T2400 (1.83GHz) T2500 (2.0 GHz) T2600 (2.16GHz)
Intel
®
Core™ 2 Duo processor T7200 (2.00GHz), T7400 (2.13GHz), T7600 (2.66GHz)
Microsoft
®
Windows
®
XP Professional SP2, Microsoft Windows XP Home SP2
945GM (667MHz front side bus) with Intel onboard graphics or 945PM with NVidia graphics
Min: 512MB DDR2 shared
1
533 or 667MHz
Max: 4GB
2
DDR2 shared
1
533 or 667MHz
Wide-aspect 14.1” WXGA (1280 x 800 resolution) 185 nits or 14.1” WXGA+ (1440 x 900 resolution) 220 nits
Supports up to a maximum resolution of WUXGA (1920 x 1200)
Choice of Intel
®
Graphics Media Accelerator 950 (up to 224MB shared) or 256MB NVIDIA
®
Quadro NVS 110M with TurboCache
3
40, 60, 80 & 100GB
4
87-Key US; 88-Key Europe; 91-Key Japan; key travel 2.5mm; key spacing 19.05mm
Touch Pad - PS/2 compatible, Track Stick - PS/2 compatible
High Definition Audio codec, speaker, 2.0W (4 ohms), integrated omni-directional microphone
H: 32mm/1.26” x W: 337mm/13.27” x D: 238mm/9.37”
Starting at 4.41Lbs/2.00Kg* with 4 cell battery and Travel Lite Module
Starting 5.04Lbs/2.28Kg* with 6 cell battery and CD-ROM
65 Watt or 90 Watt AC adapter with cord wrapping
Primary 4-cell/35 WHr “Smart” Li-Ion battery featuring ExpressCharge™
Primary 6-cell/56 WHr “Smart” Li-Ion battery featuring ExpressCharge™
Primary 9-cell/85 WHr Li-Ion battery. Supports ExpressCharge™ with 90 watt AC adapter
Secondary 6-cell/48 WHr “Smart” Li-Polymer battery featuring ExpressCharge™
56K v.92
5
Internal Modem; 10/100/1000 Gigabit
6
Ethernet network interface adaptor
Cellular Broadband:
Internal Dell Wireless 5500 Mobile Broadband 3G HSDPA (Cingular US)
Internal Dell Wireless 5700 Mobile Broadband CDMA EVDO (Verizon Wireless US)
Intel
®
PRO/Wireless 3945A/G (802.11a/g), Dell Wireless 1490 (802.11a/g), Dell Wireless 1390 (802.11g)
Dell Wireless 350 Bluetooth internal wireless card
One Type I or Type II
Serial, docking connector, 4 USB, VGA, headphone/speaker out, infrared port, RJ-11, RJ-45, AC power
D/Port , D/Dock, D/View Notebook Stand, D/Monitor Stand
24X CD-ROM, 8X DVD-ROM
7
, 24X CDRW/DVD, 8X DVD+/-RW
8
Floppy Disk Drive, Secondary 6-cell battery, 80GB
4
Hard Drive or Travel Lite Module
128MB, 256MB and 512MB USB Memory Keys
9
(optional)
Cable Lock Slots, Media Module and Hard Drive locks
Integrated Smart Card Reader, Trusted Platform Module 1.2 and optional UPEK
®
finger print reader. Wave Embassy
®
Trust Suite by Wave Systems
security software.
802.11 WiFi Protected Access (WPA), 802.11i (WPA2), Virtual Private Networks (VPN) 802.1x with EAP modes and compatible with CC
X 4.0
Helps reduce the total cost of ownership by enabling IT departments to manage and support networked systems. OpenManage enable
s software
deployment and migration, hardware configuration and system health, asset management and remote support. For more information
visit:
www.dell.com/openmanage
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 5 [73 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0814s ][ Queries: 14 (0.0060s) ][ GZIP on ]