Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 15 Nov 2018, 08:40
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Updating Network Wizard [using Woof-CE dialogs] [alpha]
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
jlst

Joined: 23 Nov 2012
Posts: 571

PostPosted: Thu 03 Mar 2016, 21:58    Post subject:  Updating Network Wizard [using Woof-CE dialogs] [alpha]  

About 1000 lines have been deleted/added.
For the GUI I borrowed some code from Simple Network Setup and alsawizard (woof ce versions).

Those with very unstable connections might find this interesting..

Screenshots: http://postimg.org/gallery/1b0czsfv4/04da478c/

I'd like to explain and document all the changes I made but I have things to do.
Just testing this takes too much time.
There are 5000+ lines of code.. feedback and patches are welcome..

/!\ Pet for testing only /!\

Last edited by jlst on Sat 05 Mar 2016, 23:51; edited 1 time in total
Back to top
View user's profile Send private message 
Atle

Joined: 19 Nov 2008
Posts: 600
Location: Oslo, Norway

PostPosted: Fri 04 Mar 2016, 07:45    Post subject:  

When you talk about unstable connections...

I have done some research and figured out it applies to situations where one is at such places as airport, McDonald and other where there are to factors involved:

A) Probably several Wlan AP in the same system

B) Lots of laptops and phones connected

This is a thing i have realized as i never have the problem in a private home, but always in public places and its really really bad for what whatever one wants to do as the connection can drop a few hundred times in a couple of hours.

I downloaded and installed your pet to my Slacko 6.3 64 bits and now we shall see how it comes out once present at a public place next week.


atle
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
jlst

Joined: 23 Nov 2012
Posts: 571

PostPosted: Sat 05 Mar 2016, 23:45    Post subject:  

Atle, something like that...

Today I added code for ifplugd and wpa_cli. After a successful connection... apparently when these daemons are running, autoreconnection happens all the time.

I'm not quite sure of what I'm doing, I guess this should have been done years ago.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0763s ][ Queries: 11 (0.0112s) ][ GZIP on ]