Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 27 May 2017, 02:20
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko64 & slacko(32)6.3.0.6
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 5 [71 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 8629
Location: qld

PostPosted: Mon 04 Apr 2016, 00:46    Post subject:  slacko64 & slacko(32)6.3.0.6
Subject description: UEFI tests
 

http://distro.ibiblio.org/puppylinux/test/slacko64/6306/ 64 bit (from testing branch)

http://distro.ibiblio.org/puppylinux/test/slacko/6306/ 32 bit (from xorg branch)

Testing. iso and md5

You can dd it to a flash drive. read the dd manual! (watchdog found an issue with this and searching for save files - confirmed).

This has UEFI support and should boot with secure boot turned off. You do not need legacy BIOS mode.

It should also boot on a BIOS machine.

The 32 bit version should boot any BIOS 32 bit machine (of which there are very few0 but NOT UEFI 32 bit machine - it has 64 bit UEFI

Only devx is available for 32 bit version. For 64 bit use the 6.3.0 devx, only git is changed and maybe a few headers.

_________________
Puppy Linux Blog - contact me for access

Last edited by 01micko on Tue 05 Apr 2016, 03:16; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 6695
Location: Kentucky

PostPosted: Mon 04 Apr 2016, 01:23    Post subject: Re: slacko64 6.3.0.6
Subject description: UEFI
 

01micko wrote:
http://distro.ibiblio.org/puppylinux/test/slacko64/6306/

Testing. iso and md5

You can dd it to a flash drive. read the dd manual!

This has UEFI support and should boot with secure boot turned off.

It should also boot on a BIOS machine.

More to come on this .. gotta run.


Guess I'll test it but I haven't had any trouble booting regular ole Pups (or anything for that matter) on my UEFI boxes with secure boot off.

Kinda bored anyway ....... Very Happy
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6695
Location: Kentucky

PostPosted: Mon 04 Apr 2016, 01:50    Post subject: Re: slacko64 6.3.0.6
Subject description: UEFI
 

James C wrote:
01micko wrote:
http://distro.ibiblio.org/puppylinux/test/slacko64/6306/

Testing. iso and md5

You can dd it to a flash drive. read the dd manual!

This has UEFI support and should boot with secure boot turned off.

It should also boot on a BIOS machine.

More to come on this .. gotta run.


Guess I'll test it but I haven't had any trouble booting regular ole Pups (or anything for that matter) on my UEFI boxes with secure boot off.

Kinda bored anyway ....... Very Happy


As I expected, it boots fine on this UEFI box with secure boot off.

Nice boot menu by the way. Smile

Code:
# inxi -Fxx
System:    Host: puppypc26778 Kernel: 4.1.11 x86_64 (64 bit, gcc: 4.8.2)
           Desktop: JWM 2.3.2 dm: N/A Distro: Slacko64 Puppy 6.3.0.6
Machine:   Mobo: ASUSTeK model: M5A97 LE R2.0 version: Rev 1.xx serial: 150545593600028
           Bios: American Megatrends version: 2601 date: 03/24/2015
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 42156.1
           Clock Speeds: 1: 1400.00 MHz 2: 3000.00 MHz 3: 1400.00 MHz 4: 1400.00 MHz 5: 1400.00 MHz 6: 1400.00 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0 chip-ID: 10de:0a65
           X.org: 1.14.3 drivers: nouveau (unloaded: fbdev,vesa) tty size: 80x25 Advanced Data: N/A for root
Audio:     Card-1: AMD/ATI [Advanced Micro Devices ] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1002:4383
           Card-2: NVIDIA High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0be3
           Sound: Advanced Linux Sound Architecture ver: k4.1.11
Network:   Card: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 1c:87:2c:5a:bb:e2
Drives:    HDD Total Size: 1120.2GB (-)
           1: id: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB serial: N/A
           2: id: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB serial: N/A
Partition: ID: swap-1 size: 8.60GB used: 0.00GB (0%) fs: swap
RAID:      System: supported: linear raid0 raid1 raid10 raid6 raid5 raid4
           No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
           Unused Devices: none
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 133 Uptime: 7 min Memory: 258.7/15927.5MB Runlevel: 5 Gcc sys: 4.8.2
           Client: Shell (bash 4.2.53 running in urxvt) inxi: 1.9.17


Code:
# free
             total         used         free       shared      buffers
Mem:      16309768       799432     15510336       264016        80512
-/+ buffers:             718920     15590848
Swap:      8396796            0      8396796


All basics working on initial boot. Live cd , pfix=ram.

I'll try it on a traditional bios box tomorrow,grab one off the shelf and dust it off..... Very Happy
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1342
Location: Italy

PostPosted: Mon 04 Apr 2016, 15:10    Post subject:  

It boots on my bios machine using a 2 Gb flashdrive but I was not able to create a savefile which can be loaded: it's created but it is not found at successive boots. I managed to create an adrv_slacko64_6.3.0.6.sfs from my old install of slacko64_6.3.0 not uefi and it's loaded and I can manage in this way my usual install. I attach hardinfo_report.
hardinfo_report.html.zip
Description 
zip

 Download 
Filename  hardinfo_report.html.zip 
Filesize  13.39 KB 
Downloaded  149 Time(s) 
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6695
Location: Kentucky

PostPosted: Mon 04 Apr 2016, 19:57    Post subject:  

No problem booting live cd on an old socket 939 box. No UEFI in sight.

All good on initial boot.

Code:
# inxi -Fxx
System:    Host: puppypc23910 Kernel: 4.1.11 x86_64 (64 bit, gcc: 4.8.2)
           Desktop: JWM 2.3.2 dm: N/A Distro: Slacko64 Puppy 6.3.0.6
Machine:   Mobo: ASUSTeK model: A8V-MQ version: Rev 1.xx serial: MB-1234567890
           Bios: American Megatrends version: 0210 date: 03/31/2006
CPU:       Single core AMD Athlon 64 3800+ (-UP-) cache: 512 KB flags: (lm nx sse sse2 sse3) bmips: 4801.03 clocked at 2400.017 MHz
Graphics:  Card: NVIDIA NV18 [GeForce4 MX 4000] bus-ID: 05:00.0 chip-ID: 10de:0185
           X.org: 1.14.3 drivers: nouveau (unloaded: fbdev,vesa) tty size: 80x25 Advanced Data: N/A for root
Audio:     Card: VIA VT8233/A/8235/8237 AC97 Audio Controller
           driver: snd_via82xx port: e400 bus-ID: 00:11.5 chip-ID: 1106:3059
           Sound: Advanced Linux Sound Architecture ver: k4.1.11
Network:   Card: VIA VT6102 [Rhine-II] driver: via-rhine port: e800 bus-ID: 00:12.0 chip-ID: 1106:3065
           IF: eth0 state: unknown speed: 100 Mbps duplex: full mac: 00:15:f2:3d:a8:d4
Drives:    HDD Total Size: 250.1GB (-)
           1: id: /dev/sda model: WDC_WD2500AAKX size: 250.1GB serial: N/A
Partition: ID: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap
RAID:      System: supported: linear raid0 raid1 raid10 raid6 raid5 raid4
           No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
           Unused Devices: none
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 94 Uptime: 7 min Memory: 241.7/1998.7MB Runlevel: 5 Gcc sys: 4.8.2
           Client: Shell (bash 4.2.53 running in urxvt) inxi: 1.9.17



Code:
# free
             total         used         free       shared      buffers
Mem:       2046708       770252      1276456       263832        78628
-/+ buffers:             691624      1355084
Swap:      4095996            0      4095996




Code:
# report-video
VIDEO REPORT: Slacko64 Puppy, version 6.3.0.6

Chip description:
VGA compatible controller: NVIDIA Corporation NV18 [GeForce4 MX 4000] (rev a4)

Requested by /etc/X11/xorg.conf:
  Resolution (widthxheight, in pixels): 1440x900
  Depth (bits, or planes):              24
  Modules requested to be loaded:       dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
  Driver loaded (and currently in use): nouveau
  Loaded modules: dbe dri2 exa extmod fb fbdevhw glx kbd mouse shadowfb

Actual rendering on monitor:
  Resolution:  1440x900 pixels (381x238 millimeters)
  Depth:       24 planes

...the above also recorded in /tmp/report-video
#
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6695
Location: Kentucky

PostPosted: Mon 04 Apr 2016, 20:08    Post subject:  

Made savefile (folder) on ext4 partition, detected and loaded on next boot.
Screenshot(1).jpg
 Description   
 Filesize   25.19 KB
 Viewed   2542 Time(s)

Screenshot(1).jpg

Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4129
Location: Sydney Australia

PostPosted: Mon 04 Apr 2016, 20:08    Post subject:  

01micko:

Thanks uncle Mick.

Might give this a shot to fix Win 8.1 laptops.
There is an Acer and a Toshiba I have in my sites.

Chris.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 8629
Location: qld

PostPosted: Mon 04 Apr 2016, 20:18    Post subject:  

cthisbear wrote:
01micko:

Thanks uncle Mick.

Might give this a shot to fix Win 8.1 laptops.
There is an Acer and a Toshiba I have in my sites.

Chris.


Thanks uncle Chris! I hope it works as expected. I have no metal to test UEFI so testing is done in Qemu. It is now in the PPM so if you update PPM in slacko(64 or 32) 630 or derivatives you should find it in 'system' or just search 'qemu' in the search bar.

I do have a MacBook Air (wife's - don't tell!) that has EFI and it boots and runs fine there.

@watchdog - I gather this is the dd to USB? There is something strange going on there. I have to investigate further. Probably some confusion as the stick "thinks" it is a CD/DVD.

@James C - thanks for testing as usual Smile

I am in the process of adding UEFI support to 32 bit; however this won't boot 32 but UEFI machines (there are only a few) but will boot 32 bit BIOS machines. Hopefully an ISO will be posted later today.

One thing to note: the boot menu for UEFI is grub2 (thanks to jamesbond) and you will see a usual grub2 boot menu but you don't get the good old Puppy help screens (F2, F3) but on BIOS we boot with isolinux (syslinux) and then you will see the syslinux boot menu which does feature the F2 and F3 help screens with extra boot parameters.

I have made backdrops for Tahr and a generic "Puppy" version. They are just simple 800x600 png images with the version number written there later at build time in woof. The correct one should be chosen for what puppy you build. @666philb (if you read this). Please make one (or I can - just let me know what you will call the "DISTRO_FILE_PREFIX") for Xenial when you are ready.

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
LazY Puppy


Joined: 21 Nov 2014
Posts: 1923
Location: Germany

PostPosted: Mon 04 Apr 2016, 23:43    Post subject:  

Hi.

Where to find compatibility package for 32bit?

Is there any?

_________________
RSH

In Deutschland bekommt jeder Depp Asyl, sogar BW-Soldaten, weil in den Behörden die absolut größten Deppen sitzen. Mathelehrer Hungerland: wer ungeeignet scheint, für das Fach-Abi, der bewerbe sich schnell bei einer Behörde!
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 8629
Location: qld

PostPosted: Tue 05 Apr 2016, 00:03    Post subject:  

LazY Puppy wrote:
Hi.

Where to find compatibility package for 32bit?

Is there any?

Menu >> Setup >> Sfs Manager...

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
watchdog

Joined: 28 Sep 2012
Posts: 1342
Location: Italy

PostPosted: Tue 05 Apr 2016, 02:43    Post subject:  

I have burned a CD. slacko64-6.3.0.6-uefi.iso works fine on my bios machine with adrv_slacko64_6.3.0.6.sfs from a previous install in sda1 (I have copied to sda1 zdrv and the main sfs, too) and a minimal savedir on the CD.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 8629
Location: qld

PostPosted: Tue 05 Apr 2016, 03:16    Post subject:  

32 bit version is now uploaded too.

See main post

_________________
Puppy Linux Blog - contact me for access
Back to top
View user's profile Send private message Visit poster's website 
watchdog

Joined: 28 Sep 2012
Posts: 1342
Location: Italy

PostPosted: Tue 05 Apr 2016, 09:32    Post subject:  

I'm testing the 32 bit version. All works fine from CD and savefile on sda1 but I have not tray icons down right: only time and CPU usage. In .config/autostart the desktop files have NoDisplay set to "true". Changing to "false" does not solve the problem.

LATER:I have solved setting to "Variable width" the Tasklist in Desktop Settings-Tray.
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 1923
Location: Germany

PostPosted: Tue 05 Apr 2016, 20:02    Post subject:  

01micko wrote:
LazY Puppy wrote:
Hi.

Where to find compatibility package for 32bit?

Is there any?

Menu >> Setup >> Sfs Manager...

Thanks.

Already downloaded the one from tahr. Will download the one from Slacko after changing the name of my own 'sfsget' script wich currently is layered on top of the 'sfsget' from Slacko and therefor makes it impossible to download 32bit compatibility pkg by qucikpet or Slacko's sfsget.

_________________
RSH

In Deutschland bekommt jeder Depp Asyl, sogar BW-Soldaten, weil in den Behörden die absolut größten Deppen sitzen. Mathelehrer Hungerland: wer ungeeignet scheint, für das Fach-Abi, der bewerbe sich schnell bei einer Behörde!
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Tue 05 Apr 2016, 21:47    Post subject:  

So far, all is well on my HP Laptop running Live using Slacko64-6.3.0.6. I like the clean polished layout you're offering.

Testing @Geoffrey's system additions found here. (This may be an item for Repo consideration)

@01Micko,
  1. is there any advice for us touch screen users to use the distro on AIOs/Touch-Laptops/Intel-Tablets? (how to implement touch to use?)
  2. Is Menu>Setup>Updates Manager a utility for service delivery to this PUP or only a Slackware package update?
Thanks for all you have done with this. I do NOT have a UEFI PC at this time to test, but will as soon I can get to one.

Edit: Network adapters were not detected upon boot. Sytem info will be added soon.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 5 [71 Posts]   Goto page: 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1207s ][ Queries: 12 (0.0110s) ][ GZIP on ]