Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 Aug 2017, 11:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Frisbee Network Manager 1.4.6
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [31 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Fri 05 Aug 2016, 17:39    Post subject:  

greengeek,
I just now downloaded and looked at slacko-5.6. I was wrong to say the 0.x versions were the "betas", which were the original packages that form the basis for my attempt to preserve frisbee. "0.1" was my initial version. There were many improvements since that package.

The newest versions will not work on the older puppies because they require the latest version of gtkdialog.

Here is how frisbee works. If you never start it, it does nothing, at all. If you start it, then it will take control of the network. If you then run SNS or the network wizard, frisbee will be turned off, as if you never used it. So it should not interfere with those network managers. But you may need to reboot, to get SNS to see the network.
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4623
Location: Republic of Novo Zelande

PostPosted: Fri 05 Aug 2016, 18:41    Post subject:  

Thanks rerwin, i appreciate the info. cheers
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Wed 26 Apr 2017, 16:45    Post subject: Frisbee-1.4.3 uploaded  

I have updated frisbee to correct the "frisbee mode disable" function and to be compatible with a new, upgraded "network_connect_update" package that refines the support for switching network managers and ensuring that the appropriate network startup script runs during a reboot.

The new frisbee is in the first message of this thread, here:
http://www.murga-linux.com/puppy/viewtopic.php?p=898555#898555

Richard
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2809
Location: Worcestershire, UK

PostPosted: Thu 27 Apr 2017, 02:08    Post subject: Re: Frisbee-1.4.3 uploaded  

rerwin wrote:
I have updated frisbee to correct the "frisbee mode disable" function and to be compatible with a new, upgraded "network_connect_update" package that refines the support for switching network managers and ensuring that the appropriate network startup script runs during a reboot.

The new frisbee is in the first message of this thread, here:
http://www.murga-linux.com/puppy/viewtopic.php?p=898555#898555

Richard

Hi Richard

Which pets do I need to load to test the new Frisbee in a recent woof-ce build?

Thanks
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Thu 27 Apr 2017, 09:02    Post subject: Re: Frisbee-1.4.3 uploaded  

peebee wrote:
Which pets do I need to load to test the new Frisbee in a recent woof-ce build?

Frisbee 1.4.3 is backward compatible, so it can be tested alone. The only behavioral change is that it kills dhcpcd when frisbee mode is disabled. That happens when you stop using frisbee and switch to another network manager.

However, eventually I will need you to test with my new "network_connect_update" package, as I plan to enter it into woofCE. I suggest testing it both ways.
Richard

Last edited by rerwin on Thu 27 Apr 2017, 19:43; edited 2 times in total
Back to top
View user's profile Send private message 
tallboy


Joined: 21 Sep 2010
Posts: 736
Location: Oslo, Norway

PostPosted: Thu 27 Apr 2017, 11:02    Post subject:  

Hi Richard.
I would like to try Frisbee in my LupuPlus 5.2.8.005-1, which I run from a live CD. Do I have to remove some of the components in WvDial, or other network components?

tallboy

_________________
True freedom is a live Puppy on a multisession CD/DVD.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2809
Location: Worcestershire, UK

PostPosted: Thu 27 Apr 2017, 12:53    Post subject: Re: Frisbee-1.4.3 uploaded  

rerwin wrote:
peebee wrote:
Which pets do I need to load to test the new Frisbee in a recent woof-ce build?

Frisbee 1.4.3 is backward compatible, so it can be tested alone. The only behavioral change is that it kills dhcpcd when frisbee mode is disabled. That happens when you stop using frisbee and switch to another network manager.

However, eventually I will need you to test with my new "network_connect_update" package, as I plan to enter it into woofCE. I suggest testing it both ways.
Richard

Hi Richard

I was hoping that you would point me explicitly at the pets I should load.....I find all the various pets very confusing I'm afraid....I'm sure you know what needs to be done but I need some guidance....

Thanks

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Thu 27 Apr 2017, 17:28    Post subject:  

peebee,
Only network_connect_update-20170418.pet in the Network thread of that name. The other packages there are for specific types of pup.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Thu 27 Apr 2017, 18:06    Post subject:  

tallboy wrote:
I would like to try Frisbee in my LupuPlus 5.2.8.005-1, which I run from a live CD. Do I have to remove some of the components in WvDial, or other network components?

You don't need to remove anything. But you would need to add files gettext.sh and envsubst and package gtkdialog-racy_lucid-0.8.4r514. To avoid having to update the connectwizard, just make frisbee the default browser and/or edit /usr/share/applications/frisbee.desktop:
Change NoDisplay=true to NoDisplay=false to add frisbee to the Network menu.
(You also need to create /tmp/.frisbee if you test frisbee before rebooting after installation.)

I just now tried frisbee-1.4.3 with the two files, but know that the gtkdialog version is a dependency. There may be other issues. I suggest that you upgrade to lupu 5.2.8.7.

An alternative approach would be to try the last Frisbee "beta", in the "Frisbee Network Manager - Beta 2" thread. I could send you Frisbee-beta-4.pet, the last beta, if you go that route. But that could get to be a "can of worms". I wouldn't risk it.
Richard
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2809
Location: Worcestershire, UK

PostPosted: Fri 28 Apr 2017, 08:59    Post subject:  

Hi Richard

Seems to work OK - did a few wifi swaps between sns and frisbee and they worked as expected.....woof-ce update?

Thanks
peebee
Screenshot.png
 Description   
 Filesize   152.72 KB
 Viewed   230 Time(s)

Screenshot.png


_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Fri 28 Apr 2017, 14:25    Post subject:  

peebee,
Thanks for running the tests. I am starting on the woofCE submission, now.
R
Back to top
View user's profile Send private message 
tallboy


Joined: 21 Sep 2010
Posts: 736
Location: Oslo, Norway

PostPosted: Fri 28 Apr 2017, 15:02    Post subject:  

Thank you, Richard.
I think I'll wait until I upgrade my Puppy, my present setup works OK. (sort of)
tallboy

_________________
True freedom is a live Puppy on a multisession CD/DVD.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Wed 17 May 2017, 19:55    Post subject:  

A new version is uploaded to the first message:
http://www.murga-linux.com/puppy/viewtopic.php?p=883858#883858

It is compatible with both the connect_update and network_connect_update packages, and is required for the latter.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1813
Location: Maine, USA

PostPosted: Thu 15 Jun 2017, 16:16    Post subject:  

A new version (1.4.5) is uploaded to the first message:
http://www.murga-linux.com/puppy/viewtopic.php?p=883858#883858

It adds the ability to use WiFi channels 12-14 where legal. Although it remains compatible with both the connect_update and network_connect_update packages, and is required for the latter, the capability is available only if network_connect_update-20170612 and quicksetup-20170612 (or later) are installed. See the 6/15/2017 update in the first message of this thread.
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 229
Location: Yugoslavija

PostPosted: Tue 18 Jul 2017, 03:20    Post subject: xenialdog-frisbee-i386-deb  

COMPLIMENTS rerwin!

IF YOU HAVE A TIME, CAN YOU SEE WHY THIS
FRISBEE CAN NOT AUTOMATICALLY RECONNECT?
REGARDS.



https://ulozto.net/!8cozr1hMoGKJ/xenialdog-frisbee-i386-deb
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [31 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0630s ][ Queries: 14 (0.0070s) ][ GZIP on ]