Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 17 Oct 2017, 00:14
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Xenialpup CE 7.0.8.1
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 31 [465 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 29, 30, 31 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 11623
Location: Stratford, Ontario

PostPosted: Tue 26 Apr 2016, 07:35    Post subject:  

@David: I cannot replicate your problem. Try a clean setup with no installed packages.

@Phil: There are indeed numerous missing files. I have pulled them out of Tahrpup605 and assembled them in a PET here.

1. /etc/cups/snmp.conf is needed to detect network printers. It also needs a CUPS restart.

2. /usr/share/cups is missing a bunch of stuff. The most crucial file is mime.convs.

3. The CUPS filter /usr/lib/cups/filter/pdftops is broken. The version from Tahrpup works.

4. The SANE config file /etc/sane.d/dll.conf is missing.

I have run a full suite of print/scan tests and everything now works.

However, I cannot get dir2pet to work with xz compression.

BTW, I have posted a new PeasyScan v2.9 here.

[Edit] PeasyPort needs an upgrade to v2.1 and YASSM needs an upgrade to v2.9.
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 237

PostPosted: Tue 26 Apr 2016, 12:42    Post subject:  

rcrsn51:

I was trying earlier today to activate my canon printer/scanner, with no success.

Installed your cups patch.pet and the other printer pets you recommended.

Having already installed your candi.pet and the canon driver.debs both printer and scanner are working well.

Would have no chance of doing any of this without your help.

Thanks as always.
irishrm.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11623
Location: Stratford, Ontario

PostPosted: Tue 26 Apr 2016, 13:02    Post subject:  

Excellent. Now that you have all the Canon Debian packages downloaded, you should use candi-pet-maker to build your own print/scan driver PET. Read here.

@Phil: I find the default Xenialpup theme difficult to read. It's gray text on a gray background on a white desktop.
Back to top
View user's profile Send private message 
irishrm


Joined: 14 Mar 2009
Posts: 237

PostPosted: Tue 26 Apr 2016, 14:07    Post subject:  

rcrsn1:

Just made a canon printer.pet for 32 bit OS. Looks good, will test when doing the next new install. Will also try making the combo pet later.

Its great to learn something new.

O for the know-how.

Thanks again.
irishrm.
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1246

PostPosted: Tue 26 Apr 2016, 14:56    Post subject:  

rcrsn51 wrote:
However, I cannot get dir2pet to work with xz compression.

I got it to work in Slacko 6.3.0.6, but it wasn't easy (example pet of the spot dir):

cd /root
mkdir -p new/spot_xz/root
mkdir -p new/spot_gz
cp -r spot new/spot_xz/root
cp -r new/spot_xz/root new/spot_gz
cd new
dir2pet spot_xz -x -s -w="spot gets xzed"
dir2pet spot_gz -g -s -w="spot gets gzed"
mv *.pet ..
cd ..
rm -rf new
ls *.pet -l


Not sure if root permissions need to be changed first. But if typing "which xz" shows nothing in Xenial, dir2pet won't work.
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 28 Apr 2016, 03:04    Post subject: so nonody complains about the kernel ! that is fine.  

so nonody complains about the kernel ! that is fine.
Why, that prooves that people need a kernel which fit their computeur, no more. Let the Puppy as is, please.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
rcrsn51


Joined: 05 Sep 2006
Posts: 11623
Location: Stratford, Ontario

PostPosted: Thu 28 Apr 2016, 08:41    Post subject: Re: so nonody complains about the kernel ! that is fine.  

Pelo wrote:
so nonody complains about the kernel ! that is fine. Why, that prooves that people need a kernel which fit their computeur, no more. Let the Puppy as is, please.

If anyone wants a newer k4.x kernel, they can use the procedure here
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Thu 28 Apr 2016, 18:24    Post subject:  

Hi.

Since Ubuntu Xenial Xerus seems to be a LTS version:

- any plans to build a Xenial Puppy in 64bit?

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 987
Location: Chatswood, NSW

PostPosted: Thu 28 Apr 2016, 20:10    Post subject: Fresh install and CUPS works
Subject description: My problem isolated to my printer sfs
 

G'day rcrsn51,

Thanks for your reply to my Xenial CUPS problem.

Finally I got around to running CUPS in a clean Xenial frugal install (deleted the Save file and used an 'empty' Boot manager).

CUPS ran with no added sfs Smile and then with four out of five of my standard-frugal 'home-made' sfs Very Happy .

I'd just recently made an sfs of the Epson printer and scanner pets and when I loaded this, CUPS gave the problem Embarassed .

Installing the printer .pet and I could run CUPS so I need to re-visit my printer+scanner .sfs to check what it's/they're doing.

All good fun Rolling Eyes .

David S.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Thu 28 Apr 2016, 22:24    Post subject:  

666philb -- I can report, finally, that there is a working OpenChrome version that supports the VIA VX855 chipset. I have the *.so and *.la as compiled in the TahrPup 6.0.2-based X-Tahr 1b3. (I assume that they will work in TahrPup 6.0.5 as well...? Kernel 3.14.20 is what I have right now.)

The current Git version of OpenChrome (as of this post) is the one I've compiled. I don't have XenialPup at the moment, but I'm happy to try and compile it.

If XenialPup still uses (as I suspect it does) OpenChrome v.0.3.3 -- that is a known BAD configuration that will not function on systems using the VX855 and similar chipsets, which means that anyone with that hardware is stuck in text mode.

I don't have a complete list of systems, of course, that use the affected chipsets -- but it's going to include, at least, a number of oddball thin clients and perhaps other systems as well.

Again, I have a compiled openchrome_drv.so and openchrome_drv.la for TahrPup 6.0.2, and I can compile it again for any other Pup you might need or want it in -- and I'm more than happy to do that, as well.

_________________

Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Tue 03 May 2016, 04:59    Post subject: xenialpup installed without any trouble at home  

xenialpup installed without any trouble at home, wireless connected.
This Puppy can work immediately, and obey my orders Smile

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Billtoo


Joined: 07 Apr 2009
Posts: 3237
Location: Ontario Canada

PostPosted: Tue 03 May 2016, 07:18    Post subject: Xenialpup 7.0.0  

Manual frugal install to a usb-3.0 SSD, pc is a HP mini Stream:

Computer
Processor 2x Intel(R) Celeron(R) 2957U @ 1.40GHz
Memory 1983MB (128MB used)
Machine Type Physical machine
Operating System xenial - 7.0.0
User Name root (root)
Date/Time Mon 02 May 2016 05:55:36 AM EDT
Display
Resolution 1920x1080 pixels
OpenGL Renderer Mesa DRI Intel(R) Haswell Mobile x86/MMX/SSE2
X11 Vendor The X.Org Foundation
Audio Devices
Audio Adapter HDA-Intel - HDA Intel HDMI
Audio Adapter HDA-Intel - HDA Intel PCH
Audio Adapter PC-Speaker - pcsp

SCSI Disks
ATA SanDisk SDSA6MM-
SONY DVD RW DRU-820A
TOSHIBA MQ01ABD100
OpenGL
Vendor Intel Open Source Technology Center
Renderer Mesa DRI Intel(R) Haswell Mobile x86/MMX/SSE2
Version 3.0 Mesa 11.2.0
Direct Rendering Yes

I updated PPM and installed kdegames,smplayer,and gkrellm.

It's working well so far.
screenshot.jpg
 Description   
 Filesize   34.25 KB
 Viewed   1110 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
tony

Joined: 14 Jan 2006
Posts: 326
Location: Montreal.ca

PostPosted: Thu 05 May 2016, 08:56    Post subject:
Subject description: skype
 

Hi watchdog,

I loaded your skype sfs but no pulseaudio.

your pulseaudio 4.0-tahr-i686.pet link is down..

skype is a pig to get working I know so thanks for your efforts.

Regards Tony.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1450
Location: Italy

PostPosted: Thu 05 May 2016, 11:12    Post subject:
Subject description: skype
 

tony wrote:
Hi watchdog,

I loaded your skype sfs but no pulseaudio.

your pulseaudio 4.0-tahr-i686.pet link is down..

skype is a pig to get working I know so thanks for your efforts.


Copy.com has been discontinued. For the tahr pulseaudio pet use the following link:

https://drive.google.com/file/d/0B9iMb4UZBeFkUkRtcjZYMXVwdlE/view?usp=sharing

Install it after loading the sfs: it was necessary to me to get the my xenial skype working. I have been using it for some weeks so I'm sure it can work.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3096
Location: wales

PostPosted: Thu 05 May 2016, 17:41    Post subject:  

BarryK wrote:
peebee wrote:
These are the errors that are being added to the typed wifi key (0123456789 was typed)
Quote:
Line 0: Invalid passphrase length 235 (expected: 8..63) 'Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
0123456789"'.


Great that 666philb is embarking on a Xenial Xerus pup!

I posted about this FcBlanks error:

http://murga-linux.com/puppy/viewtopic.php?p=899326#899326
thanks BarryK & peebee,

on further investigation xenialpup & tahrpup use /etc/fonts/font.conf from the fontconfig-config package. This and fonts-dejavu-core were suggested by iguleder to improve font rendering, especially in the browser.

however the font.conf in the xorg_base template was overwriting it!

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 31 [465 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 29, 30, 31 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0669s ][ Queries: 14 (0.0134s) ][ GZIP on ]