Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 12 Dec 2019, 16:19
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Xenialpup CE 7.5 / 25 Nov 2017
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 54 [799 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 52, 53, 54 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 17:44    Post subject: Re: pup_event_frontend_d to be manually activated  

charlie6 wrote:
Hi 666philb,

have noticed this on a pristine installation of Xenialpup 7.0.0:

clicking on a disk icon (here sda6) opens a rox window showing sda6 directory; and a green flag pops up in the upper-right corner of the disks icon.

pmount shows that sda6 is mounted;

clicking on that green flag is expected to unmount the correcponding disk; and aftrwds to swith of that green flag.

Here, what happens:
when clicking on that green flag, pmount shows that the disk is effectively unmounted; but the green flag keeps displaying.

To switch it off, doing
Code:
# pup_event_frontend_d

in a console switch it off

Cheers, Charlie


this problem is annoying me and i'm not sure what's causing it. it seems the pup_event_frontend_d daemon isn't working properly Confused

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 17:46    Post subject:  

watchdog wrote:
The losetup in initrd.gz is the right one. I have copied it in the main sfs (rebuilding it) in /bin and in /sbin as losetup-FULL and I did a symlink to /bin/busybox in /sbin dir named losetup. Now encryption is working and I can mount encrypted savefiles by filemnt.


i did include /sbin/losetup-FULL ...what else is needed for encryption to work?

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 17:49    Post subject: Re: Xenialpup 7.0.0
Subject description: nearly beta
 

peebee wrote:
666philb wrote:
Xenialpup nearly BETA
problems so far...
ddcprobe segfaults

hwclock also segfaults so time/date is wrong:
Code:
root# dmesg | grep "segfault"
[   26.229957] hwclock[8251]: segfault at 0 ip b75883d1 sp bfbfdcac error 4 in libc-2.23.so[b7515000+1ad000]
[   26.631299] ddcprobe[8362]: segfault at c0e86 ip 00000e86 sp 00000ffa error 15 in mem[0+1000]
[   27.412937] ddcprobe[8430]: segfault at c0e86 ip 00000e86 sp 00000ffa error 15 in mem[0+1000]
root#


ddcprobe now ok in the new iso
hwclock still segfaults when booting but runs fine once booted

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 17:50    Post subject:  

peebee wrote:
Duplication? - Default Applications Chooser can be dropped from build if PuppyApps D.A.C. is chosen in woof-ce....


oops ...i missed this.
cheers

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 17:51    Post subject: Re: Xenialpup 7.0.0
Subject description: nearly beta
 

Puppus Dogfellow wrote:
666philb wrote:
Xenialpup nearly BETA

[...]
abiword crashes Very Happy
[...]


Have you considered focuswriter? haven't tested it much but it's very lightweight and capable, and it appears to be reliable. Very Happy

anyway, here's a mirror, 666philb:

xenialpup


thanks for the mirror

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 17:59    Post subject:  

rcrsn51 wrote:
@David: I cannot replicate your problem. Try a clean setup with no installed packages.

@Phil: There are indeed numerous missing files. I have pulled them out of Tahrpup605 and assembled them in a PET here.

1. /etc/cups/snmp.conf is needed to detect network printers. It also needs a CUPS restart.

2. /usr/share/cups is missing a bunch of stuff. The most crucial file is mime.convs.

3. The CUPS filter /usr/lib/cups/filter/pdftops is broken. The version from Tahrpup works.

4. The SANE config file /etc/sane.d/dll.conf is missing.

I have run a full suite of print/scan tests and everything now works.

However, I cannot get dir2pet to work with xz compression.

BTW, I have posted a new PeasyScan v2.9 here.

[Edit] PeasyPort needs an upgrade to v2.1 and YASSM needs an upgrade to v2.9.


thanks rcrsn51,

barryk wrote that used the ubuntu cups for his xenial, so i decided to give that a try and it's working for me. so i've gone with that for this build (7.0.1).

i'll add your updated peasy apps in 7.0.2... i'll concentrate updating a lot of other packages then as well.

cheers

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 18:00    Post subject:  

rcrsn51 wrote:
Excellent. Now that you have all the Canon Debian packages downloaded, you should use candi-pet-maker to build your own print/scan driver PET. Read here.

@Phil: I find the default Xenialpup theme difficult to read. It's gray text on a gray background on a white desktop.


is this the gtk theme or the jwm theme?

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 18:02    Post subject:  

LazY Puppy wrote:
Hi.

Since Ubuntu Xenial Xerus seems to be a LTS version:

- any plans to build a Xenial Puppy in 64bit?


yes hopefully once the 32bit done (or nearly done) Very Happy

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 18:05    Post subject:  

starhawk wrote:
666philb -- I can report, finally, that there is a working OpenChrome version that supports the VIA VX855 chipset. I have the *.so and *.la as compiled in the TahrPup 6.0.2-based X-Tahr 1b3. (I assume that they will work in TahrPup 6.0.5 as well...? Kernel 3.14.20 is what I have right now.)

The current Git version of OpenChrome (as of this post) is the one I've compiled. I don't have XenialPup at the moment, but I'm happy to try and compile it.

If XenialPup still uses (as I suspect it does) OpenChrome v.0.3.3 -- that is a known BAD configuration that will not function on systems using the VX855 and similar chipsets, which means that anyone with that hardware is stuck in text mode.

I don't have a complete list of systems, of course, that use the affected chipsets -- but it's going to include, at least, a number of oddball thin clients and perhaps other systems as well.

Again, I have a compiled openchrome_drv.so and openchrome_drv.la for TahrPup 6.0.2, and I can compile it again for any other Pup you might need or want it in -- and I'm more than happy to do that, as well.


hi starhawk

glad you finally sorted this Cool
it might be best to compile it in xenialpup as it is probably compiled for a particular xorg version.

keep hold of the tahrpup ones though and i'll include them in the next tahrpup iso

thanks

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
yr1945

Joined: 17 Apr 2010
Posts: 208

PostPosted: Thu 05 May 2016, 18:22    Post subject: suspend capability?  

just a quick note to ask for help to suspend Xenialpup 7.0.0... on almost every "puppy" plus "quirkies" I can add acpitool and pupshutdown and then have the capability to suspend the "puppies"... in a few "puppies", eg, Slacko 6.3.0, they automatically suspend when I close the lid (or just move the lid close to the latch)... however, Xenialpup 7.0.0 (and all pups created by 666philb) will not suspend on my laptop... the screen just dims and then pops back on even after installing acpitool and pupshutdown... is it just unique to my laptop (dell latitude 64 bit e6400)? thank you for your support...
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 18:34    Post subject:  

new iso uploaded http://distro.ibiblio.org/puppylinux/test/xenialpup/

switched to kernel 4.5.2 .. this is the first 4* kernel that works with my nvidia card.
ddcprobe doesn't segfault anymore
fixed Unable to update the static FcBlanks: error
switched to ubuntu's cups and my printer now works
added missing xsane stuff and my scanner now works
added gtk3 ...lot's of packages in the ubuntu repos now have it as a dependency and also firefox now needs it.. adds some size though.
added the brilliant puppy icon theme by 01micko http://blog.puppylinux.com/?viewDetailed=00016 icons in palemoon,abiword,transmission,geany etc all puppyfied Very Happy

----------------------------------
problems ...

'pup_event_frontend_d' isn't working properly and so the mount and unmount icons on the drives aren't working

----------------------------------

to do.....

update lots of apps ... peasyapps,pfind etc
remove qt4
tweak jwm theme

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331

Last edited by 666philb on Thu 05 May 2016, 18:41; edited 1 time in total
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3511
Location: wales

PostPosted: Thu 05 May 2016, 18:37    Post subject: Re: suspend capability?  

yr1945 wrote:
just a quick note to ask for help to suspend Xenialpup 7.0.0... on almost every "puppy" plus "quirkies" I can add acpitool and pupshutdown and then have the capability to suspend the "puppies"... in a few "puppies", eg, Slacko 6.3.0, they automatically suspend when I close the lid (or just move the lid close to the latch)... however, Xenialpup 7.0.0 (and all pups created by 666philb) will not suspend on my laptop... the screen just dims and then pops back on even after installing acpitool and pupshutdown... is it just unique to my laptop (dell latitude 64 bit e6400)? thank you for your support...


see if 7.0.1 works as it has an updated kernel,

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12805
Location: Stratford, Ontario

PostPosted: Thu 05 May 2016, 18:57    Post subject:  

@666philb: Be aware that the latest PeasyPort PET now contains two binaries - arp-scan and pnscan.
Back to top
View user's profile Send private message 
yr1945

Joined: 17 Apr 2010
Posts: 208

PostPosted: Thu 05 May 2016, 19:21    Post subject: suspend capability?  

@666philb... no... Xenialpup 7.0.1, will not suspend... it's a strange situation... it's either associated/related to your process for building "pups" or it's something to do with my old laptop... the only "pups" that will not suspend are the ones you create... anyway, thank you for trying to help...

does anyone else have a problem suspending Xenial or tahr pups?
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Thu 05 May 2016, 19:46    Post subject:  

@666philb -- just now saw your comment. I'll download Xenial tonight and do the driver thing sometime this coming week (might be a tad sooner than that, but don't hold your breath).

FWIW, I'm in the middle of like twelve things right now (including building myself a new system, which right now is not going together entirely gracefully...) so it might be a bit.

But I *will* do it.

_________________

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 54 [799 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 52, 53, 54 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0785s ][ Queries: 12 (0.0228s) ][ GZIP on ]