Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Oct 2018, 08:04
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Xenialpup CE 7.5 / 25 Nov 2017
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 37 of 51 [752 Posts]   Goto page: Previous 1, 2, 3, ..., 35, 36, 37, 38, 39, ..., 49, 50, 51 Next
Author Message
bigpup


Joined: 11 Oct 2009
Posts: 11137
Location: Charleston S.C. USA

PostPosted: Thu 14 Dec 2017, 22:31    Post subject:  

My guess! Idea

Installed on a USB flash drive.

A normal kernel line for Tahrpup installed as a frugal install in a directory named:
tahr606uefi

All the Tahrpup files are in this directory, including the save.
Code:
kernel /tahr606uefi/vmlinuz   psubdir=tahr606uefi pmedia=usbflash pfix=fsck

Notice the order of the options!

The saves you made on the laptop could have some, specific to the laptop, hardware setup in the save.
It could have settings for the touchpad.
These would be very specific settings.
Desktops do not have touchpads.
But this save could be looking for one and think that is all it should have to find.

The desktop save is going to also have hardware settings, but they are going to be more general in nature. Not so specific.
Desktops are not that different in the general hardware setup.
(this is a keyboard, this is the mouse. that is about it)
It looks for things like touchpads, because nothing is telling it not too.

Why the desktop save will work in everything could be because it is setup, with general settings, that work on a lot of different hardware.

Note:
Usually using a save from one computer to another.
The hardware setup is the troublesome thing.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
proebler

Joined: 24 Jan 2012
Posts: 142
Location: TAS

PostPosted: Fri 15 Dec 2017, 00:39    Post subject:  

mikesir's
Quote:
The SaveFiles you create on a laptop don't work when you try to use them on a desktop
and
bigpup's guess
Quote:
The saves you made on the laptop could have some, specific to the laptop, hardware setup in the save.
It could have settings for the touchpad.
These would be very specific settings.
Desktops do not have touchpads.
But this save could be looking for one and think that is all it should have to find.

are likely to be correct.
I have placed the files for a frugal slacko-6.9.6.4 into a separate directory on the same USB.
Then went on to run and create savefiles for that slacko on the P4 and on one of the laptops.
The result is the same as with xenialpup-7.5, i.e. no keyboard and no mouse available on the desktop machines, when the savefile created on the laptop is used.

I should have posted this probably in House Training > Users instead of here on the Xenialpup CE 7.5 topic. My apology.

Also, I made a mistake when I wrote that I use pmedia=atahd in the kernel line of the Grub4Dos menu.lst.
I am actually using pmedia=ataflash. My usage of this comes from forcing Pupmode 13 with frugal HD installs.
With a USB flashdrive, both pmedia=ataflash and pmedia=usbflash seem to work.
Following mikesir's suggestion I have created savefile(s) after booting with
pmedia=usbflash pfix=ram psubdir=/some_subdir
it made no difference.

I may do one more thing, when I have some time, change from Grub4Dos to simply Grub.

Thanks to all for your help.
proebler
Back to top
View user's profile Send private message 
redandwhitestripes

Joined: 02 Jan 2009
Posts: 179

PostPosted: Fri 15 Dec 2017, 01:55    Post subject:  

In xenial pup 32 I can't mount my xfs partition. Xenial pup 64 is OK for me, but my drives on my 64 bit desktop don't include xfs. From searching and scanning this thread, I see there are other hitches related to drive-mounting but the discussion is a little too abstract for moi Smile

I'll stick with Tahr until that hitch is solved. Xenial looks great, though!
Back to top
View user's profile Send private message 
rufwoof

Joined: 24 Feb 2014
Posts: 2599

PostPosted: Fri 15 Dec 2017, 06:31    Post subject:  

SneekyLinux Xenial pup video https://youtu.be/N2K1NVLFFZw
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 2981

PostPosted: Fri 15 Dec 2017, 08:23    Post subject:  

redandwhitestripes wrote:
In xenial pup 32 I can't mount my xfs partition. Xenial pup 64 is OK for me, but my drives on my 64 bit desktop don't include xfs. From searching and scanning this thread, I see there are other hitches related to drive-mounting but the discussion is a little too abstract for moi Smile

This has nothing to do with drive mounting "problems"
Xenial kernels are not configured to include the xfs module.
Maybe try another kernel till a new one is provided for Xenial

Edit

...or you can make the module and insert it as such:
Make sure you load devx and kernel_source SFSs
then in the terminal type (copy/paste)
Code:
cd /lib/modules/$(uname -r)/build/
zcat /proc/config.gz > .config
make oldconfig
geany .config

In geany find the line with
"# CONFIG_XFS_FS is not set"
and change it to
"CONFIG_XFS_FS=m"
savefile and close.
Back in interminal type
Code:
make prepare #Accept the defaults in all the questions
make modules_prepare
make SUBDIRS=scripts/mod
make SUBDIRS=fs/xfs modules
mkdir -p /lib/modules/$(uname -r)/kernel/fs/xfs
cp -a --remove-destination fs/xfs/xfs.ko /lib/modules/$(uname -r)/kernel/fs/xfs/
depmod -a
modprobe xfs

You can add the last line in your /etc/rc.d/rc.local to be loaded in every boot so xfs will work
You will also need to install xfsprogs with PPM

Edit 2
...or just isntall the attached pet (and xfsprogs from PPM)
xfs_module_4.4.95-1.pet
Description  xfs module for 4.4.95 Xenial 32 kernel
pet

 Download 
Filename  xfs_module_4.4.95-1.pet 
Filesize  223.81 KB 
Downloaded  162 Time(s) 

_________________
== Here is how to solve your Linux problems fast ==

Last edited by mavrothal on Sat 16 Dec 2017, 07:41; edited 2 times in total
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1546

PostPosted: Fri 15 Dec 2017, 09:39    Post subject:  

@proebler: I would also make sure when you boot that the splash screen shows that it loads the zdrv. Whenever I forget to include the zdrv I get stuff like that happening (no keyboard, mouse, wifi, etc.). That might be related to mikeslr's point too as maybe it's looking for the zdrv on the hard drive instead of usb (not sure as I never tried using a grub line like yours though).
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3579
Location: Ontario Canada

PostPosted: Sun 17 Dec 2017, 21:40    Post subject: Xenialpup CE 7.5  

I installed to a 32gb SDHC card to use with my Compaq-Presario:

video-info-glx 1.5.3 Sun 17 Dec 2017 on xenialpup 7.5 Linux 4.1.48 i686
2.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)

X Server: Xorg Driver: intel
X.Org version: 1.18.4
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) G33 x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 17.0.7

Pentium(R) Dual-Core CPU E5200 @ 2.50GHz
Core 0: @1200 1: @1200 MHz

I changed kernels to the one that I use in Dpup-Stretch.

Works well.
screenshot.jpg
 Description   
 Filesize   93.79 KB
 Viewed   1769 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
redandwhitestripes

Joined: 02 Jan 2009
Posts: 179

PostPosted: Tue 19 Dec 2017, 22:59    Post subject:  

Thank you Mavrothal, I'll try that method to get XFS working.
Back to top
View user's profile Send private message 
hamoudoudou

Joined: 24 Jul 2014
Posts: 1467
Location: rabat

PostPosted: Sun 24 Dec 2017, 03:21    Post subject: Yonn Lopez teaches newbies how to install Xenialpup,  

Yonn Lopez teaches newbies how to install Xenialpup, that is in English, not easy
"Published on Dec 7, 2017
Xenialpup is an upgrade build to the Tahrpup series, is very stable and lightweight perfect for older computers but it will also play well with new ones, available for 32 and 64 bit architecture
."
Yonn Lopez speaks slowly enough to be understood by People level more than 600 in English (TOEIC)
What about scores?
The TOEIC Reading and Listening gives a score between 10 and 990:
905 - 990 International Proficiency
785 – 900 Working Proficiency Plus
605 – 780 Limited Working Proficiency Cool
405 – 600 Elementary Proficiency Plus
255 – 400 Elementary Proficiency
185 – 250 Memorised Proficiency
10 – 180 No Useful Proficiency
Yonn Lopez.jpg
 Description   Who could translate to spanish, french, or Catalan ?
 Filesize   13.32 KB
 Viewed   1413 Time(s)

Yonn Lopez.jpg

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3499
Location: Worcestershire, UK

PostPosted: Wed 27 Dec 2017, 06:03    Post subject: mtpaint & .gif  

@ssindian has reported a problem with .gif files and mtpaint in ArtfulPup which also applies to XenialPup-7.5:

http://murga-linux.com/puppy/viewtopic.php?p=978449#978449

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 11137
Location: Charleston S.C. USA

PostPosted: Fri 29 Dec 2017, 04:22    Post subject:  

666philb,

When you going to update the iso with the missing atheros driver modules?
http://distro.ibiblio.org/puppylinux/puppy-xenial/32/atheros_kernel_modules-4.4.95noPAE-xenial32.pet

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3200
Location: wales

PostPosted: Sun 31 Dec 2017, 13:31    Post subject: Re: gnumeric preview needs symlink to qpdfview  

charlie6 wrote:
Hi Phil,

on this 7.5 version, gnumerics preview reports in terminal: Sad
Code:
root# gnumeric
/usr/bin/evince: line 13: exec: epdfview: not found

as qpdfview is the onboard pdfviewer, just made the following symlink to fix it ! Smile
Code:
ln -s /usr/bin/qpdfview /usr/bin/epdfview

(to mention:
1) on previous versions, it happened that gnumeric asked for evince-previewer; now it claims for epdfview ; now it is evince that claims for epdfview instead of evince-previewer;
2) this xenialpup-7.5 runs like a charm Razz ! )

HTH and have a nice day whatever the weather today Very Happy !
charlie


cheers charlie6 fixed

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3200
Location: wales

PostPosted: Sun 31 Dec 2017, 13:38    Post subject: Re: mtpaint & .gif  

peebee wrote:
@ssindian has reported a problem with .gif files and mtpaint in ArtfulPup which also applies to XenialPup-7.5:

http://murga-linux.com/puppy/viewtopic.php?p=978449#978449


cheers peebee, updated the mtpaint.pet and fixed in quickpet

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Replicators

Joined: 02 Jan 2018
Posts: 8

PostPosted: Tue 02 Jan 2018, 18:45    Post subject:  

I am trying to instal this on a acer one zg5 and i cannot seem to get wifi to work on it, i tried the "atheros_kernel_modules-4.4.95noPAE-xenial32.pet" but still doesn't work. I tried the slacko puppy linux and wifi did work on it, but that distro is too out of date now and i want something more up to date.

It say's on bottom "Atheros AR5BXB63" and i don't know if that mean's anything, but i do know the wireless adapter is a atheros. The above package mentioned didn't work though, and i really do not want to use slacko. What can i do?
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2697
Location: 500 seconds from Sol

PostPosted: Tue 02 Jan 2018, 20:13    Post subject:  

Hi Replicators,

Edit: See bigpup's post further down. Deleted as it contains misinformation. I wasn't running 7.5 and wrongly recalled. Forum doesn't enable a 'strick-out' of text.

mikesLr

p.s. Or you could try one of the newer derivatives based on Slacko by 8Geee, mistfire and others that you'll find on the Derivatives SubForum. I don't know if these contain the driver you need.

Last edited by mikeslr on Wed 03 Jan 2018, 09:15; edited 1 time in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 37 of 51 [752 Posts]   Goto page: Previous 1, 2, 3, ..., 35, 36, 37, 38, 39, ..., 49, 50, 51 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2366s ][ Queries: 14 (0.1306s) ][ GZIP on ]