Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 26 May 2018, 19:47
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
XenialDog (Ubuntu 16.04 'Xenial Xerus' LTS, 32-bit)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 58 of 65 [965 Posts]   Goto page: Previous 1, 2, 3, ..., 56, 57, 58, 59, 60, ..., 63, 64, 65 Next
Author Message
Null_ID

Joined: 19 Dec 2017
Posts: 6

PostPosted: Wed 27 Dec 2017, 19:55    Post subject:  

Coolio, thanks a bunch, guys!
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1472
Location: GERMANY

PostPosted: Thu 28 Dec 2017, 09:07    Post subject:  

Hi Fred !
When i wrote " Bionic Dog " does not suspend i meant when going to >Menu>Logout ......choosing Suspend ......does not work for me .

But this is no big Deal ...

Cheers !
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 2987
Location: holland

PostPosted: Thu 28 Dec 2017, 15:14    Post subject:  

backi wrote:
Hi Fred !
When i wrote " Bionic Dog " does not suspend i meant when going to >Menu>Logout ......choosing Suspend ......does not work for me .

But this is no big Deal ...

Cheers !


Hey backi, yes, I did understood Menu > Logout > Suspend doesn't work for you
The executed command for that is "pm-suspend", so I just like to know if it doesn't work for anyone what could be the reason exactly (to look for bugs and possible improvements).
So that's why I asked you for output of "pm-suspend" , it could be help for further improvement (anyway nice that you did solve it your own way, btw)

Regards !

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1472
Location: GERMANY

PostPosted: Thu 28 Dec 2017, 15:57    Post subject:  

Hi Fred !

pm-suspend does not work for me.
When put it in terminal no message .

Hardware related Issue ?
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5027
Location: Ontario

PostPosted: Fri 29 Dec 2017, 17:02    Post subject:  

I couldn't get my simple timer PTM timer to work in Bionic,
because Bionic uses mpv to play music.
However is mpg123 or mpg321 was installed it should work.
http://murga-linux.com/puppy/viewtopic.php?t=112410
___________________________________________
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 490
Location: Scotland

PostPosted: Tue 02 Jan 2018, 13:17    Post subject:  

Hello All,
I have installed Xenial Dog (32bit) to an ntfs partition on one hdd on an old HP desktop. I also have three pups on this partition all frugal installs. I also have Ubuntu installed on an ext4 partition on a separate hdd, full install, and am booting from this one with grub2. I've gone through all the problems already mentioned in booting the pups the the dog with grub2 but all are now working. I'm more used to grub4dos. Also had problems with frisbee but changed to wicd and it works fine. I have gqrx, which is a software defined radio application, installed and working on Ubuntu but I cannot get it to work in Xenial Dog. I have tried two installation methods.

1. I've used the package manager. This was easy and all seemed to go well but it does not load from it's menu entry. I get this output if I run it in a terminal.

Code:
root@xenial:~# gqrx
linux; GNU C++ version 5.3.1 20151219; Boost_105800; UHD_003.009.002-0-unknown

Controlport disabled
No user supplied config file. Using "default.conf"
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.9
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy redpitaya
Using Volk machine: sse2_32_mmx_orc
FM demod gain: 1.52789
IQ DCR alpha: 1.04166e-05
/build/gqrx-sdr-3kG_Pj/gqrx-sdr-2.5.1/src/pulseaudio/pa_sink.cc: pa_simple_new() failed: Connection refused
Using audio backend: N/A
New filter offset: 0 Hz
BookmarksFile is /root/.config/gqrx/bookmarks.csv
Loading configuration from: "default.conf"
Configuration file: "/root/.config/gqrx/default.conf"
Crash guard triggered!


The image gqrx2(see attached) also appears. If I click on this I get this output.

Code:
Launching I/O device editor
firstTimeConfig
CIoConfig : Available input devices:
    0 : "Realtek RTL2838UHIDIR SN: 00000001"
    1 : "RFSPACE SDR-IQ Receiver"
    2 : "RFSPACE SDR-IP Receiver"
    3 : "RFSPACE NetSDR Receiver"
    4 : "RFSPACE Cloud-IQ Receiver"
    5 : "RTL-SDR Spectrum Server"
    6 : "Red Pitaya Transceiver Server"
    7 : "Complex Sampled (IQ) File"


My device is marked as '0' here but I can't choose it. When I try I can type '0' but the cursor only moves to the next line.

2. This second method is the one I used to install in Ubuntu. The instructions are here.

http://gqrx.dk/download/install-ubuntu

However, I have to install these repositories first then update.

Code:
sudo add-apt-repository -y ppa:bladerf/bladerf
sudo add-apt-repository -y ppa:ettusresearch/uhd
sudo add-apt-repository -y ppa:myriadrf/drivers
sudo add-apt-repository -y ppa:myriadrf/gnuradio
sudo add-apt-repository -y ppa:gqrx/gqrx-sdr
sudo apt-get update


I've tried this without the sudo but get this output for the first of the above. The others give similar outputs.

Code:
root@xenial:~# add-apt-repository -y ppa:bladerf/bladerf
Utility to add Ubuntu PPA in your Debian machine
usage: sudo add-apt-repository ppa:user/ppa-name [ubuntu_release]
e.g.:  sudo add-apt-repository ppa:rvm/smplayer trusty
If no Ubuntu release is given, the default will be 'xenial'
root@xenial:~#


You may have guessed by now that I know very little about Ubuntu and this carries over into Xenial Dog. I expect I could add these repositories if I knew how. If anybody can give me any help with one, other or both of these methods I'd be much obliged.

Regards,

Ken.
gqrx2.jpg
 Description   
 Filesize   13.38 KB
 Viewed   405 Time(s)

gqrx2.jpg

Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 2987
Location: holland

PostPosted: Tue 02 Jan 2018, 13:22    Post subject:  

Hi keniv, I replied in Xenialdog64 thread.
http://murga-linux.com/puppy/viewtopic.php?p=979046#979046

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 490
Location: Scotland

PostPosted: Tue 02 Jan 2018, 13:51    Post subject:  

Sorry Fred,
I realised I'd put it in the wrong thread so I removed it, left an explanation as to why, and moved it here. I'll look at your reply now and reply here if that's OK.

Regards,

Ken.

Thanks for the information Fred. I'll try using this method of installing as it works with Ubuntu. I'll report back on how I get on. I do like your Dog. As am not familiar with Ubuntu and Xenial Dog has a bit of the pup about it like running as root it helps. It also boots up faster than Ubuntu.
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 490
Location: Scotland

PostPosted: Tue 02 Jan 2018, 15:58    Post subject:  

Hi Fred,
All of the repositories added and updated and gqrx installed. However, when I ran it from the menu I got whats shown in gqrxd.jpg (attached). When I ran it in a terminal I got this.

Code:
root@xenial:~# gqrx
linux; GNU C++ version 5.4.0 20160609; Boost_105800; UHD_003.010.002.000-release

Controlport disabled
"Pulseaudio error: Connection refused"


The box in gqrxd.jpg also appeared again.

On checking the package manager I seem to have pulse audio installed though not all of it. Is there a way to find out if I am missing anything from Pulseaudio that is required. If it requires the command line can you give me details please. I have limited skills here.

Regards,

Ken.

Edit. I've added the of/root/.config/gqrx/default.conf bellow.

Code:
[General]
configversion=1

[audio]
gain=171
udp_host=localhost

[fft]
split=23

[gui]
geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0\0\0\0\0\x18\0\0\x4\xff\0\0\x3\xe7\0\0\0\xa4\0\0\0\x90\0\0\x4Y\0\0\x3+\0\0\0\0\x2\0\0\0\x5\0)
state=@ByteArray(\0\0\0\xff\0\0\0\0\xfd\0\0\0\x2\0\0\0\x1\0\0\x1j\0\0\x3]\xfc\x2\0\0\0\x2\xfc\0\0\0\x41\0\0\x2.\0\0\x1w\0\b\0\x1d\xfa\0\0\0\x1\x2\0\0\0\x3\xfb\0\0\0\x18\0\x44\0o\0\x63\0k\0I\0n\0p\0u\0t\0\x43\0t\0l\x1\0\0\0\0\xff\xff\xff\xff\0\0\0\xf9\0\xff\xff\xff\xfb\0\0\0\x12\0\x44\0o\0\x63\0k\0R\0x\0O\0p\0t\x1\0\0\0\0\xff\xff\xff\xff\0\0\x1Y\0\a\xff\xff\xfb\0\0\0\xe\0\x44\0o\0\x63\0k\0\x46\0\x66\0t\x1\0\0\0\0\xff\xff\xff\xff\0\0\0\xc8\0\a\xff\xff\xfc\0\0\x2u\0\0\x1)\0\0\0\xc8\0\xff\xff\xff\xfa\0\0\0\0\x2\0\0\0\x2\xfb\0\0\0\x12\0\x44\0o\0\x63\0k\0\x41\0u\0\x64\0i\0o\x1\0\0\0\0\xff\xff\xff\xff\0\0\0\xc8\0\xff\xff\xff\xfb\0\0\0\xe\0\x44\0o\0\x63\0k\0R\0\x44\0S\0\0\0\0\0\xff\xff\xff\xff\0\0\0h\0\xff\xff\xff\0\0\0\x3\0\0\0\0\0\0\0\0\xfc\x1\0\0\0\x1\xfb\0\0\0\x1a\0\x44\0o\0\x63\0k\0\x42\0o\0o\0k\0m\0\x61\0r\0k\0s\0\0\0\0\0\xff\xff\xff\xff\0\0\x1\x42\0\xff\xff\xff\0\0\x3\x90\0\0\x3]\0\0\0\x1\0\0\0\x2\0\0\0\b\0\0\0\x2\xfc\0\0\0\x1\0\0\0\x2\0\0\0\x1\0\0\0\x16\0m\0\x61\0i\0n\0T\0o\0o\0l\0\x42\0\x61\0r\x1\0\0\0\0\xff\xff\xff\xff\0\0\0\0\0\0\0\0)

[input]
device="rtl=0"
frequency=89899000
sample_rate=1800000

[output]
device=alsa_output.pci-0000_00_1f.5.analog-stereo

[receiver]
agc_decay=100
demod=4
filter_high_cut=80000
filter_low_cut=-80000
fm_deemph=74
offset=91000

[remote_control]
allowed_hosts=::ffff:127.0.0.1


It appears to be using alsa on ubuntu so I'm now not sure what pulseaudio error is about.
gqrxd.jpg
 Description   
 Filesize   7.75 KB
 Viewed   361 Time(s)

gqrxd.jpg

Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 2987
Location: holland

PostPosted: Tue 02 Jan 2018, 16:45    Post subject:  

Hi Ken, pulseaudio as root can be problematic, maybe try to start it first before running gqrx ?
Code:
pulseaudio --start

(you may get a warning about running as root, but might run ok if just a warning (not error) )
Or:
Code:
pulseaudio --system


I'm not on Xenialdog now, so just guessing...

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 490
Location: Scotland

PostPosted: Tue 02 Jan 2018, 17:58    Post subject:  

Hi Fred,
It's working! With Pulseaudio --Start I did get a warning telling me it was not designed to work as root and it did not start. With Pulseaudio --System it did give me many warnings which amounted to 'on your own head be it' but it did start and so did gqrx allowing me to chose my device. The sound quality is not great but I think that has more to do with the quality and positioning of the antenna I'm using. It is as good as the quality with Ubuntu using the same antenna. Thanks for all your help with this.

Regards,

Ken.
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 490
Location: Scotland

PostPosted: Thu 04 Jan 2018, 12:49    Post subject:  

Hello Fred,
I'm sorry to bother you with this again.

Quote:
pulseaudio as root can be problematic


I am having lots of inconsistencies with the installed pulse audio. If I try to load it with
Code:
pulseaudio --system

sometimes it loads and sometimes it appears not to. This is confirmed by getting a pulseaudio error when running gqrx and
Code:
pulseaudio --check

I remembered reading on the forum that some later versions of firefox needed pulse audio so I thought there might be some pets made to run as root. I downloaded three. They did not install but could be converted to a .sfs. The best of these was Pulseaudio-2.1-up-20121014.pet.sfs. I can get this to load on the fly but unlike puppy there are no menu entries. I have to mount the .sfs then find the boot script them click on that. This does work and this version of pulseaudio loads consistently, without any moans and gqrx also works. As this was a bit of a fiddle I tried to write a .desktop entry to start pulseaudio. I called it Pulse Start.desktop and put it in

Code:
 /usr/share/applications


but cannot get it to work though it does give a menu entry. I've attached it.

Code:
[Desktop Entry]
Name=Pulse Start
Type=Application
Exec=/mnt/live/mnt/sdb1/mnt/pulseaudio-2.1-up-20121014.pet.sfs/usr/bin/start-pulseaudio-x11
Icon=/usr/share/icons/hicolor/48x48/mimetypes/display.png
Terminal=false
Categories=Network;WebBrowser;Internet;


I have tried various versions of the Exec=xxxxxxxxxxx part of this but cannot get it to work. I am sure there must be a way to do this but I cannot find it. I am also not sure whether I should see a menu entry, like in puppy, when I load the .sfs on the fly. Again I'd appreciate your help with this.

Regards,

Ken.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 2987
Location: holland

PostPosted: Thu 04 Jan 2018, 14:26    Post subject:  

Hi Ken,

Quote:
I am having lots of inconsistencies with the installed pulse audio. If I try to load it with
Code:
pulseaudio --system


Are you sure "pulseaudio --start" doesn't work ?
Sound works fine for me then (ignored the warning), also see attached alsamixer pic below.
EDIT: you may need to kill it first "pulseaudio --kill"

Fred
xendog-20180104191657.jpg
 Description   after running "pulseaudio --start"
 Filesize   19.16 KB
 Viewed   279 Time(s)

xendog-20180104191657.jpg


_________________
Dog Linux website
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 490
Location: Scotland

PostPosted: Thu 04 Jan 2018, 17:13    Post subject:  

Hi Fred,
This is what I get after first starting with

Code:
pulseaudio --kill
then

Code:
pulseaudio --start


Code:
root@xenial:~# pulseaudio --kill
E: [pulseaudio] main.c: Failed to kill daemon: No such process
root@xenial:~# pulseaudio --start
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
root@xenial:~# pulseaudio --kill
root@xenial:~# pulseaudio --start
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
root@xenial:~#


I've attached the output of the alsagui. I cannot adjust the level of "capture" which appears to be at zero. Every thing else is adjustable so I expect "capture should be. gqrx does work though. If this continues to be OK I'll get rid of the .pet .sfs.

Regards,

Ken.
xendog-alsagui.jpg
 Description   
 Filesize   15.74 KB
 Viewed   254 Time(s)

xendog-alsagui.jpg

Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 2987
Location: holland

PostPosted: Thu 04 Jan 2018, 18:42    Post subject:  

Hi Ken, I'd say just use the installed pulseaudio with the --start option (not from the sfs).
The reason I wrote you might need to do "pulseaudio --kill" is in case it was already active with earlier --system attempts.

Maybe try just this in your .desktop launcher.
Code:
Exec=pulseaudio --start


No idea why you can't adjust the "capture"

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 58 of 65 [965 Posts]   Goto page: Previous 1, 2, 3, ..., 56, 57, 58, 59, 60, ..., 63, 64, 65 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1490s ][ Queries: 14 (0.0640s) ][ GZIP on ]