Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Nov 2017, 09:25
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
[Gelöst] Firefox 45.0.2 lässt sich nicht mehr aktualsieren
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
MyPuppysaysWauWau


Joined: 20 Feb 2014
Posts: 147
Location: Austria/Vienna

PostPosted: Fri 20 May 2016, 15:01    Post subject:  [Gelöst] Firefox 45.0.2 lässt sich nicht mehr aktualsieren
Subject description: Precise Puppy 5.7.1
 

Hallo, wie schon im Betreff beschrieben... seit einiger Zeit lässt sich FF nicht mehr aktualisieren.
Kann ich das Problem behen, wenn ja, wie?

Viele Grüße,
Walter

_________________
Don't start because it's easy. Start because it's worth trying. Don't stop because it's hard. Stop because you tried your Best.

Last edited by MyPuppysaysWauWau on Mon 27 Mar 2017, 17:28; edited 1 time in total
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Fri 20 May 2016, 16:37    Post subject:  

Ich kann Dir zwar nicht erklären, wie Du das beheben kannst, aber meines WIssens nach benötigt Firefox ab Version 46 gtk3. Und Precise hat wohl nur gtk2 und kein gtk3 bzw. wenn, dann möglicherweise nur ganz marginal (konnte aber es auf die Schnelle nicht lokalisieren in Precise (/usr/lib und /usr/share überprüft)).
_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
MyPuppysaysWauWau


Joined: 20 Feb 2014
Posts: 147
Location: Austria/Vienna

PostPosted: Tue 24 May 2016, 16:06    Post subject:  

[quote="LazY Puppy"]Ich kann Dir zwar nicht erklären, wie Du das beheben kannst,/quote]
Warum? gtk3 müsste sich doch nach installieren lassen!?

_________________
Don't start because it's easy. Start because it's worth trying. Don't stop because it's hard. Stop because you tried your Best.
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Tue 24 May 2016, 18:20    Post subject:  

MyPuppysaysWauWau wrote:
LazY Puppy wrote:
Ich kann Dir zwar nicht erklären, wie Du das beheben kannst,

Warum? gtk3 müsste sich doch nach installieren lassen!?

Möglicherweise geht das, wenn es ein entsprechendes Paket gibt.

Mir ist aber keines bekannt, und ich weiß auch nicht, welche Abhängigkeiten gtk3 wiederum benötigt, und ob die in Precise vorhanden oder in Precise kompilierbar sind bzw. welche Kernelversion gtk3 mindestens benötigt etc.pp.

Ich vermutete auch nur, daß das gewünschte Update für Firefox der Version ab Firefox 46 gleichkommt.

Natürlich könnte es auch an etwas anderem liegen (gtk3 war nur mein erster Gedanke, da ich mehrere Beiträge bezüglich Firefox 46 im EN Forum beobachtet hatte), das für mich schlicht im Dunkeln liegt.

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 795
Location: formerly de; now in tranquility

PostPosted: Sun 05 Jun 2016, 11:01    Post subject: Firefox Updates  

Das liegt mit Sicherheit an gtk-3.

In Tahr 6.0. habe ich das über "Quickpet" erledigt.
Erst Update auf Tahr 6.0.5, dann gtk-3 installieren.

In Precise 5.7.1 muß man erst im Puppy Package Manager einen Update desselben machen, dann nach libgtk-3-0 suchen und installieren, dabei alle dependencies mitwählen.

Nach der Installation von libgtk-3-0 kannst du in Firefox den Update fahren und du erhältst einen funktionierenden Firefox 46.0.1. bzw. den jeweils neusten.

Viel Erfolg
Back to top
View user's profile Send private message 
MyPuppysaysWauWau


Joined: 20 Feb 2014
Posts: 147
Location: Austria/Vienna

PostPosted: Mon 27 Mar 2017, 17:27    Post subject:  Gelöst - solved  

Danke Leute für eure Hilfe Smile

Es hat geklappt! Und zwar habe ich zuerst den PPM upgedatet, dann GTK3 in die Suche eingegeben, um mir dann das sympathische Very Happy aus der List auszusuchen. Da was universelles immer gut ist habe ich uim-gtk3_1.7.1 genommen^^ Das Ganze samt Abhängigkeiten installiert. Voila, jetzt habe ich fen Firefox auf die Ver 52.0.1 updaten können.

Nächstes Mal gebe ich eine Runde Bier aus

_________________
Don't start because it's easy. Start because it's worth trying. Don't stop because it's hard. Stop because you tried your Best.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0651s ][ Queries: 11 (0.0077s) ][ GZIP on ]