Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Nov 2017, 10:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
SlimJet 64-bit SFS packages
Post new topic   Reply to topic View previous topic :: View next topic
Page 12 of 13 [188 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13 Next
Author Message
Mike Walsh


Joined: 28 Jun 2014
Posts: 3139
Location: King's Lynn, UK.

PostPosted: Sat 23 Sep 2017, 18:04    Post subject:  

Hiya, Marv.

Right; okay..!

So, to recap; you've still got 'libpuppygc.so' in the /opt/slimjet folder, yes? But 'slimjet' & 'slimjet-sandbox' have now been run through the 'bbe' script, yes? And 'LD_PRELOAD, etc' is still in the exec-line, but you don't need the --no-sandbox switch any longer?

And those are the only changes, yes?


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 911
Location: SW Wisconsin

PostPosted: Sat 23 Sep 2017, 18:17    Post subject:  

Mike Walsh wrote:
Hiya, Marv.

Right; okay..!

So, to recap; you've still got 'libpuppygc.so' in the /opt/slimjet folder, yes? But 'slimjet' & 'slimjet-sandbox' have now been run through the 'bbe' script, yes? And 'LD_PRELOAD, etc' is still in the exec-line, but you don't need the --no-sandbox switch any longer?

And those are the only changes, yes?




Mike. Wink


Yep, that's it. I loaded your SFS and ran 'slimjet' and 'slimjet-sandbox' through the script. Simple drag over it, nothing else. No changes made to libraries or your stock exec line. Just looked and 'libpuppygc.so' is still in /opt/slimjet. I symlink from /root/.config to my profile on my EXT2 data partition but that was the case for the non-starting-as-root, the no-sandbox flagged run, and the bbe'd runs without the flag. Posting from that now.

Basically blindly followed your instructions Cool

_________________
Pups currently in kennel Very Happy X-slacko 4.4 and X-tahr 2.0 for my users; LxPupSc,LxPupXenial & XFCE_XenialPup64 for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3139
Location: King's Lynn, UK.

PostPosted: Sat 23 Sep 2017, 18:21    Post subject:  

Hi, Marv.

Excellent. I know now what I shall do for the next build, that being the case.

Thanks for the feedback. If it helps improve matters all round for everybody, I'm all for it.

Cheers.


Mike. Very Happy

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3139
Location: King's Lynn, UK.

PostPosted: Fri 29 Sep 2017, 05:16    Post subject:  

*** NEW Version 15.1.4.0 now available***

Morning, boys & girls.

The current stable release, 15.1.4.0, is now available for download. These can be found at the usual location in post #2. This includes the newest version of Pepper; 27.0.0.130.

------------------------------------------------------------------------------------------------------------

New stuff in this release:-

https://www.slimjet.com/en/whatisnew.php

NetFlix still working fine....... enjoy! Very Happy

What 'fixes' there are are concerned with video d/l and playback issues...

-----------------------------------------------------------------------------------

The previously-mentioned 'silent-launch' feature has been added to /root/Startup; if you look in /root/Startup, you'll find a new script, entitled 'silent_launch_slimjet'. What this effectively does is to launch SlimJet at boot, without 'opening' it; rather along the same lines as how modern Windoze works with hibernation and Fast Startup; it essentially holds it in 'standby-mode' until you launch from either desktop launcher or Menu entry. Upon doing so, it starts almost instantly. Smile

I've also taken a leaf out of Oscar's book, and begun running '/slimjet' and '/slimjet-sandbox' through Phil's 'bbe' script. A few people have mentioned having problems recently (and Marv found it worked for him the other day), so.....

--------------------------------------------------------------------------------------

Drop me a line if there's any problems.

Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------


Last edited by Mike Walsh on Fri 29 Sep 2017, 07:18; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
belham2

Joined: 15 Aug 2016
Posts: 1301

PostPosted: Fri 29 Sep 2017, 06:04    Post subject:  

Hiya, Mike!

Thanks for the newie Slimmie. And also wanted to let ya know in my BK-EasyLinux0.4 'frugal' install, with Battleshooter's XFCE.pet loaded on top, I followed BK's instructions to use his "Easy Bootmanager Configuration" menu entry, and (after manually dropping your latest slimjet.sfs in the directory he says), I rebooted---we have to reboot in Easy, haha, no load-on-the-fly---anyways, after reboot, Easy started up and there was Slimjet 15.1.4 all loaded up and raring to go. I think you really need to modify the 2nd post in this thread (and also your Belgium---HAHA Laughing ---download site) to where it says your sfs-es will work with any ubuntu-based pup, and not just Tahr. I've tried your builds in nearly all of the murga 64-bit ubuntu-based pups, and it works as advertised every time, no modification from me. Wink

Sending wishes you (and your Mum) are well. Thanks again!
Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 693
Location: Philadelphia, PA

PostPosted: Fri 29 Sep 2017, 08:53    Post subject:  

Mike Walsh (in part) wrote:
NEW Version 15.1.4.0 now available

Mike, thanks a lot.
It seems to work fine.
I had to boot to a tahr64 (6.0.6 from Feb 2017)
Usually use a tahr32 with iron.
Should I change to usually a 64-bit Puppy?
I'd have to see whether I could then run all of my 32-bit software.
Any comments or advice will be much appreciated.

Sheldon

_________________
Dell E6410: Xenial, Slim Slacko 6, LuPu Super 2, Tahr
Dell D610: Windows XP, Puppy Linux 5.2
Intel D865GBF: Tiny Windows 7, Puppy Linux 5.2
Acer Aspire One: Windows XP, Puppy Linux 5.2
Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 911
Location: SW Wisconsin

PostPosted: Fri 29 Sep 2017, 10:22    Post subject:  

Thanks, Mike!

Unloaded the '3' SFS and loaded the '4' one in battleshooters XFCE-XenialPup64 r3. Your 'bbe' blessed SFS does indeed run OOTB here. Posting from it now.

Cheers,

_________________
Pups currently in kennel Very Happy X-slacko 4.4 and X-tahr 2.0 for my users; LxPupSc,LxPupXenial & XFCE_XenialPup64 for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3139
Location: King's Lynn, UK.

PostPosted: Fri 29 Sep 2017, 10:25    Post subject:  

Hi, Sheldon.

Shouldn't be a problem running your 32-bit software in Tahr64. I have no end of 32-bit stuff, plus a load of stuff I run under WINE (which is 32-bit); it all runs nicely in Tahr64, by means of using the 32-bit compatibility libs SFS.

I'm running Tahr64 6.05, myself; I don't know whether the same 32-bit compat-lib SFS will run in 6.06. Since PhilB's on extended sabbatical, he's no longer around to ask about this.....but you can find it at this link. There's no version number for this, indicating a specific version of Tahr64; as far as I know, 6.06 mainly included the extra stuff for UEFI booting, along with a number of 'bugfixes'. I don't think core functionality has changed at all.

Place it in /mnt/home, as with any other SFS, and load it. Then, you can install your 32-bit stuff (including WINE, if you happen to use it.) All things being equal, they should run OK.

Hope that helps.


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3139
Location: King's Lynn, UK.

PostPosted: Fri 29 Sep 2017, 10:31    Post subject:  

Marv wrote:
Thanks, Mike!

Unloaded the '3' SFS and loaded the '4' one in battleshooters XFCE-XenialPup64 r3. Your 'bbe' blessed SFS does indeed run OOTB here. Posting from it now.

Cheers.


Hi, Marv..!

Well, I'm pleased to see Phil's 'bbe' script seems to be 'doing its thing'. Excellent. That's just what we need; at least things should be 'steady' for the next few releases, at any rate. It's when the 16-series arrives I'm expecting more fun'n'games; all depends on whether FlashPeak move up to a Chromium 60 base, or whether they jump one, and go straight to Chromium 61...

That's the current 'problem kiddie'. We shall see, we shall see.....

----------------------------------------------------------------

Incidentally, I do something very similar to you. I run Chrome, Chromium, SlimJet and Iron (along with a bunch of other stuff) for both 32- and 64-bit installs, from a remote partition, with everything sym-linked into each Pup where Pup expects to find it.....including .cache & .config. That way, of course, all browsers using it automatically keep 'in sync'.

I go one step further; I have just two instances of PepperFlash throughout the entire kennels; one of 32-bit, and one of 64-bit. These are then further sym-linked into the remote browsers at the appropriate locations.....and the variation that sfs did on Geoffrey's Flash Auto-Updater (for PepperFlash, instead of Flash) takes care of keeping those up to date. Since these are on the remote partition, too, and sym-linked into each Pup's /root/Startup, every Pup 'auto-updates' at boot. Neat, huh? It all works rather nicely..! Very Happy

You can find sfs's script for this here. Save it as a text file, make it executable, then edit the first few lines to point it at the correct location for wherever you keep PepperFlash. If you stick it (or sym-link it) into /root/Startup, it will run at boot. However, it does seem to work best if you manually run it through the terminal...


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
orrin


Joined: 05 Sep 2016
Posts: 120
Location: sparks, NV

PostPosted: Fri 29 Sep 2017, 13:25    Post subject:  

Hello Mike,

Version 15.1.4.0 seems to work OK here in my Slacko 64-6.3.2.

Thanks for you efforts!

_________________
Orrin - Engineer/Photographer/Webmaster

Back to top
View user's profile Send private message Visit poster's website 
step

Joined: 04 May 2012
Posts: 950

PostPosted: Thu 05 Oct 2017, 16:21    Post subject:
Subject description: not working in Fatdog64
 

SlimJet-15.1.4.0-amd64-slacko.sfs

This sfs doesn't work in Fatdog64. It and the original tar.xz package have the same fatal issue:
Code:

# /opt/slimjet/nacl_helper: error while loading shared libraries: libnssutil3.so: cannot open shared object file: No such file or directory
[1:1:1005/220011.255439:ERROR:nacl_fork_delegate_linux.cc(316)] Bad NaCl helper startup ack (0 bytes)

In addition, after loading the SFS the following command is necessary:
Code:

mkdir -p /opt/google/chrome && ln -s /opt/slimjet/libpuppygc.so /opt/google/chrome/libpuppygc.so

Then try to start the browser with
Code:
run-as-spot flashpeak-slimjet &

but this fails, like I said, due to libnssutils3.so missing.

_________________
Fatdog64-710|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3139
Location: King's Lynn, UK.

PostPosted: Thu 05 Oct 2017, 18:50    Post subject:  

Hi, step.

Hm. You seem to have anticipated the problem with Network Security Services which hasn't reared its head until Chromium 61 (the requirement for libnss >= 3.26); and SlimJet 15.1.4.0 is using a Chromium 59 base.....

Unless, of course, FatDog doesn't have libnss. Which I can't quite believe.

Daft question, perhaps, but, if you've got Firefox on your system, I take it you have tried sym-linking libnss into /usr/lib64? (I may have that wrong, since I don't run FatDog (never have, in fact).....and I know it has a number of peculiarities compared with normal Pups. In fact, I believe yours is the first feed-back from a FatDog user in this thread.....)

Why the need to symlink Chrome's libpuppygc.so into Slimmie? The pre-existing version is identical to the version I supply in the Chrome SFS packages, so...you've lost me here, I'm afraid.


Mike. Confused

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
step

Joined: 04 May 2012
Posts: 950

PostPosted: Sun 08 Oct 2017, 17:24    Post subject:  

Hi Mike,

yes, libnss-3.21 is an optional package in the Fatdog64 repo. However, there is no libpuppygc.so, not even in the repo, so I have to rely on the one in the slimjet sfs. /root/.config/slimjet attempts to preload from the chrome folder, which isn't included in slimjet sfs, hence the need to symlink.

So, after installing libnss, making symlinks and starting slimjet, ... it still doesn't work Sad

It isn't so important, it's just that your good appraisals of slimjet got me curious to see this browser at work.

edit: neither spot nor root can start slimjet

Code:

# slapt-get --install libnss
Reading Package Lists...Done
The following NEW packages will be installed:
  libnspr libnss
0 upgraded, 0 reinstalled, 2 newly installed, 0 to remove, 0 not upgraded.
Need to get 1.6MB of archives.
After unpacking 7.0MB of additional disk space will be used.
1/2 Get http://distro.ibiblio.org/fatdog/packages/710/ libnspr 4.11-x86_64-1 [181.0kB]...Done
2/2 Get http://distro.ibiblio.org/fatdog/packages/710/ libnss 3.21-x86_64-1 [1.4MB]...Done
...
Package libnspr-4.11-x86_64-1.txz installed.
...
Package libnss-3.21-x86_64-1.txz installed.
Done

# load_sfs.sh --load /home/spot/Downloads/SlimJet-15.1.4.0-amd64-slacko.sfs

# mkdir -p /opt/google/chrome && ln -s /opt/slimjet/libpuppygc.so /opt/google/chrome/libpuppygc.so

# run-as-spot flashpeak-slimjet &
[1] 19904
# [19919:19933:1008/231403.879292:ERROR:bus.cc(422)] Failed to connect to the bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[19919:19919:1008/231403.880445:ERROR:simple_message_box_views.cc(237)] Unable to show a dialog outside the UI thread message loop: Failed To Create Data Directory - Slimjet cannot read and write to its data directory:

/root/.config/slimjet
Trace/breakpoint trap
[19963:19963:1008/231404.228262:ERROR:broker_posix.cc(41)] Invalid node channel message

[1]+  Done(133)               run-as-spot flashpeak-slimjet
#

_________________
Fatdog64-710|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
belham2

Joined: 15 Aug 2016
Posts: 1301

PostPosted: Fri 13 Oct 2017, 13:02    Post subject:  

Hi ya,

Just wanted to let you know I have had to let Slimjet go. It has a bug in it, where you are doing a few page visits, then go back to Google in the same tab, and search for something, then click on that something, Slimjet just sits & spins and will not go to the website. Others on Slimjet have been reporting similar problems too....it started in slimmie 15.1.3 and has been that way ever since. So, I'm down to using Chromium builds for 32-bit (hate Opera) so I can have that "silent-launch' feature I love so much.


P.S. Interestingly, I am not experiencing the same issue in any Slimjet 64-bit version. Nor is anyone else talking about it. Only in the 32-bit version. Pretty soon, a few years maybe, pups-wise, browsers-wise, program-wise, OS-wise, etc-wise, it seems the Net world is going to close the coffin lid on all things 32-bit.
Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 3139
Location: King's Lynn, UK.

PostPosted: Fri 13 Oct 2017, 16:12    Post subject:  

Hi, belham2.

Ya, I've mentioned this myself before now, and you're right.....it is only the 32-bit version. Google have been slowly but steadily pushing for everyone to go 64-bit for a while.....and I'm pretty sure it started when they became their own certificate authority last year. They've carefully allowed the certification for 32-bit to lapse (with no intentions of re-instating it.) It's their way of 'nudging' folks in the direction they want them to take...

Anything Google-related (including YouTube, and tons of websites that use their version of web blogs), are now completely inacessible. This is why I keep the final 32-bit Chrome around (48.0.2564.116); for some reason, everything still works in that.....


Mike. Wink

_________________
If I've helped you.....please say 'Thanks'!
MY PUPPY PACKAGES
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 12 of 13 [188 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0807s ][ Queries: 12 (0.0178s) ][ GZIP on ]