Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 19 Nov 2017, 14:10
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Package Collections / Repositories
Boinc pack for Wary 5.3
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
racer63

Joined: 12 Sep 2012
Posts: 8

PostPosted: Mon 04 Jul 2016, 16:20    Post subject:  Boinc pack for Wary 5.3
Subject description: New user
 

Hi all:

For certain reasons I have to use an old PIII for Boinc from command line, so I'm in need of some Boinc package compatible with Wary 5.3. There's an old thread in this forums regarding an older version of Boinc but the link is long gone offline. Also gone are the old versions for Ubuntu Lucid in the PPM. So the question is, where can I find a suitable Boinc for this version of Puppy?
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 923
Location: El Salvador

PostPosted: Tue 05 Jul 2016, 23:18    Post subject:  

I made this procedure in Retro-precise Pupjibaro
open terminal and type:
Code:
cd /opt
mkdir boinc_compat-6.12.22
cd boinc_compat-6.12.22
wget -c --no-check-certificate https://boinc.berkeley.edu/dl/boinc_compat_6.12.22_i686-pc-linux-gnu.sh
chmod +x boinc_compat_6.12.22_i686-pc-linux-gnu.sh
./boinc_compat_6.12.22_i686-pc-linux-gnu.sh
cd BOINC
ln -s /usr/lib/libstdc++.so.6.0.16 /usr/lib/libstdc++.so.3
./run_client

Terminal show me this..
Quote:
05-Jul-2016 20:58:16 [---] Starting BOINC client version 6.12.22 for i686-pc-linux-gnu
05-Jul-2016 20:58:16 [---] log flags: file_xfer, sched_ops, task
05-Jul-2016 20:58:16 [---] Libraries: libcurl/7.18.0 OpenSSL/0.9.8g zlib/1.2.3 c-ares/1.5.1
05-Jul-2016 20:58:16 [---] Data directory: /mnt/sda6/BOINC
getaddrinfo: Success
05-Jul-2016 20:58:16 [---] Processor: 2 GenuineIntel Intel(R) Pentium(R) Dual CPU E2140 @ 1.60GHz [Family 6 Model 15 Stepping 13]
05-Jul-2016 20:58:16 [---] Processor: 1.00 MB cache
05-Jul-2016 20:58:16 [---] Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm
05-Jul-2016 20:58:16 [---] OS: Linux: 3.2.48
05-Jul-2016 20:58:16 [---] Memory: 2.94 GB physical, 0 bytes virtual
05-Jul-2016 20:58:16 [---] Disk: 113.94 GB total, 106.04 GB free
05-Jul-2016 20:58:16 [---] Local time is UTC -6 hours
05-Jul-2016 20:58:16 [---] No usable GPUs found
05-Jul-2016 20:58:16 [---] No general preferences found - using BOINC defaults
05-Jul-2016 20:58:16 [---] Preferences:
05-Jul-2016 20:58:16 [---] max memory usage when active: 1503.79MB
05-Jul-2016 20:58:16 [---] max memory usage when idle: 2706.83MB
05-Jul-2016 20:58:16 [---] max disk usage: 10.00GB
05-Jul-2016 20:58:16 [---] don't use GPU while active
05-Jul-2016 20:58:16 [---] suspend work if non-BOINC CPU load exceeds 25 %
05-Jul-2016 20:58:16 [---] (to change preferences, visit the web site of an attached project, or select Preferences in the Manager)
05-Jul-2016 20:58:16 [---] Not using a proxy
05-Jul-2016 20:58:16 [---] This computer is not attached to any projects
05-Jul-2016 20:58:16 [---] Visit http://boinc.berkeley.edu for instructions
Initialization completed

I dont know what BOINC is, and i think this just the client, you need run the manager? or another option.

_________________
My blog | | Github


Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 923
Location: El Salvador

PostPosted: Wed 06 Jul 2016, 01:58    Post subject:  

Saw this in google
https://code.google.com/archive/p/boinctui/
made a pet
http://repo.gentoo-es.com/PuppyLinux-repositorios/Pupjibaro/3.2.48/boincuit-2.3.1.pet
looks like this

_________________
My blog | | Github


Back to top
View user's profile Send private message 
racer63

Joined: 12 Sep 2012
Posts: 8

PostPosted: Wed 06 Jul 2016, 10:12    Post subject:  

Hi Nilson, thanks for the replay.

[url]boinc.berkeley.edu/[/url] is a grid computing system. Currently I'm running 7 projects in 6 diff rigs.

Ok, back to the client for Wary, I tried your pet but still doesn't work. Today I have some time, so I'll give a try compiling the official source and will report back.
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 923
Location: El Salvador

PostPosted: Wed 06 Jul 2016, 12:56    Post subject:  

Yea wary is not a ubuntu based version as Pupjibaro (retro precise remaster), to compile bointui you need the devx.sfs package for wary
http://distro.ibiblio.org/quirky/wary-5.5/devx_wary_5.5.sfs
install and download the bointcui source code and run this codes in terminal
Code:
wget -c --no-check-certificate https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/boinctui/boinctui_2.3.1.tar.gz
tar xvzf boinctui_2.3.1.tar.gz
cd boinctui-2.3.1/
autoconf
./configure --prefix=/usr --without-gnutls
make
make install

you can check missing dependences with
Code:
ldd bointcui or ldd bointcui | grep "not found"

to compile boint for linux maybe in wary need the libstdc library
http://gcc.skazkaforyou.com/libstdc++/old-releases/libstdc++-3.0.tar.bz2 read the howto compile or check in the puppy package manager
the procedure to compile boint is the same i explain before
cheers.

_________________
My blog | | Github



Last edited by nilsonmorales on Wed 06 Jul 2016, 14:17; edited 1 time in total
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1583
Location: lincoln, uk

PostPosted: Wed 06 Jul 2016, 13:02    Post subject:  

http://archive.org/download/Puppy_Linux_Devx/devx_wary_5.3.sfs

Smile
Back to top
View user's profile Send private message Visit poster's website 
racer63

Joined: 12 Sep 2012
Posts: 8

PostPosted: Tue 19 Jul 2016, 17:40    Post subject:  

Getting
Code:
error while loading shared libraries: libstdc++.so.3 cannot open shard objetc file: no such file or directory
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Package Collections / Repositories
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0514s ][ Queries: 11 (0.0078s) ][ GZIP on ]