Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 21 Sep 2019, 01:34
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
HP-X360-I3 Tahr=graphics Slacko=No wireless
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
sitdown

Joined: 03 Jan 2015
Posts: 13

PostPosted: Sat 16 Jul 2016, 14:32    Post subject:  HP-X360-I3 Tahr=graphics Slacko=No wireless  

Hi,

Just bought this Laptop:[url] http://www.elkjop.no/product/data/ipad-og-nettbrett/HP13S080NO/hp-pavilion-x360-2-i-1-13-s080no-13-3-rod#tab-specs [/url]
Thought i could easily use puppy on it, to no avail. So i hope some of you guys could help me With this.

I first tried Tahr Puppy 6.0.5, it booted directly into the x-window. But there was no visible buttons/menu's or text. When howering my mouse over the dialog Windows, the buttons appeared.

Then tried slacko 6.3.0 64bits. Got some error Messages, and could Access the config setup in the "terminal" No problem With the resolution, but on the graphics, i needed to change from Intel driver to a generic option.
Then the graphic Interface started, but there was no Wireless option, maybe more problems to.

So the best option is to try Tahr puppy and somehow change the Graphics driver, how to do this?

Code:


 Intel Dual Band Wireless-AC 3160

CPU
   Intel Core i3 5010U @ 2.10GHz   52 °C
   Broadwell-U 14nm Technology
RAM
   4,00GB Single-Channel DDR3 @ 798MHz (11-11-11-28)
Motherboard
   Hewlett-Packard 806E (U3E1)   47 °C
Graphics
   Generic PnP Monitor (1366x768@60Hz)
   Intel HD Graphics 5500 (HP)
[url][/url]
Back to top
View user's profile Send private message 
sitdown

Joined: 03 Jan 2015
Posts: 13

PostPosted: Mon 18 Jul 2016, 00:02    Post subject:  

It seems like nobody can help? To problematic to find out?

Should i just deliver the laptop back again and buy another one?
Back to top
View user's profile Send private message 
peterw

Joined: 19 Jul 2006
Posts: 360
Location: UK

PostPosted: Mon 18 Jul 2016, 17:20    Post subject: Intel Wireless Drivers  

Hi

You seem to have good machine but this range has many variants. Whilst it is not Puppy you may like to experiment with Ubuntu or Fedora and see if they give you working wireless and graphics. Intel do have linux support for the wireless card:
http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005511.html
And so it should be possible to get this working. Some of the others on the forum are good at doing this if they respond.

peterw
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12634
Location: Stratford, Ontario

PostPosted: Mon 18 Jul 2016, 18:29    Post subject:  

You should look at a new Puppy with a 4.x kernel, like Xenial.
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Mon 18 Jul 2016, 21:18    Post subject:  

Hello @Sitdown.

If I understand correctly, you have a 64bit PC. You might find better results using one of the modern 64bit PUPs that exist in the forum. There are several which may be a better match to your hardware.

Consider these:
  • Just-Lighthouse V700
  • EmSee V2.4 (and select 64bit at the boot splash screen)
  • Slacko64 V6.3.5
  • TahrPUP64 V6
  • XenialPUP64 Alpha v1
  • FATDOG V7+
I have tested the top 3 shown on Intel "I" processor PCs. ALL of the PUPs are available on the forum.

Understanding that you had some issues with w/l with Slacko64, you might find TahrPUP or any of the others will work. Just-Lighthouse has the most current kernel with drivers.

And I have tested all of the above on older PCs: Namely modern P4s (built since 2006), modern P4 Celerons, Atoms and AMD X2+.

Report ANY satisfaction or grief on each distro's thread for the best response possible from its author to help you move forward.

Hope this is helpful

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12634
Location: Stratford, Ontario

PostPosted: Tue 19 Jul 2016, 12:33    Post subject:  

Regarding your video: The Intel HD Graphics 5500 is probably going to need a very recent kernel. Xenial's k4.5.2 may support it.

Regarding your WiFi: The Intel Dual Band Wireless-AC 3160 device is probably going to need some additional firmware that you must download.

Once you have the video working OK, we can look at that.
Back to top
View user's profile Send private message 
sitdown

Joined: 03 Jan 2015
Posts: 13

PostPosted: Wed 20 Jul 2016, 16:17    Post subject:  

Thanks guys. It is quite difficult to find the version of puppy, that fits best for me. The puppy main page is quite confusing, you will mostly install older distros Smile

I tried xenial as you all mentioned that one.

What works now:

- Graphics works out of the box.
- Wireless: The problem was that i can not use special characters as - in the
Passfrase. I used WPA2 Preshared key.
- Touchpad very sensetive: Configured graphical interface, ok.

What is not optimal, and i need help with:

- Encryption: When i activate encryption, my password does not work. Error message, something like not able to acsess... press enter to reenter password.
- Soundcard. Fiddling. Had to change to analog from HDMI. Speaker seems
to be ok. But with headphones i needed to go back and forward in alsa and
activate and deactivate. If i move the slider in main volume in the
"startbar" The sound goes on/off. Can adjust the level in programs/browser
though.
The problem might be a combined Mic/headphones jack?
Back to top
View user's profile Send private message 
sitdown

Joined: 03 Jan 2015
Posts: 13

PostPosted: Sat 23 Jul 2016, 05:13    Post subject:  

Should i move to the Xenial forum to get help for the rest of my problems with Xenial? It is probably bugs they are working with?

Thank you for your help Smile
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12634
Location: Stratford, Ontario

PostPosted: Sat 23 Jul 2016, 07:38    Post subject:  

sitdown wrote:
Should i move to the Xenial forum to get help for the rest of my problems with Xenial? It is probably bugs they are working with?

Yes. This thread is hard to find.
Back to top
View user's profile Send private message 
sitdown

Joined: 03 Jan 2015
Posts: 13

PostPosted: Sun 07 Aug 2016, 04:53    Post subject:  

Slett
Last edited by sitdown on Sun 07 Aug 2016, 04:55; edited 1 time in total
Back to top
View user's profile Send private message 
sitdown

Joined: 03 Jan 2015
Posts: 13

PostPosted: Sun 07 Aug 2016, 04:54    Post subject:  

So this is the forum thread to use then?: http://www.murga-linux.com/puppy/viewtopic.php?t=106479

This thread is difficult to find because not many people uses the hardware forum?

I have an additional problem:
Get flash not working, something like: can not connect to server.[/url]
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1225s ][ Queries: 11 (0.0401s) ][ GZIP on ]