Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 24 Oct 2017, 01:58
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Interpreting Python Error Codes
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
bh56

Joined: 07 Apr 2009
Posts: 53

PostPosted: Mon 01 Aug 2016, 08:04    Post subject:  Interpreting Python Error Codes
Subject description: Using Livestreamer with Web
 

Hi,
I'm trying to use webdl from https://delx.net.au/projects/webdl.
I've installed livestreamer and its dependencies.
To get the program to run I use python ./grabber from the webgl folder.
I get this output:
Choose> 1
INFO Downloading: Glass A Portrait Of Philip In Twelve Parts.ts
Traceback (most recent call last):
File "/usr/local/bin/livestreamer", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2749, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 444, in _build_master
ws.require(__requires__)
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 725, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 628, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: requests>=1.0,<3.0
ERROR livestreamer exited with error code: 1
Press return to continue...
Could anybody be able to interpret what this all means (and how to fix it)?
Brendan
Back to top
View user's profile Send private message 
learnhow2code

Joined: 12 Jun 2016
Posts: 1015

PostPosted: Tue 09 Aug 2016, 02:31    Post subject: Re: Interpreting Python Error Codes
Subject description: Using Livestreamer with Web
 

the main thing here is:

Quote:
Traceback (most recent call last):
File "/usr/local/bin/livestreamer", line 5, in <module>
from pkg_resources import load_entry_point


thats the line of python (line 5) in the file "/usr/local/bin/livestreamer" that isnt working.

"most recent call last" if you look at the call at the bottom of the traceback (i think these things are difficult to follow, but they often do a lot to hint at the issue) it says: pkg_resources.DistributionNotFound: requests>=1.0,<3.0

what i know about this is: python requests is a python library. it seems to suggest you need a version of python requests (or even a version of python that includes it) that is between 1.0 and 2.x, but NOT 3.0.

if i do a search for python-requests in apt it gives me:

Quote:
python-requests - elegant and simple HTTP library for Python2, built for human beings


this means its probably not a standard python library-- its 3rd party. so if i install it, and run dpkg -l | grep requests i get that its version 2.4.3-6 (sound good, lets get you a copy):

go to http://packages.debian.org ... look for python-requests in the search... click on stable...

http://http.us.debian.org/debian/pool/main/r/requests/python-requests_2.4.3-6_all.deb

save that and dpkg-deb -x python-requests_2.4.3-6_all.deb / ...in puppy.

then run python:
# python

and see if it lets you do this command:
>>> import requests

if it has an error, youre still not set up. let me know what it says.

if it says this as a reply:

>>>

then try to run gstreamer again.

its been a week, so perhaps you gave up. thats understandable. take care.
Back to top
View user's profile Send private message 
bh56

Joined: 07 Apr 2009
Posts: 53

PostPosted: Thu 11 Aug 2016, 02:14    Post subject: Error codes  

Thanks for your reply.
I've downloaded a number of python modules and got one part of the program to run.
The program I'm running is python ./grabber.
It in turn, is calling another program called livestreamer.
Livestreamer fails with this error

livestreamer is not supposed to be run as root. If you really must you can do it by passing --yes-run-as-root.
ERROR livestreamer exited with error code: 1
Press return to continue...

Strangely running
livestreamer --yes-run-as-root
fails with with an unrecognized argument error.

I think I need to post in the livestreamer forum if there is one.
Thanks again.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0365s ][ Queries: 13 (0.0080s) ][ GZIP on ]