Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Nov 2017, 22:24
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy Packetmanager(PPM2) does save when it should not
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
backi

Joined: 27 Feb 2011
Posts: 1347
Location: GERMANY

PostPosted: Thu 27 Oct 2016, 06:37    Post subject:  Puppy Packetmanager(PPM2) does save when it should not  

Using Tahrpup 6.0.5 frugally installed to Flash .
As i experienced ...when running Puppys with New Puppy Packet Manager (PPM2) ... even in "no save mode " .... setting Pup Event Manager-Save-Intervals=0
(only saving on demand with save2flash )
also using Puppy Packetmanager-Configure"install to tmpfs instead of savefile, till session is saved" .....
when installing pets or installing from Puppy Packet Manager (PPM2) during session ........
they are immediately saved to save-folder despite Pup Event Manager set to Save-Intervals=0.
Other changes (configuration,Wallpaper changing ) will not be saved during session ...in this mode .

Which means using :

1.Puppy Packetmanager-Configure"install to tmpfs instead of savefile, till session is saved" does not work.
2.setting Pup Event Manager-Save-Intervals=0 does not work .
3.installing Pupsaveconfig 2.2.6 does not work ......
to prevent saving to flash when installing pets or installing from Puppy Packet Manager (PPM2) .
This is corroborated from different other users .
See Discussion here :

My suspicious:
its a special problem from PPM2
See also discussion here:

http://murga-linux.com/puppy/viewtopic.php?p=930204#930204
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 2910

PostPosted: Thu 27 Oct 2016, 11:31    Post subject:  

Try this patch
Code:
--- a/usr/local/petget/installpkg.sh
+++ b/usr/local/petget/installpkg.sh
@@ -185,7 +185,8 @@
 #elif [ "ABC" = "DEF" ];then #111013
 elif [ $PUPMODE -eq 3 -o $PUPMODE -eq 7 -o $PUPMODE -eq 13 ];then
   # SFR: let user chose...
-  [ -f /var/local/petget/install_mode ] && IMODE="`cat /var/local/petget/install_mode`" || IMODE="savefile"
+  [ -f /var/local/petget/install_mode ] && IM="`cat /var/local/petget/install_mode`" || IMODE="savefile"
+  [ "$IM" = "true" ] && IMODE="tmpfs" || IMODE="savefile"
   if [ "$IMODE" != "tmpfs" ]; then
     FLAGNODIRECT=1
     #100426 aufs can now write direct to save layer...
(fixed in woof too)
_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1347
Location: GERMANY

PostPosted: Thu 27 Oct 2016, 15:18    Post subject:  

thanks for reply ..........going to test ...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0273s ][ Queries: 11 (0.0040s) ][ GZIP on ]