Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 18 Dec 2017, 03:35
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
No wireless on Slacko 6.3 # SOLVED
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
Eksa

Joined: 04 Nov 2016
Posts: 9

PostPosted: Fri 04 Nov 2016, 15:13    Post subject:  No wireless on Slacko 6.3 # SOLVED
Subject description: Could not set my wireless adapter to work
 

I am new with Puppy, so don't be so harsh with me.

I have this problem and I want to know next:

Is it supported by Puppy new wireless chipset from Lenovo (Ideapad B51-80)?
If yes, I don't now how to activate it. Please help.

# lspci produce this:

00:00.0 Host bridge: Intel Corporation Device 1904 (rev 0Cool
00:02.0 VGA compatible controller: Intel Corporation Device 1916 (rev 07)
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
00:17.0 SATA controller: Intel Corporation Device 9d03 (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Device 9d14 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Device 9d15 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d48 (rev 21)
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
01:00.0 Display controller: AMD/ATI [Advanced Micro Devices, Inc.] Sun XT [Radeon HD 8600M Series] (rev 83)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 15)
03:00.0 Network controller: Intel Corporation Device 3166 (rev 99)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

Hope I provided enough information for someone how know how to help me with this.
Thanks in advance.

Last edited by Eksa on Sun 06 Nov 2016, 09:03; edited 1 time in total
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 260
Location: S.E Australia

PostPosted: Fri 04 Nov 2016, 18:02    Post subject:  

Hi. Seems the rts5229 driver is missing/failing. We need to know exactly which Slacko you're using & whether 32bit or 64bit, and if used live, or full or frugal install.

EDIT: my attempt to make both 32bit & 64bit drivers for Slacko 6.3.0 failed due to kernel options. Need greater boffin to address this.

Previous discussion on similar issue with different Puppy:
http://murga-linux.com/puppy/viewtopic.php?t=84944&start=57
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1499
Location: Italy

PostPosted: Sat 05 Nov 2016, 00:08    Post subject:  

Could it be a firmware issue? Try to load:

http://distro.ibiblio.org/puppylinux/pet_packages-slacko14.1/fdrv_4.1.11_slacko_PAE.sfs

and use the 4.1.11 kernel.
Back to top
View user's profile Send private message 
Eksa

Joined: 04 Nov 2016
Posts: 9

PostPosted: Sat 05 Nov 2016, 14:56    Post subject:  

Hi,

Thank you both (watchdog & ozsouth) for quick answer.

After uploading a new firmware, suggested by watchdog, my wireless module was found and started to WORK Very Happy . It's seems that's solution.

@ozsouth: I am using 64bit of Slacko installed on my USB stick.

Once again, thank's guys!

Cheers...
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1499
Location: Italy

PostPosted: Sun 06 Nov 2016, 03:11    Post subject:  

Edit the first post and add "Solved" Wink .
Back to top
View user's profile Send private message 
Eksa

Joined: 04 Nov 2016
Posts: 9

PostPosted: Sat 17 Dec 2016, 10:18    Post subject:  

Sorry guys,

I have the same problem from last time, but this time with Slacko 6.3.2 - 64 bit version? Tried everything like before. Couldn't start to work. Any idea?

Regards,
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1499
Location: Italy

PostPosted: Wed 21 Dec 2016, 02:27    Post subject:  

Have you tried to load:

http://distro.ibiblio.org/puppylinux/pet_packages-slacko6414.1/fdrv_4.1.11_slacko64.sfs

?
Back to top
View user's profile Send private message 
Eksa

Joined: 04 Nov 2016
Posts: 9

PostPosted: Sat 24 Dec 2016, 08:57    Post subject:  

Yes, but noting happens.. Crying or Very sad
Back to top
View user's profile Send private message 
LazY Puppy


Joined: 21 Nov 2014
Posts: 2007
Location: Germany

PostPosted: Sat 24 Dec 2016, 09:46    Post subject:  

watchdog wrote:
Have you tried to load:

http://distro.ibiblio.org/puppylinux/pet_packages-slacko6414.1/fdrv_4.1.11_slacko64.sfs

?

Eksa wrote:
Yes, but noting happens.. Crying or Very sad

I think you'll need to load this fdrv sfs at boot up. Did you?

_________________
RSH

"you only wanted to work your Puppies in German", "you are a separatist in that you want Germany to secede from Europe" (musher0) Laughing

No, but I gave my old drum kit away for free to a music store collecting instruments for refugees! Wink
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 260
Location: S.E Australia

PostPosted: Sat 24 Dec 2016, 16:37    Post subject:  

Perhaps the following page will help:
http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005511.html
Back to top
View user's profile Send private message 
Eksa

Joined: 04 Nov 2016
Posts: 9

PostPosted: Sun 25 Dec 2016, 07:25    Post subject:  

Aber natuerlich LaZy Puppy... it is on my SFS Load on fly list... leider ohne Erfolg...

@ozsouth - Thank you for the link, but i'm not sure which firmware to download... it say's that I have Network controller: Intel Corporation Device 3166 (rev 99), should I take iwlwifi-3160-ucode-25.30.13.0.tgz or something else?

Regards to all,
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1499
Location: Italy

PostPosted: Sun 25 Dec 2016, 16:09    Post subject:  

The fdrv.sfs should be saved in the same location of the frugal install near the zdrv.sfs and the main sfs and it is loaded without sfs load by initrd.gz at init time.
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 260
Location: S.E Australia

PostPosted: Sun 25 Dec 2016, 18:58    Post subject:  

Ok, got a pc with iwlwifi to test. /var/log/messages contains error details - search for iwlwifi - should see exactly which firmware is missing. I needed 7265D-13. MUST copy it to /lib/firmware & reboot (creating savefile, if not full install to disk. Via my earlier link, option 2 may be what you're after. If not, check contents of fdrv_4.1.11_slacko64.sfs.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0855s ][ Queries: 13 (0.0059s) ][ GZIP on ]