Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Aug 2017, 13:49
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use Brother MFC-L2680W in Tahr? SOLVED
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [25 Posts]   Goto page: 1, 2 Next
Author Message
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Sun 04 Dec 2016, 20:46    Post subject:  How to use Brother MFC-L2680W in Tahr? SOLVED  

I selected this printer because I found driver support here.
http://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=mfcl2680w_us&os=128

Easy install on my Windows system but I am doing something wrong on Tahrpup. I downloaded the install package. Saved in root. Unzipped and tried to run it in the console. I get an invalid command message. I must not be typing it in right. Can someone give me very specific instructions for the install ? THANKS.

Last edited by J_D_ on Fri 09 Dec 2016, 22:07; edited 1 time in total
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 569
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Mon 05 Dec 2016, 00:36    Post subject:  

Hi J_D_

Fortunately, forum member rscn51 has put together a program with very specific install instructions to get
Brother printers and scanners running in Puppy.

The first post in the following thread has what you are looking for

http://murga-linux.com/puppy/viewtopic.php?t=42533&sid=9c62a5777112771f0461e862490909f4

The whole thread is chock full of Brother troubleshooting tips if you have problems with the install instructions.

Just so you are aware, you will probably need to remove the install package and start fresh. Don't get rid of the .debs though, you will need them for the next try.

Post back here if you have trouble.

_________________
.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Tue 06 Dec 2016, 00:31    Post subject:  

Ive tried a few more times, per the link above. Debbi comand not found keeps coming up. Will try again tomorrow.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 569
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Tue 06 Dec 2016, 01:50    Post subject:  

debbi is a .pet program that you have to download and install from the page of instructions. It is located for download at the bottom of the first post, easy to miss.

You are running 32-bit Tahrpup?

64-bit is more work to get going but the instructions are there.

You will need to run debbi from the console.

Keep in mind that debbi is case sensitive, so debbi not Debbi.

_________________
.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Tue 06 Dec 2016, 10:05    Post subject:  

Ok, I will go back and get Debbi. Thanks. Using 32 bit Tahrpup,
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 569
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Tue 06 Dec 2016, 10:26    Post subject:  

Grab the debbi 1.2 .pet

When I installed my printer debbi complained but it worked.

I have not set up my printer in 32-bit Tahrpup yet, I will if needed to follow through here. My printer is the MFC-J450DW wireless.

_________________
.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Tue 06 Dec 2016, 10:29    Post subject:  

I went back to the Brother download page. Debbi is part of the download Ive been trying to run. If you look maybe you can tell me what I am doing wrong. Thanks, again.
http://support.brother.com/g/b/downloadhowto.aspx?c=us&lang=en&prod=mfcl2680w_us&os=128&dlid=dlf006893_000&flang=4&type3=625
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 569
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Tue 06 Dec 2016, 10:48    Post subject:  

Did you download and install debbi1.2 pet from the post on this forum?

http://murga-linux.com/puppy/viewtopic.php?mode=attach&id=95134

Why did you send me to the Brother site?

When you run the debbi program from the terminal it starts with debbi , not Debbi. It is case sensitive.

You will not be using the driver install tool from Brother. You have to download the appropriate .deb files for your
printer from Brother to do the manual install of the drivers.

Get the proper driver packages from this page http://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=mfcl2680w_us&os=128

The driver packages you want are mentioned in the first post of the "How to install Brothe Printers and Scanners" thread I referenced you to.

From that post "
Code:
You will download two files - the LPR driver and the CUPS wrapper driver. Get the DEB versions. Select Save to Disk and store them in /root.
As an example, let's assume that you downloaded the files mfc210clpr-1.0.2-1.i386.deb and cupswrapperMFC210C-1.0.2-3.i386.deb.


No point and click from Brother. Hang in there it ain't so bad Wink:

.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Tue 06 Dec 2016, 12:29    Post subject:  

I think, debbi is properly installed. I think cupswrapper is installed. When I clicked it, console opened, Severel lines of script showed and it closed real fast. I think I must be entering something wrong for the debbi command in terminal. Have to quit for the day. Life is getting in the way.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 569
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Tue 06 Dec 2016, 13:53    Post subject:  

Ok, making progress.

Should be just installing these two by using the debbi program with the terminal commands listed below (the green text) Did you download them both to the /root directory?

mfcl2680wcupswrapper-3.2.0-1.i386.deb
mfcl2680wlpr-3.2.0-1.i386.deb

rscn51 is assuming you are using Rox Filer since it is in every puppy.

The following is verbatim from the post by rscn51 I referenced you to.

Code:
You will download two files - the LPR driver and the CUPS wrapper driver. Get the DEB versions. Select Save to Disk and store them in /root. As an example, let's assume that you downloaded the files mfc210clpr-1.0.2-1.i386.deb and cupswrapperMFC210C-1.0.2-3.i386.deb.

Go to your /root folder and press the back-tick key (this is usually the lower-case ~ key above Tab). This opens a terminal window. To display a list of files, type:
Code:   
ls   

Now type:
Code:   
debbi mfc210clpr-1.0.2-1.i386.deb   

followed by
Code:   
debbi cupswrapperMFC210C-1.0.2-3.i386.deb   


After they are installed, then you open the terminal window and enter the command


Open the terminal window using Rox.

You need to supply your file names instead of the examples he is using.

Follow the instructions in his post step-by-step, It is very important to go in the order he presents.

Post back your success! Hang in there, all questions will get answered.

.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Wed 07 Dec 2016, 17:33    Post subject:  

Have not walked away from this. Just been a busy day and still much to do. Dont give up on me yet.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Wed 07 Dec 2016, 19:05    Post subject:  

Tried some things. First I am using Rox. It rocks.
I got the driver and cupswrapper to go to the console but both had the following message.
ln: failed to create symbolic link ‘/usr/share/cups/model/brother-MFCL2680-cups-en.ppd’: File exists
Post- install script completed!
Done
Then I deleted everything I downloaded but the debbi pet and started over. Got the same message for the driver file and now I keep getting, file not found when I enter the cupswrapper.
Linux can really make me feel like an idiot.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Wed 07 Dec 2016, 19:20    Post subject:  

Maybe this will help. When I open the console to enter the cupswrapper, I type,
debbi cupswrappermfcl2680w-3.2.0-1.i386.deb
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 569
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Wed 07 Dec 2016, 22:27    Post subject:  

Code:
ln: failed to create symbolic link ‘/usr/share/cups/model/brother-MFCL2680-cups-en.ppd’: File exists

Thats ok, I think it just means the driver is located in the directory where it was going to create a sym link, should make no difference.

You should hang onto the debs, possible error not found due to delete....

I think you can ignore the errors.

Jump to the next step of the instructions, run the cups wizard and test the printer.

.
Back to top
View user's profile Send private message 
J_D_

Joined: 11 Apr 2014
Posts: 108
Location: Indiana

PostPosted: Wed 07 Dec 2016, 23:10    Post subject:  

Terminal cant find the cupswrapper file. (its there in root) Last night it did find it and returned the error message but at least I had both the drivers and cupswrapper installed. It still wouldnt print. Thats why I deleted everything and started over. Thinking about doing that again. I'd reformat and do a fresh install if I thought that would work.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [25 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0422s ][ Queries: 13 (0.0032s) ][ GZIP on ]