Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 17 Dec 2017, 16:03
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
bash-4.4, published Sept. 15, 2016
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
musher0


Joined: 04 Jan 2009
Posts: 11292
Location: Gatineau (Qc), Canada

PostPosted: Sun 11 Dec 2016, 22:15    Post subject:  bash-4.4, published Sept. 15, 2016  

Hello all.

I couldn't find a thread on the forum for the latest bash, released last
September, so here it is.

Compiled on Puduan-6 with
Code:
./configure --prefix=/usr --docdir=/usr/share/doc/bash-4.4 --with-included-gettext
Untested on other Puppies. Please let me know if it works on yours.

The package is in three parts:
Docs -- https://my.pcloud.com/publink/show?code=XZJiPCZU1v9t1emeSpNsDeq1Spmxzihi9ek
NLS -- https://my.pcloud.com/publink/show?code=XZRiPCZwIRP76pFwQV5IfOJ64ndjkDwz9gV
Exec -- https://my.pcloud.com/publink/show?code=XZziPCZkze27rKRN7mQAHpg1PVdP8AAX4BV

If your Puppy is short on space, you only need to install the "Exec" pet.

As you may have noticed from the configure line (the "gettext" part), this
bash will display messages in your language if it finds its *.mo file.

If you want this feature, download and un-compress the NLS pet, and
install the directory for your language at the corresponding place in your
Puppy. It's easy, it will be the mirror of where it is in the archive, i.e.
/usr/share/locale/Your_Language/LC_MESSAGES/bash.mo. Sorry in
advance for the large NLS file download, but I couldn't see myself creating
a separate pet for each of the 37 languages bash has been translated in...

I've been testing it for a few hours now, and everything runs as it should
with this new bash version.

Its NEWS file is attached. It contains the list of the +/- 50 improvements
in this 4.4 version, and of older changes.

Enjoy!
NEWS.zip
Description  List of improvements in this bash 4.4 version, and of older changes.
zip

 Download 
Filename  NEWS.zip 
Filesize  27.46 KB 
Downloaded  55 Time(s) 

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11292
Location: Gatineau (Qc), Canada

PostPosted: Wed 14 Dec 2016, 11:05    Post subject:  

This post to save this thread from going into limbo! Twisted Evil
_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0459s ][ Queries: 14 (0.0052s) ][ GZIP on ]