Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 11 Dec 2017, 19:02
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
[JWM] How to disable window decorations per application?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
qp0913562

Joined: 07 Jan 2017
Posts: 1

PostPosted: Sat 07 Jan 2017, 13:19    Post subject:  [JWM] How to disable window decorations per application?  

Hi,

does anyone know if it is possible to disable window decorations per application with JWM?

In Openbox this apparently is possible as like in this example:

http://openbox.org/wiki/Help:Applications

Code:
<application class="Firefox*">
   <maximized>yes</maximized>
   <decor>no</decor>
</application>

This example would make Firefox run maximized and without decorations.

Would this also be possible with JWM?
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 11256
Location: Gatineau (Qc), Canada

PostPosted: Sat 07 Jan 2017, 15:23    Post subject:  

Hello qp0913562.

The answer is yes. jwm has a file called jwmrc-personal at /root/.jwm .

Further down in it, it has what jwm calls "groups". In the example below,
the title of the window has been disabled for the xclock program.
Quote:
<Group>
<Name>xclock</Name>
<Option>notitle</Option>
<!-- <Option>noborder</Option> -->
<Option>nolist</Option>
<Option>nopager</Option>
</Group>
Upon launch, the xclock program window will show borders but not
the title.

The options at the bottom mean that this window will not show in the list
of open programs and neither in the window pager in the task bar.

Notice how you enable or disable a feature in the "noborder" line. As it is
in the example, it is disabled.

If you wish to enable "noborder" for the xclock window, remove the
<!-- at the beginning, and the --> at the end. Do the reverse (put these
arrows back at the beginning and end of the line) if you want to disable
any feature.

IHTH.

_________________
musher0
~~~~~~~~~~
"Logical entities must not be multiplied beyond necessity." | |
« Il ne faut pas multiplier les entités logiques sans nécessité. » (Ockham)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0306s ][ Queries: 11 (0.0035s) ][ GZIP on ]