Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Nov 2019, 15:56
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
XenialDog 64bit (Ubuntu 'Xenial Xerus' LTS, 64-bit)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 24 of 29 [423 Posts]   Goto page: Previous 1, 2, 3, ..., 22, 23, 24, 25, 26, 27, 28, 29 Next
Author Message
backi

Joined: 27 Feb 2011
Posts: 1836
Location: GERMANY

PostPosted: Mon 22 Jan 2018, 10:59    Post subject:  

Hi wiak !

Got it .
Glad to hear Smile

Regards !
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4165
Location: holland

PostPosted: Mon 22 Jan 2018, 11:00    Post subject:  

Hi backi, wiak, dancytron, belham

A new thread about zram will be nice, but no need to blank posts IMO.
No worries, It's ok by me here, interesting discussion, btw, thanks !
@backi your english is fine ! Smile

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4165
Location: holland

PostPosted: Thu 25 Jan 2018, 07:13    Post subject:  

New topic about zram and zswap here (thanks wiak !)
http://www.murga-linux.com/puppy/viewtopic.php?t=112599

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Ushichan

Joined: 26 Jan 2018
Posts: 7

PostPosted: Sat 27 Jan 2018, 00:28    Post subject: SUSPEND function not working  

is there a way to suspend as the install of this pet did not work and also holding hown the power button has the option to suspend but does not work on my laptop a hp elitebook 2540p intel i7. Im running a persistent usb install works flawlessly otherwise

I got the pet from
http://murga-linux.com/puppy/viewtopic.php?t=76894
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 1830
Location: not Bulgaria

PostPosted: Sat 27 Jan 2018, 04:33    Post subject: Re: SUSPEND function not working  

Ushichan wrote:
is there a way to suspend as the install of this pet did not work and also holding hown the power button has the option to suspend but does not work on my laptop a hp elitebook 2540p intel i7. Im running a persistent usb install works flawlessly otherwise

I got the pet from
http://murga-linux.com/puppy/viewtopic.php?t=76894


Hi Ushichan,

I doubt that pet is relevant since it is very old from 2012 or so.

I have an older elitebook but have never used suspend or hibernate with it and haven't tried as yet. However, I came across this post, which may or may not help or be relevant:

https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1574120

Quote:
Bruno Santos (bsantos) wrote on 2016-04-24: comment #5
Adding HandleLidSwitchDocked=suspend in /etc/systemd/logind.conf solved it in my system, but suspend was flawless before upgrading to 16.04.
Bruno followed that config file change with a reboot.

EDIT: From same thread:

Quote:
Bob (caltinay) wrote on 2017-06-15: comment #106
I have the same issue on a HP ZBook G3 running Debian with the 4.11 kernel from experimental and after reading comment #103 I tried
rmmod hp_wmi
and this fixed it!


Quote:
Carlo (carlo-b) wrote on 2017-04-10: #103
Just FYI I posted this https://lkml.org/lkml/2017/4/9/57 yesterday. Still to be reviewed.
Hope it helps.


i.e. See: https://lkml.org/lkml/2017/4/9/57
Permanent fix might thus be found in upgraded kernel.

You may find more useful information via that bugs.launchpad thread link given above.

wiak
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4165
Location: holland

PostPosted: Sat 27 Jan 2018, 16:31    Post subject:  

For info, the hp-wmi module is already blacklisted by default in Xenialdog.
I can't remember exactly why I did that, something to do with WiFi not working due to rfkill and the blacklisting fixed that, in /etc/modprobe.d/blacklist.conf:
Code:
blacklist hp-wmi


EDIT: @Ushichan, backi fixed suspend not working problem with acpitool:
http://murga-linux.com/puppy/viewtopic.php?p=978465#978465

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Ushichan

Joined: 26 Jan 2018
Posts: 7

PostPosted: Sat 27 Jan 2018, 21:51    Post subject:  

could I turn off the blacklisting instead as I dont use wife and never will, only ethernet cables here to avoid radiation for our kids

I tried to open as by finally finding filemnt when searching system files but cannot do as you suggested with only open as text as the closest option to your suggestion
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4165
Location: holland

PostPosted: Sun 28 Jan 2018, 08:03    Post subject:  

Ushichan wrote:
I tried to open as by finally finding filemnt when searching system files but cannot do as you suggested with only open as text as the closest option to your suggestion


Should open automatically with leafpad when clicking on /etc/modprobe.d/blacklist.conf from pcmanfm or rox, for me it does, not for you ?
For other files you may need to associate to leafpad, by "Open with..." and choose leafpad from list

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Ushichan

Joined: 26 Jan 2018
Posts: 7

PostPosted: Sun 28 Jan 2018, 23:19    Post subject:  

Hello Fred
I couldnt get this window or the ability to open with anything but geany so cannot get to the screen window you suggest....very dumb user here Sad
fredx181 wrote:
@backi, thanks ! strange that suspend doesn't work for you, it works for me with 'pm-suspend'
If you have time can you do in terminal (and what's the message?):
Code:
pm-suspend


@Null_ID, indeed what rcrsn51 suggested works , but you can also use filemnt, it just needs association (supports also .2fs, .3fs .4fs, besides iso, squashfs and sfs) just right-click on the pupsave file > open with, and type filemnt as custom command line, see pic below (for pcmanfm)

Fred


fredx181 wrote:
Ushichan wrote:
I tried to open as by finally finding filemnt when searching system files but cannot do as you suggested with only open as text as the closest option to your suggestion


Should open automatically with leafpad when clicking on /etc/modprobe.d/blacklist.conf from pcmanfm or rox, for me it does, not for you ?
For other files you may need to associate to leafpad, by "Open with..." and choose leafpad from list

Fred


Yes thank you Fred I was able to do as you said here but still dont know what to do after clicking on blacklist.conf. Still having trouble setting up open with leafpad as it still has geany as the only option
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 1830
Location: not Bulgaria

PostPosted: Mon 29 Jan 2018, 04:36    Post subject:  

fredx181 wrote:
For info, the hp-wmi module is already blacklisted by default in Xenialdog.
I can't remember exactly why I did that, something to do with WiFi not working due to rfkill and the blacklisting fixed that, in /etc/modprobe.d/blacklist.conf:
Code:
blacklist hp-wmi


EDIT: @Ushichan, backi fixed suspend not working problem with acpitool:
http://murga-linux.com/puppy/viewtopic.php?p=978465#978465

Fred


The only thing is, it seems some would (understandably) like suspend to work on closing the lid, which it is supposed to I think. That's what I was posting about, but admit to never having tried it myself! Basically, I was however curious if anyone tried the method:

Quote:
Adding HandleLidSwitchDocked=suspend in /etc/systemd/logind.conf


Of course I can try it myself sometime, though really I never care to suspend/hibernate my system

EDIT: well method suggested above didn't work for me on my HP Elitebook 2530p in a quick test. Having said that, my elitebook is a strange old beast which for unknown reason (maybe just BIOS battery - haven't changed it as yet) takes over a minute to even reach grub4dos menu (fine after that) so the suspend idea needs further testing by anyone with more reliable machine I'd say... EDIT2: Hmmm, I'm not sure if it worked or not - discovered I was still logged in the murga forum when lid was opened, but fan seemed to keep running all the time (but then again, I'm not using battery power and have to check if BIOS has fan always on when on mains power.

wiak
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4165
Location: holland

PostPosted: Mon 29 Jan 2018, 06:57    Post subject:  

Ushichan wrote:
I couldnt get this window or the ability to open with anything but geany so cannot get to the screen window you suggest....


Not completely sure if I understand well your problem, anyway see screenshot how to associate from pcmanfm filemanager, e.g. with leafpad (under accessories)

Once you opened the file /etc/modprobe.d/blacklist.conf, to un-blacklist, remove the line:
Code:
blacklist hp-wmi

Save the file and reboot.
(I doubt if that will help for your suspend problem, but worth trying anyway)

Fred
open_with.png
 Description   Open with...
 Filesize   45.87 KB
 Viewed   426 Time(s)

open_with.png


_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 1830
Location: not Bulgaria

PostPosted: Thu 08 Feb 2018, 20:31    Post subject:  

Am at early stage of writing a simple app to control webcam parameters and for image/video previews was hoping to use:

Code:
mpv av://v4l2:/dev/video0

or

mpv tv://


However, I find there is a lag in the mpv playing webcam video of several seconds (i.e. it can't keep up with movements - as if it is buffering first). I've only tested this with XenialDog64 mpv.

There is no such lag when using the mplayer available in XenialDog64 with "mplayer tv://" command but I'd like possibility of using mpv as alternative to mplayer if desired. Anyone come across an mpv lag fix for the above?

wiak

EDIT: I've tried creating ~/.config/mpv/mpv.conf and playing around with options like cache=nnn and demuxer-readahead-secs=nnn but not having any effect. Might not be doing it right but as I say mplayer works fine - webcam image keeps up with movements with no lags/delay at all.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4165
Location: holland

PostPosted: Sat 10 Feb 2018, 11:49    Post subject:  

Hi wiak, maybe try newer mpv, didn't test on XD, but I expect it works:
https://fredx181.github.io/bionicdog/Packages-amd64/Extra/mpv_0.27.0-ddstretch_amd64.deb

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 1830
Location: not Bulgaria

PostPosted: Sun 11 Feb 2018, 05:45    Post subject:  

fredx181 wrote:
Hi wiak, maybe try newer mpv, didn't test on XD, but I expect it works:
https://fredx181.github.io/bionicdog/Packages-amd64/Extra/mpv_0.27.0-ddstretch_amd64.deb

Fred


hmmm... well I tried installing that mpv you provided fred by right click install deb action from pcmanfm. However, that revealed there were missing dependencies, which I thought it was then auto-installing... But actually, it was installing a lot of other stuff (including mplayer...) whilst removing gnome-mplayer and mpv amongst some other stuff.

How best to install it? Maybe if I noted some of the apparently missing dependencies and installing them first? Sorry, haven't had time to try more.

wiak
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4165
Location: holland

PostPosted: Sun 11 Feb 2018, 07:17    Post subject:  

Ah, sorry wiak, I should have tested first.
I changed a few dependency names, made a new package specially for Xenialdog64, added to 64bit repo, so a "apt-get update && apt-get install mpv" should upgrade to v0.27 (tested now Wink )

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 24 of 29 [423 Posts]   Goto page: Previous 1, 2, 3, ..., 22, 23, 24, 25, 26, 27, 28, 29 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0841s ][ Queries: 12 (0.0306s) ][ GZIP on ]