Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 05:50
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
PSI: Puppy Software Installer 07
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 10 [148 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 09 Feb 2008, 23:31    Post subject:  

I updated the version for Puppy 3.
It now starts quicker.
On my system, the old one needed 70 seconds to start, this now is reduced to 30 seconds.
Details about the change:
http://wxbasic.sourceforge.net/phpBB2/viewtopic.php?p=5425#5425

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 10 Feb 2008, 03:15    Post subject:  

Smile Mark if the puppybasic runtme is added to Dingo (Puppy 4 in testing for those wondering) is there a chance PSI would work.?
_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 10 Feb 2008, 03:33    Post subject:  

yes, someone is already working on a dotpet.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sun 10 Feb 2008, 05:52    Post subject:  

MU wrote:
I updated the version for Puppy 3.

Mark, there is still a problem with this version in your install script. It calls dillo for htm files when Puppy 3 has netsurf. Substituting the browser name resolves the problem and you can again click on htm files in PSI and get the appropriate link or explanation file.

Cheers

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
changturkey

Joined: 29 Dec 2007
Posts: 67

PostPosted: Tue 12 Feb 2008, 10:30    Post subject:  

Will a Puppy4 version be coming out soon?
Back to top
View user's profile Send private message 
setecio

Joined: 01 Nov 2006
Posts: 326
Location: UK

PostPosted: Tue 12 Feb 2008, 13:45    Post subject:  

Does PSI for Puppy 3 require the getdir.pup and Gtklist04MU.pup ?

I wasn't sure, from the first page in this thread, whether these are only required for Puppy 2 or also for Puppy 3 .

Thanks.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 12 Feb 2008, 15:30    Post subject:  

Gtklist04MU.pup is required in Puppy 3.
Getdir is already included.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 12 Feb 2008, 15:35    Post subject:  

changturkey wrote:
Will a Puppy4 version be coming out soon?


Someone has installed it in Puppy 4 alpha.
So if he provides a dotpet - fine.
Myself I actually wait at least until there is a beta available.
Barry has dropped dotpuprox.sh in Puppy 4, so you had to copy that from Puppy 3.
I don't know what Barry plans concerning dotpups, so I'm hesitating to release a version for Puppy 4 already "officially".
Don't know what he changed in petget, if it is still compatible with the entries that dotpups add.

Can someone report experiences?
I currently concentrate on the Puppy 3 series.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
richhard

Joined: 22 Jul 2007
Posts: 51

PostPosted: Sun 17 Feb 2008, 04:59    Post subject:  

Hi Mu,
the PSI is really a genious tool! One question come up:
- I can't install the debianinstaller-beta01.tar.gz
- the debianinstaller-alpha09.pet however is working fine.

--> How can I get the newest version?

Remark: with the debianinstaller I was able to install the
driver and cups-wrapper for my Brother dcp-130c printer,
and it is working straight ahead!! Laughing
To help others, I would like to put it into the wiki, but this seems
to be difficult.
For the scanner I still have troubles with the sane stuff.

==> the debianinstaller is quite an important issue and should
keep his place in the PSI, to enable the use of any kind of drivers.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 17 Feb 2008, 10:07    Post subject:  

The debianinstaller is no longer supported.
Please use Gslapt instead, the Slackware packagemanager.

It is more intuitive, has long-time-support, and Slackware packages will be more compatible with Puppy.
http://murga-linux.com/puppy/viewtopic.php?t=21908

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
richhard

Joined: 22 Jul 2007
Posts: 51

PostPosted: Mon 18 Feb 2008, 04:33    Post subject:  

Hi Mu, of coarse it is nice to have available a repository with a huge
number of SW and a nice comment to them!

Sorry, but you missed my point: Crying or Very sad
as we know, Linux is not comfortable supported with drivers for the
connected hardware. But if a company makes the efford, then the
support is as .deb or .rpm available, but most probably not as .pet ! Rolling Eyes

Conclusion: users of not on deb or rpm based distributions have a
problem, to bring their Printer and Scanner to work (except they are
experts!).
But if there is an option to install .deb or .rpm drivers, they will be
happy! Wink

Question: how to do this without the debianinstaller (which works nice!)??
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 18 Feb 2008, 10:33    Post subject:  

you can use "undeb".
http://dotpups.de/dotpups/System_Utilities/unrpm.undeb.pup

This is what the debian-installer uses, too.

in a console you type in a temporary folder:
undeb xxx.deb

Then you can copy the extracted files to your Puppy.

pb_debianinstaller is just a grafical interface for undeb.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 06 May 2008, 08:22    Post subject:  

Confused Has the version 4 "Dingo" PSI materialised? On its way?
The package manager in Dingo looks great
but where are all the programs? Embarassed

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
tombh


Joined: 12 Jan 2007
Posts: 422
Location: Bristol, UK

PostPosted: Thu 05 Jun 2008, 09:05    Post subject:  

Hi Mark,

I'm just writing the cron jobs on the Community Website to update these package lists once a day for the software search ;

http://puppyfiles.org/dotpupsde/dotpups/pupget_packages-1-dotpups.txt
http://puppyfiles.org/dotpupsde/dotpups/pet_packages-2-dotpups.txt
http://puppyfiles.org/dotpupsde/dotpups/pet_packages-3-dotpups.txt

and it occurred to me that there isn't one for Puppy 4. Is there one somewhere or can I help make one?

tom Smile

_________________
Colour-Memories Database
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 05 Jun 2008, 11:57    Post subject:  

there was no script for that yet.

I now adapted one.
So you have:
http://dotpups.de/dotpups/pet_packages-4-dotpups.txt
or
http://dotpups.de/dotpups/pet_packages-4-dotpups.txt.tar.bz2

But it is not updated daily.

I attach a PHP-script, that you can use on your own server, to generate such a list, e.g. daily by a cron-job.
Extract it somewhere on your server, then run it like
http://test.org/.getpets4.php

It will tell you the usage, that is performed in 2 steps:
.getpets4.php?mode=getindex
This downloads the packagelist from ibilio.

.getpets4.php?mode=buildlist
This creates the final list, and a zipped version.

The script requires, that you are allowed to run shell commands from PHP, what is not the case on every server.
If you cannot do that, I can send you via PM a link to the scripts on my server (they have a different name there).
This script should be run only by an admin or cronjob, and only once at the same time, as it has no file-locking.
If 2 persons would run it at the same time, this could create a corrupted dotpups.txt.

Mark
getpets4.php.tar.gz
Description 
gz

 Download 
Filename  getpets4.php.tar.gz 
Filesize  983 Bytes 
Downloaded  595 Time(s) 

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 9 of 10 [148 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0980s ][ Queries: 12 (0.0257s) ][ GZIP on ]