Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Nov 2017, 13:31
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Filesystem
XFE-1.4.2
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
WiZard

Joined: 11 Sep 2005
Posts: 61

PostPosted: Sun 26 Feb 2017, 11:58    Post subject:  XFE-1.4.2
Subject description: XFE 2-3 pane file manager
 

I've compiled XFE 1.4.2 file manager which has improved features, bug fixes and a built in file/text search. I also slimmed it down to reduce the installed size and tested it in:
Lucid 5.2.8
Wary 5.3.3
Precise 5.7.1
Slacko 5.3
Slacko 6.3.0
Tahr 6.0.5

I'd like to share it if someone can guide me to a place to upload the 1.9mb pet file.

It requires the fox toolkit to run. The README file in the source code said it required fox 1.6.36 or newer, but less than 1.7.0, I compiled in Puppy 5.2.8 with fox-1.6.37-i486.pet installed. I had been using XFE 1.19.2 with fox-1.6.31.pet installed. The first thing I noticed was that XFE's installed size grew from 6mb to 35mb. This was mostly due to the increased size of fox-1.6.37 which takes 28mb. I tried running it with fox-1.6.31 and it seems to work fine, that reduced the install to 11mb.

Other Changes:
-XFE 1.4.2 included three helper applications, a text editor, a image viewer, and a package manager. Since these were redundant, they were removed.
-Moved xfe.desktop file into usr/share/applications to conform to Puppy's convention.
-Changed XFE program preferences (file associations) to Puppy's default applications.

This brought the install size down to 8mb.

http://archive.org/download/Puppy_Linux_Forum_Pets/xfe-1.42mod-i686.pet

To use:
-install xfe-1.42mod-i686.pet
-install fox-1.6.31.pet or fox-1.6.37-i486.pet if you don't mind the size increase.

Last edited by WiZard on Wed 01 Mar 2017, 19:44; edited 2 times in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 9517
Location: Charleston S.C. USA

PostPosted: Sun 26 Feb 2017, 12:23    Post subject:  

Try here:
http://www.smokey01.com/

I assume contact by E-mail to make a request for submission.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4295
Location: West Lothian, Scotland, UK

PostPosted: Sun 26 Feb 2017, 14:41    Post subject:  

Have you repaired the [normally] empty right-click on file "Open-with" context menu?
It's always a pest to have to fix this. Sad
Back to top
View user's profile Send private message 
WiZard

Joined: 11 Sep 2005
Posts: 61

PostPosted: Sun 26 Feb 2017, 15:54    Post subject:  

@Sylvander
I did not attempt to fix the "open with" issue and I don't think my skills qualify me to tackle it. Do we know if this is unique to Puppy or is it in all distros? Has anyone reported it as a bug to the author?

wiz
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1583
Location: lincoln, uk

PostPosted: Sun 26 Feb 2017, 15:57    Post subject:  

wizards xfe: http://archive.org/download/Puppy_Linux_Forum_Pets/xfe-1.42-i686.pet

Smile
Back to top
View user's profile Send private message Visit poster's website 
Geoffrey


Joined: 30 May 2010
Posts: 2307
Location: Queensland

PostPosted: Sun 26 Feb 2017, 16:13    Post subject:  

Doesn't work for me in X-Tahr 2.0, needs libFOX-1.6.so.0, there is a broken symlink libjpeg.so.62, also was compiled for /usr/local.
_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
WiZard

Joined: 11 Sep 2005
Posts: 61

PostPosted: Sun 26 Feb 2017, 17:03    Post subject:  

@geoffery
XFE uses libjpeg.so.62. All the Puppies I tested with had it except Slacko 6.3 which only had the newer libjpeg.so.8.0.1. I did a crude hack and made a libjpeg.so.62 symlink to libjpeg.so.8.0.1 and put it in usr/local/lib, this let it work in Slacko 6.3 and didn't break the others. Try looking for libjpeg.x.x files in usr/lib. You may find several symlinks already there, but choose the one that isn't a symlink and then make a new symlink to it named libjpeg.so.62. You can delete the broken usr/local/lib/libjpeg.so.62 symlink.

The compile used the source default configure which was for /usr/local. My apologies if this breaks a convention, I can probably figure out how to put it somewhere else, let me know. New at this.

wiz
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 2307
Location: Queensland

PostPosted: Sun 26 Feb 2017, 19:58    Post subject:  

WiZard wrote:
@geoffery
XFE uses libjpeg.so.62. All the Puppies I tested with had it except Slacko 6.3 which only had the newer libjpeg.so.8.0.1. I did a crude hack and made a libjpeg.so.62 symlink to libjpeg.so.8.0.1 and put it in usr/local/lib, this let it work in Slacko 6.3 and didn't break the others. Try looking for libjpeg.x.x files in usr/lib. You may find several symlinks already there, but choose the one that isn't a symlink and then make a new symlink to it named libjpeg.so.62. You can delete the broken usr/local/lib/libjpeg.so.62 symlink.

The compile used the source default configure which was for /usr/local. My apologies if this breaks a convention, I can probably figure out how to put it somewhere else, let me know. New at this.

wiz


Worked with libFOX installed.

I never compile to use local, that's pretty much the norm.

To compile it to not use local
Code:
./configure --prefix=/usr


To fix the libjpeg.so.62 missing in slacko, you could add a pinstall.sh script to the package,
that way you will have no need to put one in /usr/local/lib.

Code:
# Add symlink for Slacko
# will not overwrite libjpeg.so.62 if it already exists
ln -s /usr/lib/libjpeg.so.8.0.1 /usr/lib/libjpeg.so.62


Code:
root# ln -s /usr/lib/libjpeg.so.8.0.1 /usr/lib/libjpeg.so.62
ln: failed to create symbolic link ‘/usr/lib/libjpeg.so.62’: File exists
root#

_________________
Carolina: Recent Repository Additions

Back to top
View user's profile Send private message 
WiZard

Joined: 11 Sep 2005
Posts: 61

PostPosted: Sun 26 Feb 2017, 20:53    Post subject:  

@Geoffery
Great, will go back and see if I can redo and make it work. Smarter now thanks to you.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1583
Location: lincoln, uk

PostPosted: Wed 01 Mar 2017, 16:13    Post subject:  

replacement XFE from wizard:

http://archive.org/download/Puppy_Linux_Forum_Pets/xfe-1.42mod-i686.pet

Smile
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Filesystem
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0409s ][ Queries: 11 (0.0036s) ][ GZIP on ]