Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Nov 2017, 17:11
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Woof CE Debian Stretch and Devuan Ascii Based Development
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 45 of 48 [717 Posts]   Goto page: Previous 1, 2, 3, ..., 43, 44, 45, 46, 47, 48 Next
Author Message
OscarTalks


Joined: 05 Feb 2012
Posts: 1632
Location: London, England

PostPosted: Wed 27 Sep 2017, 08:47    Post subject:  

B.K. Johnson wrote:
I meant the PartView icon which on click gives the size/free storage for each inserted storage device.

Hello B.K.,
This was actually a very useful report. The icon in the tray notification area is in fact freememapplet_tray and this was not always displaying, perhaps because I had an older version of it in there. It would show up if I had a save-file but not with a save-folder or without any save (segmentation fault).

I found the sources in the Puppy ibiblio repos and compiled version 2.8.6 of freememapplet_tray which seems to have fixed things. This icon should appear automatically (triggered from /root/.config/autostart) and there is no way to start it from the menu.

Left clicking on the freememapplet_tray icon launches partview which shows Puppy version, kernel version and free/used space in partitions.

The partview program menu entry had been "switched off" by someone adding the line NoDisplay=true in the .desktop file (presumably because the idea is to launch it from the freememapplet_tray icon instead). To restore it to the menu you can change the line to NoDisplay=false or just remove the line. To refresh the menu after any changes, always run fixmenus followed by jwm -reload. You then have the 2 alternative methods of launching partview.

I have added these changes and re-uploaded the test .iso
https://yadi.sk/d/nzC5YTU93MgVaf?force_show=1

_________________
Oscar in England

Back to top
View user's profile Send private message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 639

PostPosted: Thu 28 Sep 2017, 07:58    Post subject:  

Hi OscarTalks, a couple How do I dos:
1. Change my cursor.?
In tahr, I usually install the cursor-themes pet then using Menu>Desktop>JWMDesk Manager then Mouse Cursor and select the cursor I want. That route is not available in your debian stretch 7. So how do I change the cursor?
2. Change the font (and colours) used in the console?
The default colours of white on black is the ideal combination, I think, but the default font makes the screen incomprehensible.

I downloaded version 2 but won't be able to get to it for a while.

_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1632
Location: London, England

PostPosted: Thu 28 Sep 2017, 11:18    Post subject:  

Hello B.K.,
When you install cursor themes they go into the hidden /root/.icons directory.
There is one already in there called crystalgold but it is not activated.
Inside the /root/.icons directory just make a symlink named default to the chosen cursor theme directory.
Then restart X and the new cursor theme should be active.

There are 2 consoles.
For Urxvt there is Urxvt Terminal Control in the main menu.
The other one is LXterminal which has a preferences GUI in its drop-down menu options.

EDIT:- I compiled and added urxvt upgrade to version 9.22 some time ago. This has support for tabs which can be activated via Terminal Control (plugins button).
The config for urxvt is /root/.Xdefaults so perhaps an update to this would be a good idea as well. I have now added this. Of course it gets overwritten when the user changes anything, but maybe at least the starting config is a little better now.

_________________
Oscar in England

Back to top
View user's profile Send private message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 639

PostPosted: Thu 28 Sep 2017, 23:15    Post subject:  

@OscarTalks
Thanks very much for those bits of info. Greatly appreciated.
BK

_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1632
Location: London, England

PostPosted: Sun 01 Oct 2017, 07:56    Post subject:  

Firefox version upgrade to latest ESR 52.4.0
This is the official Debian build, not the Mozilla version, so will not auto-update.
It depends on GTK3 (which is in Dpup Stretch) but does NOT need pulseaudio.

This Puppy is a good choice for people wanting to run very recent browsers.
It is 32bit so Google Chrome is out, but you have a choice of other Chromium derivatives.
My personal favourite is Vivaldi and latest stable version 1.12 is based on Chromium 61.0.3163.102 and it seems to run as sweet as a nut after applying the usual couple of tweaks. There is a .sfs package of this in case anyone wants to give it a try.
EXPERIMENTAL .iso and packages including VLC 2.2.6 are here:-
https://yadi.sk/d/nzC5YTU93MgVaf?force_show=1

_________________
Oscar in England

Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3265
Location: Ontario Canada

PostPosted: Sun 01 Oct 2017, 10:44    Post subject:  

Hi OscarTalks,
I installed your latest iso to my lenovo thinkcentre desktop:

video-info-glx 1.5.3 Sun 1 Oct 2017 on Dpup Stretch 7.0.0a1 Linux 4.13.2 i686
0.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)

X Server: Xorg Driver: nvidia
X.Org version: 1.19.1
dimensions: 3840x1080 pixels (1049x292 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 430/PCIe/SSE2es
OpenGL core profile version string: 4.5.0 NVIDIA 384.90

Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
Core 0: @2992 1: @2992 MHz

I updated PPM and installed some applications + added the proprietary nvidia driver.
Also install JWMDesk-2.4.pet and JWM_themes_update-2.0.pet by radky.
No luck with firefox or vlc, both segfault when I try to run them.
I'm using Qupzilla from PPM and it's working well.

Thanks.
screenshot.jpg
 Description   
 Filesize   38.47 KB
 Viewed   743 Time(s)

screenshot.jpg

screenshot2.jpg
 Description   
 Filesize   12.67 KB
 Viewed   744 Time(s)

screenshot2.jpg

Back to top
View user's profile Send private message 
foxpup


Joined: 29 Jul 2016
Posts: 243
Location: europa near northsea

PostPosted: Sun 01 Oct 2017, 14:49    Post subject: Re: short report, OscarTalks dpup install on 2 machines  

OscarTalks wrote:
I did change the uploaded .iso the other day to include the 4.13.2 kernel so not sure which one you have. If you have the 4.4.87 then you might want to grab it again to extract the 4.13.2 vmlinuz and zdrv and try switching them.
Hello Oscar. I 've downloaded your iso last night; that was just before you uploaded a new one Surprised
I switched vmlinuz and zdrv.sfs (4.4=>4.13). Then I had to throw in a more recent driver for wifi.
All seems to go well.
No problem with firefox (ESR 52.3.0).
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3265
Location: Ontario Canada

PostPosted: Sun 01 Oct 2017, 18:26    Post subject: Woof CE Debian Stretch and Devuan Ascii Based Development  

I downloaded the palemoon installer from their homepage and installed version 27.5.0 (32bit)
It plays videos with sound from a local news site while running as user spot.

I changed some things with JWMDesk as well.

Thanks @OscarTalks
newbackground.jpg
 Description   
 Filesize   39.13 KB
 Viewed   661 Time(s)

newbackground.jpg

palemoon.jpg
 Description   
 Filesize   93.34 KB
 Viewed   664 Time(s)

palemoon.jpg

Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Tue 03 Oct 2017, 06:20    Post subject:  

OscarTalks wrote:

EXPERIMENTAL .iso and packages including VLC 2.2.6 are here:-
https://yadi.sk/d/nzC5YTU93MgVaf?force_show=1


Cups not working for me. "Filter failed" with Brother laser printer.
Back to top
View user's profile Send private message 
davids45


Joined: 26 Nov 2006
Posts: 992
Location: Chatswood, NSW

PostPosted: Tue 03 Oct 2017, 19:13    Post subject: Non-printing Stretch Pups
Subject description: ghostscript faulty and missing link
 

G'day watchdog,

I thought I was the only one who still wanted to use a printer in Puppyland Laughing .

I was advised how to fix the 'filter failed' problem in new Pups (32-bit) by:

1) replacing/deleting the faulty ghostscript version (numbered 9.14 or thereabouts) in woof-based Pups with an older working version (9.05, using a ghostscript_s533-9.05.pet) plus another needed pet

2) make a link in /lib called ld-lsb.so.3 to the existing ld-2.23.so file

One or both of these fixes has allowed me to print on paper with my Epson in Stretch Pups and other recent 32-bit Pups which won't print here because of these filter faults.

http://www.murga-linux.com/puppy/viewtopic.php?p=968898&search_id=751235165#968898
may help you see better what I have to do for printing although this post was about more than just printing problems.

Good luck.

David S.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Wed 04 Oct 2017, 07:21    Post subject: Printing in a chroot jail
Subject description: for geek?
 

watchdog wrote:
OscarTalks wrote:

EXPERIMENTAL .iso and packages including VLC 2.2.6 are here:-
https://yadi.sk/d/nzC5YTU93MgVaf?force_show=1


Cups not working for me. "Filter failed" with Brother laser printer.


Poppler needs to be correctly installed but no luck for printing even with poppler. There is a bug in this cups.

The following script uses a chroot jail in /mnt/home from tahr-6.0.2 to use the chroot jail for printing and print in my puppy stretch 7.0.0a1:


Code:
#!/bin/sh
/etc/init.d/cups stop
mount --bind /dev /mnt/home/jail/dev
mount --bind /proc /mnt/home/jail/proc
mount --bind /sys /mnt/home/jail/sys
mount --bind /mnt/home/jail/var/run/cups /var/run/cups
mount --bind /mnt/home/jail/var/spool/cups /var/spool/cups 
xhost +
mount --bind /tmp/.X11-unix /mnt/home/jail/tmp/.X11-unix
mount -t tmpfs -o size=10M tmpfs /var/spool/cups
chroot /mnt/home/jail /etc/init.d/cups start


The script prepares the running of other commands in chroot using X and open the chroot jail. I can open at localhost:631 in palemoon in the main environment (puppy stretch 7.0.0a1) the cups' interface of tahr-6.0.2. Printer installed in the jail needs to be shared. To run skype4.3 previously installed in the jail:

Code:
chroot /mnt/home/jail skype4.3
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1285

PostPosted: Wed 04 Oct 2017, 11:11    Post subject:  

There is a 7.0.0a2-2 in woof-CE now that adds a few missing things (xsane opens now for instance), I'm not sure if it helps with any printing (I haven't had a printer for over a decade) but I uploaded an iso at the first commit if anyone wants to test. I think using older stuff from slacko 5.3.3 is probably seen as "going backwards" and maybe something else needs to be upgraded instead (a program or script) or maybe newer ghostscript version truly is broken and using a 9.05 pet is the only solution? Smile

There's a few entries in /usr/share/applications that have problematic %U thing in them (screenshot attached). I'm guessing there's a kind of sed command that could be added to get rid of them but need to learn more about how this command works.
capture19539.png
 Description   
 Filesize   8.12 KB
 Viewed   422 Time(s)

capture19539.png


Last edited by Sailor Enceladus on Fri 06 Oct 2017, 08:53; edited 1 time in total
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Wed 04 Oct 2017, 14:58    Post subject:  

Sailor Enceladus wrote:
There is a 7.0.0a2-2 in woof-CE now that adds a few missing things (xsane opens now for instance), I'm not sure if it helps with any printing (I haven't had a printer for over a decade) but I uploaded an iso at the first commit if anyone wants to test.


I have found in cups log file the same error of OscarTalks' build (stretch-7.0.0a1):

Code:
CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 689
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Thu 05 Oct 2017, 02:01    Post subject: Re: Non-printing Stretch Pups
Subject description: ghostscript faulty and missing link
 

davids45 wrote:
G'day watchdog,

I thought I was the only one who still wanted to use a printer in Puppyland Laughing .

I was advised how to fix the 'filter failed' problem in new Pups (32-bit) by:

1) replacing/deleting the faulty ghostscript version (numbered 9.14 or thereabouts) in woof-based Pups with an older working version (9.05, using a ghostscript_s533-9.05.pet) plus another needed pet

2) make a link in /lib called ld-lsb.so.3 to the existing ld-2.23.so file

One or both of these fixes has allowed me to print on paper with my Epson in Stretch Pups and other recent 32-bit Pups which won't print here because of these filter faults.

http://www.murga-linux.com/puppy/viewtopic.php?p=968898&search_id=751235165#968898
may help you see better what I have to do for printing although this post was about more than just printing problems.

Good luck.

David S.


Hi davids45, Thanks for the instructions!
I can confirm that your instructions fix printing in ttuuxxx debian stretch-7.0.0a1.iso for using my Brother MFC-J450DW

1. Start by removing builtin package ghostscript (it was version 9.20) Menu-->Setup-->Remove builtin packages
2. Install ghostscript_s533-9.05.pet md5= 5e1193067e0165ed83707659eea6939b
3. Install gstoraster_s533-9.05.pet md5= 997a62be9a99d223fd89fb263f1e429c
4. Install printer drivers. I used these instructions from rcrsn51 for installing my Brother Printer.
5. Then run CUPS wizard Menu-->Setup-->Cups Printer Wizard

The following steps may be driver specific
------------------------------------------------------------
5a. After installing the drivers I had to delete the USB Brother printer in CUPS (default install) and then re-install as a wireless printer lpd://BRW70188BEF51A3/BINARY_P1 in CUPS
5b. Rebooted - printer available after reboot

Don't forget to have puppy connected to your router if wireless, or have the cable plugged in if USB.

.
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 689
Location: Altair IV , Just north of Eeyore Junction.

PostPosted: Fri 06 Oct 2017, 16:42    Post subject:  

This is a remaster of ttuuxxx stretch-7.0.0a1 with the fixes/changes suggested in this thread. It is the puppy I have transitioned to, replacing Precise 5.7.1

Posting this here in the hopes of saving someone the chore of reading through this whole thread to find the fixes applied to this remaster.
This is ttuuxxx work with no changes except those listed at the bottom of this post.

The remaster is available here as stretch-7.0.0a1.r01.iso
md5 - 10839e54188d25cb1d0323493c4b6774
Size - 278.5MB
This puppy is 32-bit
All credit goes to ttuuxx & co. who developed stretch-7.0.0a1 Razz

The following changes were applied.
1. Geany config changed per musher0 suggestion
2. Delayed run bug fix when installing additional applets
3. Battery icon not showing in tray
4. Installed missing gtk hash utility that is common in puppies
5. "Fail to launch" menu fix
6. Printer filter error due to bug in ghostscript
#########################################
Edit: Two fixes to apply to improve this remaster
1. Hp and Epson printer fix pet with xsane scanner program fix.
These are the fixes provided by watchdog (1) & (2) and davids45 (1) that fix issues in this remaster. It adds 3 symlinks and 2 missing lib files.
2. gtk-dialog upgrade should be added as per suggestion from zigbert (I somehow missed this one when doing remaster)

.

Last edited by perdido on Mon 09 Oct 2017, 20:52; edited 4 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 45 of 48 [717 Posts]   Goto page: Previous 1, 2, 3, ..., 43, 44, 45, 46, 47, 48 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0973s ][ Queries: 14 (0.0228s) ][ GZIP on ]