Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 22 Oct 2017, 09:54
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
[SOLVED] OpenOrienteering - Qt plugin xcb issue
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
davids45


Joined: 26 Nov 2006
Posts: 987
Location: Chatswood, NSW

PostPosted: Thu 09 Mar 2017, 18:35    Post subject:  [SOLVED] OpenOrienteering - Qt plugin xcb issue
Subject description: Mapping and map-making software with a Linux version
 

G'day,

To those few of you who recognise my avatar as being orienteering-related (g'day zigbert)...

I read in the latest Australian orienteering magazine that there's an alternative to the Windows-based Ocad for drawing orienteering maps, Open Orienteering, which is open-source and cross-platform.

The website is http://www.openorienteering.org/

So I thought I'd give it a try in Puppy. Not surprisingly, it doesn't list Puppy in the download versions, but does have packages for Debian and Ubuntu.

I downloaded the .deb package and installed it in a Full Xenialpup-7.0.1 but found many missing .libs. So then I downloaded these missing libs one-by-one until I stopped getting missing .lib messages.

My downloaded and installed files list is shown in the screenshot.

However, OpenOrienteering now stalled with the error message in the other screenshot. I don't know what this means, or what to do next. I think I tried a re-install but don't know for sure if what I did fell into the 're-install' category Embarassed .

If someone who knows what they're doing could make a .pet or .sfs of OpenOrienteering that would be excellent Laughing , or could advise me of how to fix my last error, that would be OK too Very Happy .

Meanwhile, it's back to old Ocad and wine for me Smile , for the present.

Thanks for your time,

David S.
openo-filesloaded.png
 Description   files so far downloaded trying too run OpenOrienteering
 Filesize   32.26 KB
 Viewed   203 Time(s)

openo-filesloaded.png

openo-errormessage.png
 Description   
 Filesize   17.8 KB
 Viewed   207 Time(s)

openo-errormessage.png


Last edited by davids45 on Mon 13 Mar 2017, 19:02; edited 1 time in total
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7775
Location: World_Hub

PostPosted: Thu 09 Mar 2017, 23:17    Post subject:  

David, is that file onboard?

askubuntu.com/questions/308128/failed-to-load-platform-plugin-xcb-while-launching-qt5-app-on-linux-without
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 6493
Location: Valåmoen, Norway

PostPosted: Fri 10 Mar 2017, 04:07    Post subject: Re: OpenOrienteering - Qt plugin xcb issue
Subject description: Mapping and map-making software with a Linux version
 

davids45 wrote:
(g'day zigbert)...
Good morning David Laughing

I didn't know about openorientering. Interesting to see if you are able to get this going on Puppy. Always good news to see open source alternatives. On the other hand, Ocad (at least version 8 which is free) runs flawless on wine.

Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 3099
Location: wales

PostPosted: Fri 10 Mar 2017, 06:52    Post subject:  

hi davids45,

i think you've grabbed the wrong version of the .deb.
you should uninstall all of those .debs as they will have probably broken xenials qt5

for xenial you want the .deb from here http://download.opensuse.org/repositories/home:/dg0yt/Ubuntu_16.04/
amd64 folder for 64bit and i386 for 32bit

then from the PPM you need to install
libpolyclipping
libproj9

it then fires up for me

if you're still getting that 'xcb' error try

Code:
ldd /usr/lib/qt5/plugins/platforms/libqxcb.so
install any missing xcb stuff from the PPM & restart X
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 400
Location: Connecticut, United States

PostPosted: Fri 10 Mar 2017, 10:41    Post subject:  

wow! I got it going in Tahr 6.0.6. I used the PPM to install :
1. libQt5PrintSupport
2. libpolyclipping
3. libproj0
4. qtbase5-dev from here ->http://packages.ubuntu.com/trusty/qtbase5-dev
5. qt5-default from here ->http://packages.ubuntu.com/trusty/qt5-default (I installed it but I am not sure if this is needed).
For openorienteering-mapper I downloaded this .deb -> http://download.opensuse.org/repositories/home:/dg0yt/Ubuntu_14.04/i386/ as suggested by 666philb

Mapper showed up in Menu->Utility

Back to top
View user's profile Send private message Visit poster's website 
davids45


Joined: 26 Nov 2006
Posts: 987
Location: Chatswood, NSW

PostPosted: Fri 10 Mar 2017, 20:00    Post subject:  

G'day,

Thanks everyone who replied so quickly and with good-looking advice.

I'll use your feedback to get this program running Linuxly - I have the wine-Windows-version running already but would like to use the "right" version. Then I'll mark this thread [Solved] Very Happy .

Mapper looks quite good and reads the sport-standard Ocad files very well on a quick first try. Seems to read most versions of Ocad formats as well - I have Ocad8 but Ocad8 cannot not read files from recent Ocads (they're up to Ocad12 now which makes more use of GPS and other satellite data).
Just a few differences so far in drawing and editing maps, and with symbols handling, so I'm on a re-learning curve, once I get Mapper "properly" running.

Thanks all again,

David S.
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 400
Location: Connecticut, United States

PostPosted: Sat 11 Mar 2017, 00:33    Post subject:  

here is a SFS of OpenOrienteering_mapper.0.6.8
made in Tahr 6.0.6. A menu entry will be in Menu>Utility.

https://drive.google.com/open?id=0By2RUsFzFaMkOU1GMUh5LXVVQkk
Back to top
View user's profile Send private message Visit poster's website 
davids45


Joined: 26 Nov 2006
Posts: 987
Location: Chatswood, NSW

PostPosted: Mon 13 Mar 2017, 19:38    Post subject: Qt5 Plugin xcb fix
Subject description: OpenOrienteering 'Mapper' map-maker
 

G'day,
Thanks to all the above posters who have enabled me to fix most of the problems I came across (or made for myself no doubt) in getting this open-source orienteering map-making program running in Puppy.

I've attached a screenshot of Mapper opened with a new and unfinished map..

Semme's link in his post above to the 'ask.ubuntu' post provided a fix for several Pups that gave the xcb stumbling block I highlighted in my initial post.
The ask.ubuntu page noted a fix for a missing symlink using some CLI words & commands but I just opened two Rox windows, one at /usr/lib/qt5/plugins/platforms/ (that has the troublesome xcb lib file) and the other Rox at /usr/bin/ and symlinked (dragged) the platforms directory into the bin directory.

Sometimes a missing library file was also reported on a Pup's terminal but opening with Rox the files of an OpenOrienteering-working Pup, I just copied the libs from that to the deficient Pup.

Rockedge helped out by making an .sfs of the latest OpenOrienteering version so checking through my frugal Pups was much easier. I've listed the Pups I've found to work in his thread
http://www.murga-linux.com/puppy/viewtopic.php?t=109888.

The Pup-age limit for this Mapper program seems to be when older Pups have a libstdc++ mismatch. But there are enough good recent Pups to use if someone needs to run Mapper.

I guess as this is supposedly a serious graphics package, the 64-bit version needs to be checked out too - I just don't use many 64-bit Pups yet, and the 32-bit version is fast enough for me.

David S.
PuppEx401-Mapper.jpg
 Description   Mapper in Puppex401 - a starting urban base-map for eventual orienteering use
 Filesize   169.25 KB
 Viewed   104 Time(s)

PuppEx401-Mapper.jpg

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0436s ][ Queries: 14 (0.0040s) ][ GZIP on ]