Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 16 Oct 2017, 17:49
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
FireFox requires PulseAudio for sound; how to install?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 5 [74 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
bigpup


Joined: 11 Oct 2009
Posts: 9370
Location: Charleston S.C. USA

PostPosted: Wed 22 Mar 2017, 19:52    Post subject:  

RickGT351,

Try OscarTalks pet only.

What version of Puppy?

Have you tried to install PulseAudio?

If yes.

Do not have PulseAudio installed.

Only install OscarTalks pet.
http://www.murga-linux.com/puppy/viewtopic.php?p=947398#947398

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 4293
Location: West Lothian, Scotland, UK

PostPosted: Thu 23 Mar 2017, 07:42    Post subject:  

OscarTalks wrote:
...try installing this apulse package
http://smokey01.com/OscarTalks/apulse-0.1.8-i686-wz.pet
Then just run Firefox as normal.
Just a library so no need to start and stop daemons.
Compiled in Wheezy but tested briefly and worked in Slacko 5.7

Was running Slacko-5.7.0-pae->Firefox-52.0, and getting no sound [in youtube videos].
Installed the above .pet, and now I get sound. Very Happy
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 232

PostPosted: Thu 23 Mar 2017, 16:58    Post subject:  

The 64 bit apulse pet was also useful for getting audio on Firefox 52
in FATDOG 710 (which requires GTK3 to support Firefox). FATDOG doesn't
use pets but it offers to extract them. Then the three .SO files are copied
to the lib64 folder.

Art
Back to top
View user's profile Send private message 
RickGT351

Joined: 27 Sep 2011
Posts: 189
Location: Auckland, New Zealand

PostPosted: Thu 23 Mar 2017, 17:32    Post subject:  

Precise 5.7.1
Update I figured out why pulse audio wasn't working but got these grumpy comments too. Also no sound
Code:
# pulseaudio --system
W: [pulseaudio] main.c: Running in system mode, but --disallow-exit not set!
W: [pulseaudio] main.c: Running in system mode, but --disallow-module-loading not set!
N: [pulseaudio] main.c: Running in system mode, forcibly disabling SHM mode!
N: [pulseaudio] main.c: Running in system mode, forcibly disabling exit idle time!
W: [pulseaudio] main.c: Home directory of user 'root' is not '/var/run/pulse', ignoring.
W: [pulseaudio] main.c: OK, so you are running PA in system mode. Please note that you most likely shouldn't be doing that.
W: [pulseaudio] main.c: If you do it nonetheless then it's your own fault if things don't work as expected.
W: [pulseaudio] main.c: Please read http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode for an explanation why system mode is usually a bad idea.
W: [pulseaudio] module.c: module-detect is deprecated: Please use module-udev-detect instead of module-detect!
Back to top
View user's profile Send private message 
RickGT351

Joined: 27 Sep 2011
Posts: 189
Location: Auckland, New Zealand

PostPosted: Thu 23 Mar 2017, 19:30    Post subject:  

bigpup wrote:
RickGT351,

Try OscarTalks pet only.

What version of Puppy?

Have you tried to install PulseAudio?

If yes.

Do not have PulseAudio installed.

Only install OscarTalks pet.
http://www.murga-linux.com/puppy/viewtopic.php?p=947398#947398

Precise 5.7.1
Installed the pet, now can't play youtube videos at all. Looks like I will need to do some more experimentation

Last edited by RickGT351 on Thu 23 Mar 2017, 19:40; edited 1 time in total
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7775
Location: World_Hub

PostPosted: Thu 23 Mar 2017, 19:38    Post subject:  

Remove Pulse.
_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 9370
Location: Charleston S.C. USA

PostPosted: Fri 24 Mar 2017, 00:02    Post subject:  

As Semme says.

Make sure to remove PulseAudio.
Reboot.
Before installing the pet.

Do Not Have PulseAudio Installed.

If both are installed.
Uninstall both.
Reboot.
Install only OscarTalks pet.

If this is what you have done, than tell us?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
RickGT351

Joined: 27 Sep 2011
Posts: 189
Location: Auckland, New Zealand

PostPosted: Fri 24 Mar 2017, 09:38    Post subject:  

Precise 5.7.1
Success! Started a newsavefile, installed the latest Firefox, downladed and installed http://smokey01.com/OscarTalks/apulse-0.1.8-i686-wz.pet
Now have youtube with sound.
Thanks guys
Back to top
View user's profile Send private message 
RickGT351

Joined: 27 Sep 2011
Posts: 189
Location: Auckland, New Zealand

PostPosted: Fri 24 Mar 2017, 18:30    Post subject:  

Have just noticed. While I have sound and video, I can no longer comment on youtube. JOFTAA
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7775
Location: World_Hub

PostPosted: Fri 24 Mar 2017, 21:09    Post subject:  

Is this with or without Flash installed?
_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 232

PostPosted: Sat 25 Mar 2017, 08:25    Post subject:  

A note on browsers that use Firefox code:

Seamonkey 2.49a1 (nightly) is the first version that doesn't have audio,
and it corresponds to Firefox 50. The apulse pet fixes the issue as
expected.

Browsers such as cyberfox will also most probably lack audio after
updating, and they should respond to the apulse solution.
Back to top
View user's profile Send private message 
casePup337

Joined: 07 Mar 2017
Posts: 11
Location: Louisiana, Cajun French part USA

PostPosted: Sat 25 Mar 2017, 09:17    Post subject: Had same issue! See you later for now, Firefox52(deleted)
Subject description: lxxenial-16.08 Kernel 4.1.31
 

I know this is to get Firefox working but Firefox seems to need more work than the recent Palemoon version. Lately im using sites with JW-player(for movie sites) , flash-players(youtube), and adobe-flash(even Spotify-web) all are working well. What took the cake for me, was getting Firefox to even notice the adobe flash install, i finally got it working in Palemoon(27.2.0-32bit) and moved on! Palemoon comes with some Puppies, and its almost just like Firefox, isn't it? thanks..
03capture.png
 Description   
 Filesize   142.37 KB
 Viewed   712 Time(s)

03capture.png

Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7775
Location: World_Hub

PostPosted: Sat 25 Mar 2017, 10:23    Post subject:  

It's similar >> "What are the differences with Firefox?"
_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
casePup337

Joined: 07 Mar 2017
Posts: 11
Location: Louisiana, Cajun French part USA

PostPosted: Sat 25 Mar 2017, 10:36    Post subject:  

Thanks! I think the getflash-1.6.1.pet fixed some browser issues for me. I have more space for all my libs and dependency tweaking without Firefox now, but isn't their a fix for pulse audio in the new Firefox52? try newest flash install.
Last edited by casePup337 on Sat 25 Mar 2017, 11:42; edited 2 times in total
Back to top
View user's profile Send private message 
casePup337

Joined: 07 Mar 2017
Posts: 11
Location: Louisiana, Cajun French part USA

PostPosted: Sat 25 Mar 2017, 10:42    Post subject: Intersting forum read at bugzilla site  

oops! Rolling Eyes Thanks Semme! As you can tell, im new to quoting..Also learning how to talk on forums, besides gaming forums..
This is what link I was thinking of pertaining to Pulse audio!

https://bugzilla.mozilla.org/show_bug.cgi?format=default&id=1345661

Last edited by casePup337 on Mon 03 Apr 2017, 22:04; edited 1 time in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 5 [74 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0493s ][ Queries: 12 (0.0065s) ][ GZIP on ]