Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Apr 2017, 11:01
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How keep correct time, with dual booting Tahrpup64? (SOLVED)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Author Message
gychang


Joined: 29 Nov 2008
Posts: 174
Location: Davis, CA

PostPosted: Sun 16 Apr 2017, 19:54    Post subject:  How keep correct time, with dual booting Tahrpup64? (SOLVED)  

I have been using puppy for several years on-off, by far the best distro Very Happy Very Happy

I have to dual boot with windows since work place network allow windows connect only..., Have had similar problems with Precise, tharpup64 and PAE version. I noticed after I set the correct date-time, and HW-clock to set to software and set, everything is OK (pupclock). Several days later wrong time is shown. I do not let the internet time sync.

Am I doing something wrong?, happens with different flavors of pup and also main PC and laptop...

Last edited by gychang on Thu 20 Apr 2017, 16:15; edited 1 time in total
Back to top
View user's profile Send private message 
realwigums

Joined: 07 Apr 2017
Posts: 11

PostPosted: Mon 17 Apr 2017, 00:19    Post subject:  

setup ntpd. also ntpdate comes with the ntpd so you can manually adjust time
as well.
Back to top
View user's profile Send private message Visit poster's website 
bigpup


Joined: 11 Oct 2009
Posts: 8586
Location: Charleston S.C. USA

PostPosted: Mon 17 Apr 2017, 07:44    Post subject:  

Are you setting it to a specific time zone?
Example:
US/Pacific

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
gychang


Joined: 29 Nov 2008
Posts: 174
Location: Davis, CA

PostPosted: Mon 17 Apr 2017, 07:48    Post subject:  

bigpup wrote:
Are you setting it to a specific time zone?
Example:
US/Pacific


Yes I have setup the time zone already, seems to run about 7 hours ahead next time when I reboot...
Back to top
View user's profile Send private message 
gychang


Joined: 29 Nov 2008
Posts: 174
Location: Davis, CA

PostPosted: Mon 17 Apr 2017, 07:50    Post subject:  

realwigums wrote:
setup ntpd. also ntpdate comes with the ntpd so you can manually adjust time
as well.


not sure how to do this, I manually setup using pupclockset manager as I stated.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 8586
Location: Charleston S.C. USA

PostPosted: Mon 17 Apr 2017, 07:53    Post subject:  

What version of Tahrpup64?

It works OK in Windows?

The calendar date is set correctly?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Burn_IT


Joined: 12 Aug 2006
Posts: 2733
Location: Tamworth UK

PostPosted: Mon 17 Apr 2017, 08:05    Post subject:  

Is it adjusting for summer time twice???
_________________
"Just think of it as leaving early to avoid the rush" - T Pratchett
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 122

PostPosted: Mon 17 Apr 2017, 12:02    Post subject:  

gychang wrote:
bigpup wrote:
Are you setting it to a specific time zone?
Example:
US/Pacific


Yes I have setup the time zone already, seems to run about 7 hours ahead next time when I reboot...


Specify exactly which time zone you have set. Do not use GMT time zones. Use named zones like bigpup suggested.
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 714

PostPosted: Mon 17 Apr 2017, 14:43    Post subject:  

This is the conflict between the hardware clock being set to local time (the puppy/windows default) and the hardware clock being set to UTC time (the debian default and a lot of other linux systems).

There is a checkbox on the first run/quick setup screen that appears when you open Puppy for the first time that says "Set hardware clock to UTC" that is unchecked by default.

Run the quick setup again from the menu and change that checkbox. If it is checked, then uncheck it. If it is unchecked, then check it. That will solve your problem.

I attached the explanation if you click the "i" button next to the checkmark.
capture18619.png
 Description   
 Filesize   27.16 KB
 Viewed   150 Time(s)

capture18619.png

Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10013
Location: Gatineau (Qc), Canada

PostPosted: Mon 17 Apr 2017, 14:46    Post subject:  

Hi, gychang and all.

I solved my similar problem with the attached ntp simple package.

I compiled the entire ntp server package for Puppy Stretch and extracted
this smaller utility for everyday use.

This will work on Puppies with a glibc or ldd of 2.24. If there is a request
I'll compile it again, but on a lesser glibc.

This is the list of files in the attached pet:
Quote:
.
[4.0K] ./etc
[ 100] ./etc/ntp.conf
[ 132] ./pet.specs
[4.0K] ./root
[4.0K] ./root/Startup
[ 852] ./root/Startup/zz-ntp-sync.sh
[4.0K] ./usr
[4.0K] ./usr/bin
[2.8K] ./usr/bin/calc_tickadj
[800K] ./usr/bin/ntpd
[ 82K] ./usr/bin/ntpdate
[231K] ./usr/bin/ntpdc
[169K] ./usr/bin/ntp-keygen
[267K] ./usr/bin/ntpq
[ 17K] ./usr/bin/ntptime
[3.5K] ./usr/bin/ntptrace
[3.1K] ./usr/bin/ntp-wait
[201K] ./usr/bin/sntp
[5.3K] ./usr/bin/tickadj
[ 11K] ./usr/bin/update-leap
[4.0K] ./usr/share
[4.0K] ./usr/share/man
[4.0K] ./usr/share/man/man1
[3.1K] ./usr/share/man/man1/calc_tickadj.1
[ 32K] ./usr/share/man/man1/ntpd.1
[ 28K] ./usr/share/man/man1/ntpdc.1
[ 43K] ./usr/share/man/man1/ntp-keygen.1
[ 36K] ./usr/share/man/man1/ntpq.1
[3.6K] ./usr/share/man/man1/ntptrace.1
[3.4K] ./usr/share/man/man1/ntp-wait.1
[ 12K] ./usr/share/man/man1/sntp.1
[5.0K] ./usr/share/man/man1/update-leap.1
[4.0K] ./usr/share/man/man5
[105K] ./usr/share/man/man5/ntp.conf.5
[3.7K] ./usr/share/man/man5/ntp.keys.5
[4.0K] ./usr/share/ntp
[4.0K] ./usr/share/ntp/lib
[4.0K] ./usr/share/ntp/lib/NTP
[3.7K] ./usr/share/ntp/lib/NTP/Util.pm
[4.0K] ./var
[4.0K] ./var/lib
[4.0K] ./var/lib/ntp
[ 88] ./var/lib/ntp/ntp.drift

In /etc/ntp.conf, you should have a config file like this:
Quote:
server 0.ca.pool.ntp.org
server 1.ca.pool.ntp.org
server 2.ca.pool.ntp.org
server 3.ca.pool.ntp.org
Notice the 2-letter country code after the server number.
Change it to the code for your country: us, uk, it, fr, whatever it is.

You also have a "general pool" file at /var/lib/ntp/ntp.drift:
Quote:
server 0.pool.ntp.org
server 1.pool.ntp.org
server 2.pool.ntp.org
server 3.pool.ntp.org

This one sort of "informs" the ntp.conf file in /etc. You need both. Don't
touch this one. I'm just telling you what it does: it looks for the pool of ntp
servers in your country and selects one for your use.

The attached pet also has a launch file in /root/Startup prefixed "zz" so it
launches as the last exec in the Startup dir. This is because ntpdate can
take a few minutes to hook up to a time server in your country and then
update the time on your machine: we do not want to put the loading of the
other Startup apps on pause while ntpdate is searching for a connection.

Finally, make sure your hardware time (hwtime; please see dancytron's
post above) is set to "local time".

IHTH.
ntp-4.2.8p10_simple.pet
Description 
pet

 Download 
Filename  ntp-4.2.8p10_simple.pet 
Filesize  64.66 KB 
Downloaded  1 Time(s) 

_________________
musher0
~~~~~~~~~~
« Un insensé sur le trône n'est qu'un singe sur le haut d'un toit. » / "A madman
on the throne is just a monkey on top of a roof." (Bernard de Clervaux)
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 122

PostPosted: Mon 17 Apr 2017, 16:14    Post subject:  

Time zone config is buggy in Puppy Linux.

Been a long-standing minor bug with Puppy Linux. Need to either fix or remove the GMT zones, and certainly should not be the default.(just confuses new users) Workarounds can be done but root cause remains.
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 10013
Location: Gatineau (Qc), Canada

PostPosted: Mon 17 Apr 2017, 16:22    Post subject:  

Hi jd7654.

I'm sorry to hear that.

I'll touch wood, but it's been two weeks since I've been using my
nptdate_simple pet package and I've had no problems so far. Aside from
some delay when the servers in my country are very busy -- which is a
rare occurrence.

Maybe using this ntpdate package can solve the problem for you too?

IHTH.

_________________
musher0
~~~~~~~~~~
« Un insensé sur le trône n'est qu'un singe sur le haut d'un toit. » / "A madman
on the throne is just a monkey on top of a roof." (Bernard de Clervaux)
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 122

PostPosted: Mon 17 Apr 2017, 16:45    Post subject:  

musher0 wrote:
Maybe using this ntpdate package can solve the problem for you too?


I don't have a problem with time config. Just relaying the bug to OP, et al.
Solution is simply to NOT use GMT zones like GMT-8, and use named zone like US/Pacific instead.
Back to top
View user's profile Send private message 
gychang


Joined: 29 Nov 2008
Posts: 174
Location: Davis, CA

PostPosted: Mon 17 Apr 2017, 19:41    Post subject:  

bigpup wrote:
What version of Tahrpup64?

It works OK in Windows?

The calendar date is set correctly?


I use Tahrpup64, 6.0.5 ?latest version

I rarely use windows but will check next time.

usually in puppy, time is about 7 hours ahead (time zone America/LosAngeles)
Back to top
View user's profile Send private message 
gychang


Joined: 29 Nov 2008
Posts: 174
Location: Davis, CA

PostPosted: Mon 17 Apr 2017, 19:46    Post subject:  

dancytron wrote:
This is the conflict between the hardware clock being set to local time (the puppy/windows default) and the hardware clock being set to UTC time (the debian default and a lot of other linux systems).

There is a checkbox on the first run/quick setup screen that appears when you open Puppy for the first time that says "Set hardware clock to UTC" that is unchecked by default.

Run the quick setup again from the menu and change that checkbox. If it is checked, then uncheck it. If it is unchecked, then check it. That will solve your problem.

I attached the explanation if you click the "i" button next to the checkmark.


as you suggested quick setup, it was unchecked so I checked it. (attached photo). The photo shows about 11PM but actual time is 4PM (so puppy runs about 7 hrs ahead). I set the correct time using pupclockset manager manually.

will see if that solved the problem as u suggest, thanks.
time1.jpg
 Description   I check the box, I as shown and manually set the correct time to around 4PM
 Filesize   51.78 KB
 Viewed   74 Time(s)

time1.jpg

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0616s ][ Queries: 12 (0.0046s) ][ GZIP on ]