Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 18 Dec 2017, 16:42
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Qt 5.6.1-1 for Slacko 700
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
norgo


Joined: 13 Nov 2015
Posts: 169
Location: Germany

PostPosted: Thu 04 May 2017, 12:48    Post subject:  Qt 5.6.1-1 for Slacko 700  

Qt version 5.6.1-1

Compiled under use of:
Slacko 700 Beta 2 testing branch 2017-01-17
Slacko64 700 RC3 testing branch 2017-06-13

Qt4 is totally outdated and it becomes more and more difficult to compile newer applications using qt4.
So I decided to compile qt5 from source.
I built single packages of the most important modules.
So you have to install only the packages which are really needed by the application.
This saves a lot of space.
If you are missing a package please let me know.
I decided for this qt version to get a maximum of compatibility to Slackware 14.2 packages.

Packages are only for the purpose to run qt5 applications,
they doesn't contain any kind of header files or stuff to build applications.

Packages can be downloaded here

Here the configuration I used to build qt5 from source:
( update: build script for 64 bit version added, PET's in progress )
qt_561-1_build_slk700_32_and_64.tar
Description  qt 5.6.1 build scripts
tar

 Download 
Filename  qt_561-1_build_slk700_32_and_64.tar 
Filesize  10 KB 
Downloaded  11 Time(s) 

Last edited by norgo on Thu 02 Nov 2017, 11:38; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 05 Jun 2017, 15:07    Post subject: "Qt4 is totally outdated"  

"Qt4 is totally outdated" Unfortunately... and most of Qt-apps are unserviceable..
They are missing devs.. Qt is appreciated by Germans, as KDE. Qt apps please me as Symphytum, association sucribers. But i must say that in our forum, it's a Flop.. (flop is english word?).
I hope that some Puppy-builder will remasterise the Pemasu's PolarQt005 Puppy. It could be done with tarpup as Qt libs are included. I suggested it but with no success. That would have changed our puppies.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
norgo


Joined: 13 Nov 2015
Posts: 169
Location: Germany

PostPosted: Mon 05 Jun 2017, 15:51    Post subject: Re: "Qt4 is totally outdated"  

Pelo wrote:
...Qt is appreciated by Germans, as KDE. Qt apps please me as Symphytum, association sucribers. But i must say that in our forum, it's a Flop..

@Pelo
The number of downloads tell me another story ...
There are really a lot of qt applications I don’t want to do without.
To build a distro containing all qt libs is not a good idea in my opinion.
This would make the distro quite large.
In my opinion it's the better way to install only the qt modules which are really needed to run the desired applications.
That's why I split up qt into single modules.
Back to top
View user's profile Send private message Visit poster's website 
norgo


Joined: 13 Nov 2015
Posts: 169
Location: Germany

PostPosted: Fri 01 Dec 2017, 22:07    Post subject: Qt 5.6.1 ( 64bit version )  

Qt-5.6.1-1 for Slacko 700 ( 64bit ) now available here

For information see main post.
I uploaded not all but the most important modules.
If you miss a component please let me know.
Back to top
View user's profile Send private message Visit poster's website 
frenchiveruti

Joined: 15 Feb 2017
Posts: 93

PostPosted: Sun 03 Dec 2017, 00:12    Post subject:  

Thanks a lot! Do you think you can do the same for XenialPup?
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 169
Location: Germany

PostPosted: Wed 06 Dec 2017, 18:37    Post subject:  

@frenchiveruti

as far as I know, XenialPup has the old qt4 installed by default
but qt5 should be installable via PPM without problems.
Regarding your question you better ask @scabz instead, he is the right contact person for Qt for Ubuntu derivates.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0635s ][ Queries: 12 (0.0076s) ][ GZIP on ]