Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 28 Jun 2017, 23:52
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
HDMI and alsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
Wognath

Joined: 19 Apr 2009
Posts: 392

PostPosted: Tue 09 May 2017, 14:58    Post subject:  HDMI and alsa  

I recently got a new laptop and had my first experience with hdmi. Since it took me a while to stumble on the right commands, I thought it might save someone some time to post what worked.

Video worked right away (after turning it on with lxrandr) but sound was frustrating. One problem is that alsa-hdmi randomly starts up muted. (You're right, I'm probably doing something stupid, but since I don't know what it is, it's random to me Confused)
Flash wrote:
When I choose the HDMI option from alsamixer's F6 menu, the alsamixer window shows S/PDIF with a little box above it that has MM in it. I have to hit the M key to toggle MM (mute) to 00,
(link) Many thanks! I might have figured it out for myself in another 6 months or so. Another thing I found out the hard way: sound card must be set before starting vlc, browser, etc.

My goal was for switchover to hdmi to be done by a script that starts a video streaming service from the local library. Preliminaries:
    # alsamixer [F6, set to hdmi card]
    # cp /root/.asoundrc /root/.asoundrc-hdmi [save a copy]
    # amixer -c 0 scontrols [list simple controls available with card 0]
    Simple mixer control 'PCM',0
    Simple mixer control 'IEC958',0 [By elimination, this one corresponds to the mute]
    Simple mixer control 'SoftPCM',0
    # xrandr -q [find name of HDMI screen]

Based on that info, my script has these lines to get hdmi up:
Code:
xrandr --output HDMI-0 --auto  #switch on HDMI output
cp -f /root/.asoundrc-hdmi /root/spot/.asoundrc  # spot uses hdmi sound card, root unchanged
amixer -c 0 set IEC958 unmute   # make sure it's not muted
run-as-spot browser "--options" "website"

If you know a better way to do this, or any good tips, please post.

alsa wiki
HP 14-an013nr, Fatdog 710 temporarily booting from flash drive
Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio. Driver: snd_hda_intel
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0275s ][ Queries: 13 (0.0057s) ][ GZIP on ]