Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 13:00
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Blobwars needs missing library
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
chubby

Joined: 07 Sep 2006
Posts: 7

PostPosted: Fri 15 Sep 2006, 07:17    Post_subject:  Blobwars needs missing library  

Hi!

Hopely this is the right place to ask this. I have installed blobwars from there: http://dotpups.de/dotpups/ and when I try to play it, this is what I get:

Code:
sh-3.1# ./play-blobwars2
*** DEBUG (-1340768627): Pak : Filename set to blobAndConquer.pak
*** DEBUG (-1340768627): LocaleManager::setLanguage - en
*** DEBUG (-1340768624): loadData() : Loaded data/locale/index (84)
*** DEBUG (-1340768623): initSystem()
*** DEBUG (-1340768623): Loading locale data from 'data/locale/system'
*** DEBUG (-1340768623): loadData() : Loaded data/locale/system (181)
*** DEBUG (-1340768623): Setting System Properties to Locale Manager...
*** DEBUG (0): Graphics::getAvailableScreenModes()
*** DEBUG (0): User Home = /root/.parallelrealities/blobAndConquer
*** DEBUG (0): Graphics::setResolution() - 0: 1024 x 768
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Couldn't set 1024x768 video mode: Couldn't find matching GLX visual
*** DEBUG (0): Cleaning Up...
*** DEBUG (0): Deleting Tracer...
*** DEBUG (0): Remove Locale Data...
*** DEBUG (0): Freeing Audio...
*** DEBUG (0): Removing Music...
*** DEBUG (0): Saving Config...
*** DEBUG (0): Removing Font File...
*** DEBUG (0): Removing PAK File Data...
*** DEBUG (0): Closing Audio...
*** DEBUG (0): Freeing Game Data...
*** DEBUG (0): Freeing Remaining Entities...
*** DEBUG (0): Freeing Widgets...
*** DEBUG (0): Freeing Sprites and Fonts
*** DEBUG (0): Freeing Textures...
*** DEBUG (0): Freeing Models...
*** DEBUG (0): Closing TTF...
*** DEBUG (0): Closing SDL Sub System...
*** DEBUG (3): All Done.
sh-3.1#


It seems that there is a missing Xlib extension GLX, but I don't know where to look for to find it... Please, help me if you know what to do to make this game to work...

I'm using puppy 2.02.

-c
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 15 Sep 2006, 10:16    Post_subject:  

Install glx in Puppy 2.02 with:
http://www.murga.org/~puppy/viewtopic.php?t=8661
It is in the "openGL".

More info on blobwars:
http://www.murga.org/~puppy/viewtopic.php?t=7922

Meanwhile version 0.4 was released, but I made no dotpup yet.

Mark
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0493s ][ Queries: 11 (0.0110s) ][ GZIP on ]