Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Oct 2018, 07:19
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko-700 rc3
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 28 of 31 [464 Posts]   Goto page: Previous 1, 2, 3, ..., 26, 27, 28, 29, 30, 31 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 3489
Location: Worcestershire, UK

PostPosted: Sat 24 Mar 2018, 14:34    Post subject:  

Delete it and download:
http://distro.ibiblio.org/puppylinux/Packages-puppy-common-official

0setup should do this for you.....

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1546

PostPosted: Sun 01 Apr 2018, 12:55    Post subject:  

I tried a Slacko64 build with the latest woof-CE when at my parents for Easter on my dad's Core2Duo laptop. Here's the iso:
http://www.mediafire.com/folder/y13kxdldb9i9d/x86_64

It seems to be working ok so far on it, I didn't need anything from puppy-common this time either. These comments also apply to it:

Quote:
- The adrv has Firefox 52.7.3esr and Abi/Gnumeric
- chose Original Pup as the default theme, and gnome-mplayer as the default music player
- kernel has firmware-140621-cut, if you are missing any drivers/functionality there's instructions on how to swap kernels here
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3577
Location: Ontario Canada

PostPosted: Mon 02 Apr 2018, 04:04    Post subject:  

@Sailor

I installed to the hard drive of my Acer desktop:

System: Host: puppypc14078 Kernel: 4.4.126 x86_64 (64 bit) Desktop: JWM 2.3.2 Distro: Slacko64 Puppy 6.9.9.9
Machine: Device: desktop System: ACER product: Aspire M5620 v: R01-A4 serial: PTS860X0348050CF642700
Mobo: ACER model: G33T-AM v: 1.0 serial: 00000000 BIOS: American Megatrends v: R01-A4 date: 12/19/2007
CPU: Quad core Intel Core2 Quad Q6600 (-MCP-) speed/max: 1603/2403 MHz
Network: Card: Intel 82566DC-2 Gigabit Network Connection driver: e1000e
Drives: HDD Total Size: 500.1GB (3.6% used)
Info: Processes: 184 Uptime: 1:08 Memory: 419.4/7984.8MB Client: Shell (bash) inxi: 2.3.8
X Server: Xorg Driver: nvidia
X.Org version: 1.18.3
dimensions: 3840x1080 pixels (1049x292 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 430/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 384.130

Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Core 0: @1870 1: @1603 2: @1870 3: @1870 MHz

I installed applications with PPM,installed the proprietary Nvidia
driver, and compiled Smplayer/Smtube.

Works great,
Thanks.

Edit: I've done 2 more hard drive installs, pc1 has newer intel graphics, pc2 has ati radeon graphics.

It's working well on both new installs.
screenshot.jpg
 Description   
 Filesize   95.54 KB
 Viewed   1973 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
foxpup


Joined: 29 Jul 2016
Posts: 571
Location: europa near northsea

PostPosted: Sat 07 Apr 2018, 16:33    Post subject: slacko hangs on i5 machine  

Sailor Enceladus wrote:
I tried a Slacko64 build with the latest woof-CE when at my parents for Easter on my dad's Core2Duo laptop. Here's the iso
I installed it on my dualcore and it works very nice.

I also installed it on my i5 laptop.
Startup seems to hang there between loading modules and starting X. It comes through eventually. I send you xerrs.log and my system specs in case you want to look into this.
When I try to startup with the savefile, it really hangs.
I have not yet tried to switch kernels. I may go for the 4.9.30 from 01micko and see wat happens.
errs+sys.zip
Description 
zip

 Download 
Filename  errs+sys.zip 
Filesize  4.49 KB 
Downloaded  73 Time(s) 
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 359
Location: S.E Australia

PostPosted: Wed 11 Apr 2018, 05:41    Post subject:  

@Sailor - thanks for this puplet. I used your 4.4.126 kernel in LXpupsc64 18.03 - faster than 4.15 kernels, but still covered for spectre/meltdown.

@Foxpup - last time I had that happen, missing firmware was the culprit.
Back to top
View user's profile Send private message 
foxpup


Joined: 29 Jul 2016
Posts: 571
Location: europa near northsea

PostPosted: Thu 12 Apr 2018, 05:18    Post subject:  

ozsouth wrote:
@Foxpup - last time I had that happen, missing firmware was the culprit.
I switched kernel and zdrv and now it runs very nicely.
You could be right ozsouth, but I don't know which. It may be a kernel specific driver that needs compiling. Is there an easy way to know? Can I see it in some log file?

On my dualcore this slacko with the original kernel has now effectively replaced a heavily remastered Tahr 6.0.2 as my main workhorse.

Is slacko not ready for a release? Wouldn't it be nice if slacko, dpup (radky) and upupBB (peebee) released all together !?
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 271
Location: Germany

PostPosted: Thu 12 Apr 2018, 12:52    Post subject: Slacko 700 RC3 K4.4.70-PAE  

Here the 32 bit version of Slacko 700 RC3 snapshot for testing.
Used kernel version K 4.4.70-PAE

BUILD_FROM_WOOF='testing;6d5d2531;2018-04-05 13:45:04 +0300'

Looks really good, didn't find seriously errors up to now except these blemishes

- pkeys=de will be ignored ( I'm using ISOBOOTER )
- empty tables of contents of developer tools remain in packages/builtin_files ( 0 byte files )
- menu entry xcalc present but application not installed

slacko-700-RC3_k4.4.70-PAE_2018-04-05.iso

size: 281 M
md5: 16d38a00df3318e93a979463f9d150a9

Many thanks for this great Distro
Back to top
View user's profile Send private message Visit poster's website 
gyro

Joined: 28 Oct 2008
Posts: 1551
Location: Brisbane, Australia

PostPosted: Fri 13 Apr 2018, 20:00    Post subject: Re: Slacko 700 RC3 K4.4.70-PAE  

norgo wrote:
- pkeys=de will be ignored ( I'm using ISOBOOTER )
Do you answer 'y' or 'n' to the isobooter "splash screen" question?
Answering 'n' means it boots using the files in the iso rather than booting the iso itself.
Then adding boot parameters in "menu.lst" should work.

gyro
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 271
Location: Germany

PostPosted: Fri 13 Apr 2018, 20:32    Post subject: Re: Slacko 700 RC3 K4.4.70-PAE  

gyro wrote:
Do you answer 'y' or 'n' to the isobooter "splash screen" question?
Answering 'n' means it boots using the files in the iso rather than booting the iso itself.
Then adding boot parameters in "menu.lst" should work.

Hello gyro,
yes I'm using isobooter with "splash screen" and "menu.lst" contains already the boot parameter pkeys=de

here a snippet of my "menu.lst"
Code:
title SLACKO  32 700 RC3 K4.4.70-PAE 2017-12-10 DEVELOPMENT
partnew (hd0,3) 0x00 (hd0,0)/slacko-700-RC3_k4.4.70-PAE_2017-12-10.iso
map --heads=0 --sectors-per-track=0 (hd0,0)/slacko-700-RC3_k4.4.70-PAE_2017-12-10.iso (0xff)
map --hook
root (0xff)
kernel /vmlinuz pmedia=cd psavemark=2 pfix=ram pkeys=de
initrd /initrd.gz

title SLACKO  32 700 RC3 K4.4.70-PAE 2018-04-05 DEVELOPMENT
partnew (hd0,3) 0x00 (hd0,0)/slacko-700-RC3_k4.4.70-PAE_2018-04-05.iso
map --heads=0 --sectors-per-track=0 (hd0,0)/slacko-700-RC3_k4.4.70-PAE_2018-04-05.iso (0xff)
map --hook
root (0xff)
kernel /vmlinuz pmedia=cd psavemark=2 pfix=ram pkeys=de
initrd /initrd.gz

title SLACKO  64 700 RC3 K4.9.30
partnew (hd0,3) 0x00 (hd0,0)/slacko64-6.9.9.9-uefi-k4.9-FF-LO.iso
map --heads=0 --sectors-per-track=0 (hd0,0)/slacko64-6.9.9.9-uefi-k4.9-FF-LO.iso (0xff)
map --hook
root (0xff)
kernel /vmlinuz pmedia=cd psavemark=2 pfix=ram intel_pstate=disable pkeys=de
initrd /initrd.gz

the other versions are working without problems
Back to top
View user's profile Send private message Visit poster's website 
foxpup


Joined: 29 Jul 2016
Posts: 571
Location: europa near northsea

PostPosted: Sat 14 Apr 2018, 11:29    Post subject: Re: Slacko 700 RC3 K4.4.70-PAE  

norgo wrote:
Here the 32 bit version of Slacko 700 RC3 snapshot for testing.
Used kernel version K 4.4.70-PAE

BUILD_FROM_WOOF='testing;6d5d2531;2018-04-05 13:45:04 +0300'

Looks really good, didn't find seriously errors up to now except these blemishes

- pkeys=de will be ignored ( I'm using ISOBOOTER )
- empty tables of contents of developer tools remain in packages/builtin_files ( 0 byte files )
- menu entry xcalc present but application not installed
Norgo, thank you for this new build. Now I have a recent slacko32 as well to test with.
I have installed yours on my dualcore PC and found it works well
I took kernel sources and devx from micko's build and compiled the 304.137 nvidia driver for my graphic card.

I use pkeys=be-latin1. It is all right on the prompt (nox) but it has to be setup again for X (be), as in most Puppies. No problem.
I install frugally by copying the Puppy files into a directory and adding lines to the menu.lst for grub4dos.

Confirmation on the other blemishes.
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 271
Location: Germany

PostPosted: Sat 14 Apr 2018, 19:33    Post subject:  

Hello foxpup,

thank you for feedback.

update:
My search for the reason of pkeys issue ends up here
Seems to be a feature now Wink
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3489
Location: Worcestershire, UK

PostPosted: Mon 16 Apr 2018, 13:57    Post subject:  

norgo wrote:
Hello foxpup,

thank you for feedback.

update:
My search for the reason of pkeys issue ends up here
Seems to be a feature now Wink

see:
https://github.com/puppylinux-woof-CE/woof-CE/commit/d553a8cfd71b4f13f2ece47819a91edd2d476e2e
Quote:
fixes for keymap-set and xkbconfigmanager

improve symbiotic relationship and throw xorgwizard-automatic into the mix

hopefully this fixes the pkeys= issue reported by @peabee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
norgo


Joined: 13 Nov 2015
Posts: 271
Location: Germany

PostPosted: Mon 16 Apr 2018, 14:47    Post subject:  

@peebee

hey peebee you already knew this.
I only read your post at github today, thank you for report.

I patched slacko-700-RC3_k4.4.70-PAE_2018-04-05.iso by the changes of commit d553a8c for test.

slacko-700-RC3_k4.4.70-PAE_2018-04-05_d553a8c-patched.iso
size: 281 M
md5: a7bed9a8abad39a4874c0e8ed3cd7cbb

Up to now no problems at all.

wdlkmpx you are awesome !
Back to top
View user's profile Send private message Visit poster's website 
Dry Falls

Joined: 16 Dec 2014
Posts: 571
Location: Upper Columbia

PostPosted: Thu 26 Apr 2018, 20:36    Post subject: ifactive  

Frisbee in /usr/sbin/ifactive should be changed to all lower case in script ('Frisbee' -> 'frisbee') to work with the frisbee installed in Slacko64. Also, sections on frisbee-tray might be removed, as it's not present or used in this version. If this is part of woofCE, someone should commit the change. If it was just lifted out of lighthouse for this build, just change the script.

Here's the fixed one (still has ref to frisbee-tray):
ifactive.gz
Description  fakegz
gz

 Download 
Filename  ifactive.gz 
Filesize  3.23 KB 
Downloaded  111 Time(s) 
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 359
Location: S.E Australia

PostPosted: Fri 27 Apr 2018, 04:12    Post subject: 64 bit kernel  

I've made a 64bit Slacko compatible 4.9.94 kernel via Puppy kernel-kit, with the cutdown firmware option. Is Spectre/Meltdown mitigated. Have swapped it into Slacko64 6.9.9.9 and LxpupSc64 18.03. Works ok in both.
See: http://murga-linux.com/puppy/viewtopic.php?p=989955#989955
.

Last edited by ozsouth on Tue 01 May 2018, 20:16; edited 5 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 28 of 31 [464 Posts]   Goto page: Previous 1, 2, 3, ..., 26, 27, 28, 29, 30, 31 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0699s ][ Queries: 12 (0.0155s) ][ GZIP on ]